summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2014-01-01 13:04:00 -0800
committerMatt Turner <mattst88@gmail.com>2014-01-01 13:04:00 -0800
commitd1e3827c54e66adcf78e55286934d1a7d9d58f02 (patch)
treee9110fcd4852cc7efc311c2d8c2cf28b36537740 /x11-drivers
parentx11-libs/libxkbcommon: migrate to multilib, git-r3, bump 0.3.1-r1, fix git url (diff)
downloadx11-d1e3827c54e66adcf78e55286934d1a7d9d58f02.tar.gz
x11-d1e3827c54e66adcf78e55286934d1a7d9d58f02.tar.bz2
x11-d1e3827c54e66adcf78e55286934d1a7d9d58f02.zip
x11-drivers/xf86-input-evdev: Check for INPUT_EVDEV.
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-evdev/xf86-input-evdev-9999.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/x11-drivers/xf86-input-evdev/xf86-input-evdev-9999.ebuild b/x11-drivers/xf86-input-evdev/xf86-input-evdev-9999.ebuild
index 338e670e..ff7a5fe1 100644
--- a/x11-drivers/xf86-input-evdev/xf86-input-evdev-9999.ebuild
+++ b/x11-drivers/xf86-input-evdev/xf86-input-evdev-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=5
-inherit xorg-2
+inherit linux-info xorg-2
DESCRIPTION="Generic Linux input driver"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
@@ -15,3 +15,10 @@ RDEPEND=">=x11-base/xorg-server-1.12[udev]
DEPEND="${RDEPEND}
>=x11-proto/inputproto-2.1.99.3
>=sys-kernel/linux-headers-2.6"
+
+pkg_pretend() {
+ if use kernel_linux ; then
+ CONFIG_CHECK="INPUT_EVDEV"
+ fi
+ check_extra_config
+}