summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2008-01-12 16:07:49 +0000
committerMike Auty <ikelos@gentoo.org>2008-01-12 16:07:49 +0000
commit16c3472c0929fca31755b4618a2b18cb5c82de4b (patch)
tree21e1d1b99c2cfd16d7fd6ed4d8be26bcb8587a2f /eclass
parentFix typo. (diff)
downloadvmware-16c3472c0929fca31755b4618a2b18cb5c82de4b.tar.gz
vmware-16c3472c0929fca31755b4618a2b18cb5c82de4b.tar.bz2
vmware-16c3472c0929fca31755b4618a2b18cb5c82de4b.zip
Apply the linux header patch to all -r1 ebuilds.
svn path=/trunk/; revision=239
Diffstat (limited to 'eclass')
-rw-r--r--eclass/vmware-mod.eclass11
1 files changed, 8 insertions, 3 deletions
diff --git a/eclass/vmware-mod.eclass b/eclass/vmware-mod.eclass
index 97b8cea..4ee250c 100644
--- a/eclass/vmware-mod.eclass
+++ b/eclass/vmware-mod.eclass
@@ -76,9 +76,11 @@ vmware-mod_src_unpack() {
cd "${S}"/${mod}-only
# Ensure it's not used
# rm getversion.pl
- EPATCH_SUFFIX="patch"
- epatch "${FILESDIR}"/patches
- [[ -d "${FILESDIR}"/patches/${mod} ]] && epatch "${FILESDIR}"/patches/${mod}
+ if [[ "${VMWARE_MOD_DIR}" = "${ANY_ANY}" ]] ; then
+ EPATCH_SUFFIX="patch"
+ epatch "${FILESDIR}"/patches
+ [[ -d "${FILESDIR}"/patches/${mod} ]] && epatch "${FILESDIR}"/patches/${mod}
+ fi
convert_to_m "${S}"/${mod}-only/Makefile
done
}
@@ -112,3 +114,6 @@ vmware-mod_src_install() {
# 'VME_V55' = .13
# 'VME_S1B1' = .14
# 'VME_S1??' = .15
+# 'VME_V6' = .16
+# 'VME_V6' = .17 (6.0.2)
+# 'VME_S2B1' = .18