summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2008-12-26 21:43:48 +0000
committerSebastian Pipping <sping@gentoo.org>2008-12-26 21:43:48 +0000
commit93fa1b5a75134bddc31e26d3536c7757c9902086 (patch)
tree705b029e9e9915fb9537067ab41d46f2e671f150 /dev-util/colormake
parentdev-java/fec: Revert previous commit (diff)
downloadsunrise-93fa1b5a75134bddc31e26d3536c7757c9902086.tar.gz
sunrise-93fa1b5a75134bddc31e26d3536c7757c9902086.tar.bz2
sunrise-93fa1b5a75134bddc31e26d3536c7757c9902086.zip
dev-util/colormake: Add colormake-0.2 ebuild
svn path=/sunrise/; revision=7535
Diffstat (limited to 'dev-util/colormake')
-rw-r--r--dev-util/colormake/ChangeLog8
-rw-r--r--dev-util/colormake/Manifest5
-rw-r--r--dev-util/colormake/colormake-0.2.ebuild28
-rw-r--r--dev-util/colormake/files/colormake-0.2-disable-broken-tagging.patch20
-rw-r--r--dev-util/colormake/metadata.xml5
5 files changed, 66 insertions, 0 deletions
diff --git a/dev-util/colormake/ChangeLog b/dev-util/colormake/ChangeLog
new file mode 100644
index 000000000..00d0da55e
--- /dev/null
+++ b/dev-util/colormake/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-util/colormake
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 26 Dec 2008; Sebastian Pipping (sping) <sebastian@pipping.org>
+ +colormake-0.2.ebuild, +files/colormake-0.2-disable-broken-tagging.patch,
+ +metadata.xml:
+ Add colormake-0.2 ebuild
diff --git a/dev-util/colormake/Manifest b/dev-util/colormake/Manifest
new file mode 100644
index 000000000..257170025
--- /dev/null
+++ b/dev-util/colormake/Manifest
@@ -0,0 +1,5 @@
+AUX colormake-0.2-disable-broken-tagging.patch 661 RMD160 c9cee92d1a83b3696ec2ee75ef037ab4734112b8 SHA1 5e2fde865ffe028f5bfea6cb69fd938b5671105c SHA256 b61d0262b8a69edf7c20b07c5698122a35ad251ea5e542bd9926a622daefa944
+DIST colormake-0.2.tar.gz 9871 RMD160 b39e22de6ed72a5874af56e2fc46774a9452af4d SHA1 d24e1cd27c121aba86b1610616848228eebd1393 SHA256 8e7cc49acbc2b9b52ce2d87993f709e6813f0ba3aff0b0bbe7630c3a24aff969
+EBUILD colormake-0.2.ebuild 599 RMD160 04acca0192c34f57c6e8af4b75ae81fb0f316c7a SHA1 41cc7bd5a41092852dfb8c680396dc30c2c4b0bd SHA256 65f758bc988f82be5eed546fa0e41bfdd709efb269724b5a937afe3ac2f87226
+MISC ChangeLog 304 RMD160 dc9a83f8b499c5d33cf329fe1b50f073d2c1c645 SHA1 937c83f36d49af24af161ec2ce6d1fee3d3cde8e SHA256 92fe7face800f0af7d2a2daf7e2b7faad0a95ddd9e1130cd2a375874d5ae5de0
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/dev-util/colormake/colormake-0.2.ebuild b/dev-util/colormake/colormake-0.2.ebuild
new file mode 100644
index 000000000..8684df131
--- /dev/null
+++ b/dev-util/colormake/colormake-0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+inherit eutils
+
+DESCRIPTION="Colorizing wrapper around make"
+HOMEPAGE="http://bre.klaki.net/programs/colormake/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="vanilla"
+RDEPEND="dev-lang/perl"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ use vanilla || epatch "${FILESDIR}"/${P}-disable-broken-tagging.patch
+ mv cmake colormake # prevent clash with dev-util/cmake
+ rm Makefile
+}
+
+src_install() {
+ dobin colormake{,.pl} || die
+}
diff --git a/dev-util/colormake/files/colormake-0.2-disable-broken-tagging.patch b/dev-util/colormake/files/colormake-0.2-disable-broken-tagging.patch
new file mode 100644
index 000000000..043d241b8
--- /dev/null
+++ b/dev-util/colormake/files/colormake-0.2-disable-broken-tagging.patch
@@ -0,0 +1,20 @@
+--- colormake.pl 2000-03-08 00:58:33.000000000 +0100
++++ colormake.pl 2008-12-22 02:52:02.000000000 +0100
+@@ -27,7 +27,7 @@
+ $col_green = "\033[32m";
+ $col_cyan = "\033[36m";
+ $col_brown = "\033[33m";
+-$col_norm = "\033[00m";
++$col_norm = "\033[00m";
+ $col_background = "\033[07m";
+ $col_brighten = "\033[01m";
+ $col_underline = "\033[04m";
+@@ -42,7 +42,7 @@
+ $col_linenum = $col_cyan;
+ $col_trace = $col_brown;
+ $col_warning = $col_green;
+-$tag_error = "Error: ";
++$tag_error = "";
+ $col_error = $tag_error . $col_brown . $col_brighten;
+ $error_highlight = $col_brighten;
+
diff --git a/dev-util/colormake/metadata.xml b/dev-util/colormake/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/dev-util/colormake/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>