summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkeenblade <keenblade@gmail.com>2010-09-21 23:27:51 +0000
committerkeenblade <keenblade@gmail.com>2010-09-21 23:27:51 +0000
commit4dee4ab4caa601163cc8dd01b2eceee2828b93fa (patch)
tree7d2d02b5e3506821a388e59ab74d087a3074a91e /app-antivirus/clamtk/clamtk-4.29.ebuild
parentmedia-sound/gogglesmm: Updated to latest version. New USE=gcrypt for external... (diff)
downloadsunrise-4dee4ab4caa601163cc8dd01b2eceee2828b93fa.tar.gz
sunrise-4dee4ab4caa601163cc8dd01b2eceee2828b93fa.tar.bz2
sunrise-4dee4ab4caa601163cc8dd01b2eceee2828b93fa.zip
app-antivirus/clamtk: Version bump
svn path=/sunrise/; revision=11335
Diffstat (limited to 'app-antivirus/clamtk/clamtk-4.29.ebuild')
-rw-r--r--app-antivirus/clamtk/clamtk-4.29.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-antivirus/clamtk/clamtk-4.29.ebuild b/app-antivirus/clamtk/clamtk-4.29.ebuild
new file mode 100644
index 000000000..5d7cbde76
--- /dev/null
+++ b/app-antivirus/clamtk/clamtk-4.29.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils perl-module
+
+DESCRIPTION="A frontend for ClamAV using Gtk2-perl"
+HOMEPAGE="http://clamtk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="Artistic GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+LANGS="ar bg cs da de el en_GB es eu fr gl he hr hu it ja ko ms nb nl nn pl pt pt_BR ro ru sk sl sv th tr uk zh_CN zh_TW"
+IUSE="nls"
+for i in ${LANGS}; do
+ IUSE="${IUSE} linguas_${i}"
+done
+
+DEPEND=""
+RDEPEND=">=dev-perl/gtk2-perl-1.140
+ dev-perl/File-Find-Rule
+ dev-perl/libwww-perl
+ dev-perl/Net-DNS
+ dev-perl/Date-Calc
+ dev-util/desktop-file-utils
+ >=app-antivirus/clamav-0.95
+ nls? ( dev-perl/Locale-gettext )
+ sys-fs/udev"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ gunzip ${PN}.1.gz || die "gunzip failed"
+}
+
+src_install() {
+ dobin ${PN} || die "dobin failed"
+
+ doicon ${PN}.png || die "doicon failed"
+ domenu ${PN}.desktop || die "domenu failed"
+
+ dodoc CHANGES README || die "dodoc failed"
+ doman ${PN}.1 || die "doman failed"
+
+ # The custom Perl modules
+ perlinfo
+ insinto ${VENDOR_LIB}/ClamTk
+ doins lib/*.pm || die "doins failed"
+
+ if use nls ; then
+ domo po/*.mo || die "domo failed"
+ fi
+}