summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/som_pak/som_pak-3.1.ebuild')
-rw-r--r--sci-visualization/som_pak/som_pak-3.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-visualization/som_pak/som_pak-3.1.ebuild b/sci-visualization/som_pak/som_pak-3.1.ebuild
new file mode 100644
index 000000000..67e09a3cf
--- /dev/null
+++ b/sci-visualization/som_pak/som_pak-3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+SRC_URI="http://www.cis.hut.fi/research/${PN}/${P}.tar"
+SLOT="0"
+LICENSE="free-noncomm"
+KEYWORDS="~x86"
+DESCRIPTION="The Self-Organizing Map Program Package"
+HOMEPAGE="http://www.cis.hut.fi/research/som-research/nnrc-programs.shtml"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}_makefile_qa.diff"
+}
+
+src_compile() {
+ emake -f makefile.unix || die "compilation failed"
+}
+
+src_test() {
+ # is this really a "test"?
+ emake -f makefile.unix example || die "tests failed"
+}
+
+src_install() {
+ dobin lininit mapinit planes qerror randinit sammon umat vcal vfind visual vsom
+ dodoc README
+} \ No newline at end of file