summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhasufell <julian.ospald@googlemail.com>2012-04-14 23:41:07 +0200
committerhasufell <julian.ospald@googlemail.com>2012-04-14 23:41:07 +0200
commit25ab9793d3312084239238a15ac187695c2fa237 (patch)
tree9580075ec457a91aba0cc5469f9f60e0604f23bd /games-strategy
parentgames-strategy/0ad-data: New Ebuild for bug 278541 thanks to mgorny and binki (diff)
downloadsunrise-reviewed-25ab9793d3312084239238a15ac187695c2fa237.tar.gz
sunrise-reviewed-25ab9793d3312084239238a15ac187695c2fa237.tar.bz2
sunrise-reviewed-25ab9793d3312084239238a15ac187695c2fa237.zip
games-strategy/0ad: New Ebuild for bug 278541 thanks to mgorny and binki
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/0ad/0ad-11339_alpha9.ebuild107
-rw-r--r--games-strategy/0ad/0ad-99999.ebuild119
-rw-r--r--games-strategy/0ad/ChangeLog12
-rw-r--r--games-strategy/0ad/Manifest6
-rw-r--r--games-strategy/0ad/files/11339_alpha9-fcollada-makefile.patch26
-rw-r--r--games-strategy/0ad/metadata.xml12
6 files changed, 282 insertions, 0 deletions
diff --git a/games-strategy/0ad/0ad-11339_alpha9.ebuild b/games-strategy/0ad/0ad-11339_alpha9.ebuild
new file mode 100644
index 000000000..290cd247c
--- /dev/null
+++ b/games-strategy/0ad/0ad-11339_alpha9.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+WX_GTK_VER="2.8"
+
+inherit eutils wxwidgets games
+
+MY_PV="r${PV%_*}-alpha"
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="A free, real-time strategy game"
+HOMEPAGE="http://wildfiregames.com/0ad/"
+SRC_URI="mirror://sourceforge/zero-ad/${MY_P}-unix-build.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1 MIT CCPL-Attribution-ShareAlike-3.0 as-is"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+audio +editor fam pch test"
+
+RDEPEND="
+ ~dev-lang/spidermonkey-1.8.5
+ dev-libs/boost
+ dev-libs/libxml2
+ dev-util/nvidia-texture-tools
+ ~games-strategy/0ad-data-${PV}
+ media-libs/libpng:0
+ media-libs/libsdl[X,opengl,video]
+ net-libs/enet:1.3
+ net-misc/curl
+ sys-libs/zlib
+ virtual/jpeg
+ virtual/opengl
+ audio? ( media-libs/libogg
+ media-libs/libvorbis
+ media-libs/openal )
+ editor? ( x11-libs/wxGTK:$WX_GTK_VER[X,opengl] )
+ fam? ( virtual/fam )
+ "
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ test? ( dev-lang/perl )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # respect flags for 3rd party fcollada
+ epatch "${FILESDIR}"/11339_alpha9-fcollada-makefile.patch
+}
+
+src_configure() {
+ cd build/workspaces || die
+
+ # custom configure script
+ local myconf
+ use fam || myconf="--without-fam"
+ use pch || myconf="${myconf} --without-pch"
+ use test || myconf="${myconf} --without-tests"
+ use audio || myconf="${myconf} --without-audio"
+
+ # don't use bundled sources
+ ./update-workspaces.sh \
+ --with-system-nvtt \
+ --with-system-enet \
+ --with-system-mozjs185 \
+ $(use_enable editor atlas) \
+ --bindir="${GAMES_BINDIR}" \
+ --libdir="$(games_get_libdir)"/${PN} \
+ --datadir="${GAMES_DATADIR}"/${PN} \
+ ${myconf} || die
+}
+
+src_compile() {
+ emake -C build/workspaces/gcc verbose=1 || die
+}
+
+src_test() {
+ if use nvtt ; then
+ cd binaries/system || die
+ ./test || die "test phase failed"
+ else
+ ewarn "Skipping tests because USE nvtt is disabled"
+ fi
+}
+
+src_install() {
+ # bin
+ dogamesbin binaries/system/pyrogenesis || die
+
+ # libs
+ exeinto "$(games_get_libdir)"/${PN}
+ doexe binaries/system/libCollada.so || die
+ if use editor ; then
+ doexe binaries/system/libAtlasUI.so || die
+ fi
+
+ # other
+ dodoc binaries/system/readme.txt || die
+ doicon build/resources/${PN}.png || die
+ games_make_wrapper ${PN} "${GAMES_BINDIR}/pyrogenesis"
+ make_desktop_entry ${PN} ${PN} ${PN}
+
+ # permissions
+ prepgamesdirs
+}
diff --git a/games-strategy/0ad/0ad-99999.ebuild b/games-strategy/0ad/0ad-99999.ebuild
new file mode 100644
index 000000000..2b17b7c44
--- /dev/null
+++ b/games-strategy/0ad/0ad-99999.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+WX_GTK_VER="2.8"
+
+inherit eutils subversion wxwidgets games
+
+MY_PV="r${PV%_*}-alpha"
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="A free, real-time strategy game"
+HOMEPAGE="http://wildfiregames.com/0ad/"
+ESVN_REPO_URI="http://svn.wildfiregames.com/public/ps/trunk"
+
+LICENSE="GPL-2 LGPL-2.1 MIT CCPL-Attribution-ShareAlike-3.0 as-is"
+SLOT="0"
+KEYWORDS=""
+IUSE="+audio +editor fam +pch test"
+
+RDEPEND="
+ ~dev-lang/spidermonkey-1.8.5
+ dev-libs/boost
+ dev-libs/libxml2
+ dev-util/nvidia-texture-tools
+ !games-strategy/0ad-data
+ media-libs/libpng:0
+ media-libs/libsdl[X,opengl,video]
+ net-libs/enet:1.3
+ net-misc/curl
+ sys-libs/zlib
+ virtual/jpeg
+ virtual/opengl
+ audio? ( media-libs/libogg
+ media-libs/libvorbis
+ media-libs/openal )
+ editor? ( x11-libs/wxGTK:$WX_GTK_VER[X,opengl] )
+ fam? ( virtual/fam )
+ "
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ test? ( dev-lang/perl )"
+
+S=${WORKDIR}/trunk
+
+pkg_setup() {
+ games_pkg_setup
+
+ if ! use pch ; then
+ eerror "pch useflag is potentially broken"
+ eerror "see http://trac.wildfiregames.com/ticket/1313"
+ fi
+}
+
+src_unpack() {
+ subversion_src_unpack
+}
+
+src_configure() {
+ cd build/workspaces || die
+
+ # custom configure script
+ local myconf
+ use fam || myconf="--without-fam"
+ use pch || myconf="${myconf} --without-pch"
+ use test || myconf="${myconf} --without-tests"
+ use audio || myconf="${myconf} --without-audio"
+
+ # don't use bundled sources
+ ./update-workspaces.sh \
+ --with-system-nvtt \
+ --with-system-enet \
+ --with-system-mozjs185 \
+ $(use_enable editor atlas) \
+ --bindir="${GAMES_BINDIR}" \
+ --libdir="$(games_get_libdir)"/${PN} \
+ --datadir="${GAMES_DATADIR}"/${PN} \
+ ${myconf} || die
+}
+
+src_compile() {
+ emake -C build/workspaces/gcc verbose=1 || die
+}
+
+src_test() {
+ if use nvtt ; then
+ cd binaries/system || die
+ ./test || die "test phase failed"
+ else
+ ewarn "Skipping tests because USE nvtt is disabled"
+ fi
+}
+
+src_install() {
+ # data
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r binaries/data/* || die
+
+ # bin
+ dogamesbin binaries/system/pyrogenesis || die
+
+ # libs
+ exeinto "$(games_get_libdir)"/${PN}
+ doexe binaries/system/libCollada.so || die
+ if use editor ; then
+ doexe binaries/system/libAtlasUI.so || die
+ fi
+
+ # other
+ dodoc binaries/system/readme.txt || die
+ doicon build/resources/${PN}.png || die
+ games_make_wrapper ${PN} "${GAMES_BINDIR}/pyrogenesis"
+ make_desktop_entry ${PN} ${PN} ${PN}
+
+ # permissions
+ prepgamesdirs
+}
diff --git a/games-strategy/0ad/ChangeLog b/games-strategy/0ad/ChangeLog
new file mode 100644
index 000000000..f3856eba0
--- /dev/null
+++ b/games-strategy/0ad/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for games-strategy/0ad
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*0ad-99999 (14 Apr 2012)
+*0ad-11339_alpha9 (14 Apr 2012)
+
+ 14 Apr 2012; hasufell <julian.ospald@googlemail.com>
+ +files/11339_alpha9-fcollada-makefile.patch, +0ad-11339_alpha9.ebuild,
+ +0ad-99999.ebuild, +metadata.xml:
+ New Ebuild for bug 278541 thanks to mgorny and binki
+
diff --git a/games-strategy/0ad/Manifest b/games-strategy/0ad/Manifest
new file mode 100644
index 000000000..e6eba791b
--- /dev/null
+++ b/games-strategy/0ad/Manifest
@@ -0,0 +1,6 @@
+AUX 11339_alpha9-fcollada-makefile.patch 1069 RMD160 d9155d60bd47eb83876f3b65c92d6c2384f87bdc SHA1 a04d8aea0c8ea6e13d0c123c5590eaf3b45d10cf SHA256 11ed3a1d83c2784d590ec047750cd1cc56932ad2e10203f70f72d19fe879464f
+DIST 0ad-r11339-alpha-unix-build.tar.xz 8593664 RMD160 5e7fc6449f7bde30611880ac2575c7cd2ef021d2 SHA1 e44f8484ca7082b1a9f2761a48aa8f54c8e833d1 SHA256 1e69bc02c1af1bfbe30244467761d13e1aaff164fe583d962cc8e13faf4a56cb
+EBUILD 0ad-11339_alpha9.ebuild 2372 RMD160 61c94b8f78cfa568a9f8b6864854f59e53d55b24 SHA1 50d480c6dbf44ae19e4fc3f35241516b2f125e59 SHA256 2293f7cad565ba5c17337ccc4ac7f7f3e7faf671aaabe7f79565d0c7d0f9a6c3
+EBUILD 0ad-99999.ebuild 2527 RMD160 574524ecd2cbb0876d720425c0a7f8a76ede6a05 SHA1 cea8cfbb71ba6093c09eff13cb75ae74c47d42c8 SHA256 aec0528dc9106bf0a21cf2ab0b3985b904c2d2b07e730d011547d100a29b657b
+MISC ChangeLog 397 RMD160 2d28da716512d22b0321cd41b33bc6f877dbee8b SHA1 dc1aa5ca88ff8b36e6dd7540c5b5c70a7451829c SHA256 2fc32721fb321a23d6d144c0ef42114d93a371f808668181777ce74807db76b8
+MISC metadata.xml 340 RMD160 6ac942a82ac7f194dd3e3c6437c6870c7e54af18 SHA1 59ffafa67aee64665a8cb7404f26b694a8a9705a SHA256 79e3cad447e25c2749b646cf284cda9c44abb3865a89998a08f7e3df1561b73e
diff --git a/games-strategy/0ad/files/11339_alpha9-fcollada-makefile.patch b/games-strategy/0ad/files/11339_alpha9-fcollada-makefile.patch
new file mode 100644
index 000000000..e397e8692
--- /dev/null
+++ b/games-strategy/0ad/files/11339_alpha9-fcollada-makefile.patch
@@ -0,0 +1,26 @@
+From: hasufell <julian.ospald@googlemail.com>
+Date: Wed Apr 11 14:45:32 UTC 2012
+
+FCollada Makefile does not respect CXX and flags
+
+--- libraries/fcollada/src/Makefile
++++ libraries/fcollada/src/Makefile
+@@ -7,14 +7,14 @@
+ PIC_FLAGS ?= -fpic
+ endif
+
+-CXX := g++
+-CXXFLAGS := -fvisibility=hidden -W -Wall -Wno-unused-parameter -Wno-unused-function $(OS_DEFINE) $(PIC_FLAGS) $(CPPFLAGS)
++CXX ?= g++
++CXXFLAGS += -fvisibility=hidden -W -Wall -Wno-unused-parameter -Wno-unused-function $(OS_DEFINE) $(PIC_FLAGS) $(CPPFLAGS)
+ CXXFLAGS_DEBUG := -O0 -g -D_DEBUG -DRETAIL
+ CXXFLAGS_RELEASE := -O1 -DNDEBUG -DRETAIL
+ # (-O2 with gcc 4.3 causes linker errors when using this library, for unknown reasons, so stick with -O1)
+ CXXFLAGS_TEST := -O0 -g -D_DEBUG
+-LIBS := `pkg-config libxml-2.0 --libs`
+-INCLUDES := -IFCollada `pkg-config libxml-2.0 --cflags`
++LIBS += `pkg-config libxml-2.0 --libs`
++INCLUDES += -IFCollada `pkg-config libxml-2.0 --cflags`
+ INCLUDES_TEST := -IFCollada/FColladaTest $(INCLUDES)
+
+ # FCollada is not aliasing-safe, so disallow dangerous optimisations
diff --git a/games-strategy/0ad/metadata.xml b/games-strategy/0ad/metadata.xml
new file mode 100644
index 000000000..b699881d7
--- /dev/null
+++ b/games-strategy/0ad/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-wanted@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="audio">Audio support</flag>
+ <flag name="editor">Include Atlas scenario editor projects</flag>
+ </use>
+</pkgmetadata>
+