summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoe9 <joe9mail@gmail.com>2013-04-02 18:07:10 -0400
committerhasufell <hasufell@gentoo.org>2013-04-03 00:15:28 +0200
commit59a856a94cd1415088b3f21ae77519dc3cca31f0 (patch)
treef530dc196a1df2167e84dbdba561b99e8c9dd10d /app-shells/zsh-history-substring-search
parentdev-python/Whoosh: moved to gx86. (diff)
downloadsunrise-reviewed-59a856a94cd1415088b3f21ae77519dc3cca31f0.tar.gz
sunrise-reviewed-59a856a94cd1415088b3f21ae77519dc3cca31f0.tar.bz2
sunrise-reviewed-59a856a94cd1415088b3f21ae77519dc3cca31f0.zip
added zsh-history-substring-search-9999 ebuild
Diffstat (limited to 'app-shells/zsh-history-substring-search')
-rw-r--r--app-shells/zsh-history-substring-search/ChangeLog10
-rw-r--r--app-shells/zsh-history-substring-search/Manifest3
-rw-r--r--app-shells/zsh-history-substring-search/metadata.xml11
-rw-r--r--app-shells/zsh-history-substring-search/zsh-history-substring-search-9999.ebuild39
4 files changed, 63 insertions, 0 deletions
diff --git a/app-shells/zsh-history-substring-search/ChangeLog b/app-shells/zsh-history-substring-search/ChangeLog
new file mode 100644
index 000000000..2a1ae58e2
--- /dev/null
+++ b/app-shells/zsh-history-substring-search/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-shells/zsh-history-substring-search
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*zsh-history-substring-search-9999 (02 Apr 2013)
+
+ 02 Apr 2013; Joe M <joe9mail@gmail.com>
+ +zsh-history-substring-search-9999.ebuild, +metadata.xml:
+ Initial import
+
diff --git a/app-shells/zsh-history-substring-search/Manifest b/app-shells/zsh-history-substring-search/Manifest
new file mode 100644
index 000000000..7f2553d30
--- /dev/null
+++ b/app-shells/zsh-history-substring-search/Manifest
@@ -0,0 +1,3 @@
+EBUILD zsh-history-substring-search-9999.ebuild 1156 SHA256 bd038a133508c9959c65c791811fac5cc26a9e1157c150aac7e8b4fe371f0fea SHA512 66358367c7e6c7ac19f0a76d014aa8bcd9778970b9a5907ea4d746a14a8bb75d371dd8638a95a750578dba43c0586955da1bdd56b888e700b9431856c3dfbe16 WHIRLPOOL 1c23a938c8bc6e2abe82d7cbd1a1295e7cbbea8e29cdca73f3dbe8fd74f5235ee3db57045c646e5ca1f4f26787f453f9ce3dad48c7a5ea15bfdd597f7b6e76df
+MISC ChangeLog 310 SHA256 afeca958d9c85b6c8350ea8a32fe8a3d15cfd6538ef2bac31e3a5f853454efa2 SHA512 e12fefc4a448e9f4c58ad84ae9e9ab94e09bff6b6c1c5e69066b798711790cf9b85092b7dffcbff7602edbf2d5b43c6ba654a3e3e1226faa996c09e490ef95c3 WHIRLPOOL 436c533ee6a4ba37910e7d5b05e9c06cd1de51334362a20276a6da9b1d7849b1f68bf55e27e8e7953959373263643bf5e9a5d9ef7557975d4dc3eae0fca13a33
+MISC metadata.xml 445 SHA256 e832e31b4b7e76b3b6977ef713b1893e1c239007cbbe9abe22130f918c517f36 SHA512 bb40eb094d1417a1532c46aa89cde62780ce3b3d6c7c11fcc0e030a6651c34f2fd1e8863b46a9e4b92c6b672c3a7ccd8b3c9dd7023fa0abcb4e98a8191ca0aae WHIRLPOOL 6d43618280a2e767a788dd901b8ad3e054eb217f9565d6995859552c47507b43e3e38d58f8f9118bfd9b4326d0ca820658a290025f778cf8158fd7ae2206c740
diff --git a/app-shells/zsh-history-substring-search/metadata.xml b/app-shells/zsh-history-substring-search/metadata.xml
new file mode 100644
index 000000000..142678de6
--- /dev/null
+++ b/app-shells/zsh-history-substring-search/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-wanted@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/zsh-users/zsh-history-substring-search/issues</bugs-to>
+ <remote-id type="github">zsh-users/zsh-history-substring-search</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/zsh-history-substring-search/zsh-history-substring-search-9999.ebuild b/app-shells/zsh-history-substring-search/zsh-history-substring-search-9999.ebuild
new file mode 100644
index 000000000..544267f45
--- /dev/null
+++ b/app-shells/zsh-history-substring-search/zsh-history-substring-search-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit eutils git-2
+
+EGIT_REPO_URI="git://github.com/zsh-users/zsh-history-substring-search.git"
+DESCRIPTION="Fish shell like history substring search for zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-history-substring-search"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="app-shells/zsh"
+
+src_prepare() {
+ epatch_user
+}
+
+src_install() {
+ dodoc *.md
+ insinto /usr/share/zsh/site-contrib/${PN}
+ doins zsh-history-substring-search.zsh
+}
+
+pkg_postinst() {
+ [[ -n "${REPLACING_VERSIONS}" ]] && return
+ elog "In order to use ${CATEGORY}/${PN} add"
+ elog ". /usr/share/zsh/site-contrib/${PN}/zsh-history-substring-search.zsh"
+ elog "at the end of your ~/.zshrc"
+ elog "For testing, you can also execute the above command in your zsh."
+ elog "If you want to use zsh-syntax-highlighting along with this "
+ elog "script, then make sure that you load it before you load this "
+ elog "script:"
+ elog ". /usr/share/zsh/site-contrib/${PN}/zsh-syntax-highlighting.zsh"
+ elog ". /usr/share/zsh/site-contrib/${PN}/zsh-history-substring-search.zsh"
+}