summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2010-03-24 11:35:41 +0000
committerMichał Górny <mgorny@gentoo.org>2010-03-24 11:35:41 +0000
commitc57056368958d5cfef78542bdcd0d94b3212ab59 (patch)
tree4d74de35c25fb2c5f23cf33417507a8196db285d /app-portage
parentwww-apps/tt-rss: Version bump for tt-rss and removed mysqli USE flag, thanks ... (diff)
downloadsunrise-reviewed-c57056368958d5cfef78542bdcd0d94b3212ab59.tar.gz
sunrise-reviewed-c57056368958d5cfef78542bdcd0d94b3212ab59.tar.bz2
sunrise-reviewed-c57056368958d5cfef78542bdcd0d94b3212ab59.zip
app-portage/smart-live-rebuild: New ebuild for bug #310975.
svn path=/sunrise/; revision=10339
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/smart-live-rebuild/ChangeLog8
-rw-r--r--app-portage/smart-live-rebuild/Manifest4
-rw-r--r--app-portage/smart-live-rebuild/metadata.xml5
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-0.1.ebuild23
4 files changed, 40 insertions, 0 deletions
diff --git a/app-portage/smart-live-rebuild/ChangeLog b/app-portage/smart-live-rebuild/ChangeLog
new file mode 100644
index 000000000..e34f2d424
--- /dev/null
+++ b/app-portage/smart-live-rebuild/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-portage/smart-live-rebuild
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 24 Mar 2010; Michał Górny (sedzimir) <gentoo@mgorny.alt.pl>
+ +smart-live-rebuild-0.1.ebuild, +metadata.xml:
+ New ebuild for bug #310975.
+
diff --git a/app-portage/smart-live-rebuild/Manifest b/app-portage/smart-live-rebuild/Manifest
new file mode 100644
index 000000000..97b2513b5
--- /dev/null
+++ b/app-portage/smart-live-rebuild/Manifest
@@ -0,0 +1,4 @@
+DIST smart-live-rebuild-0.1.py.bz2 3607 RMD160 2e3264dd992cf4012fbdbd899d76a4f731832b5b SHA1 ff2b53248a7ad9f736beb11fa08f8a186d95a80c SHA256 aefe51ec2f37e37de5202ac0dc3787d5f8f2334ae5b0fc7268a50462f9e78574
+EBUILD smart-live-rebuild-0.1.ebuild 482 RMD160 39927d40264dfa83f2fc983d1e52e1a2751fcd63 SHA1 a5003befcf2cd334cb22ed7d674cfb620fed668f SHA256 35038e5508829ce60d8edc1c7b4b71dfba425939d2d7b2f243cf0a03e39ea26e
+MISC ChangeLog 275 RMD160 b1d7199063edcbdb9a2fcd245f6db22b59da0871 SHA1 d53d7f15d9cccdf6090a199839f7649ae8cd1d54 SHA256 212e62b90b497e64666ea951b088c78a6479d92960f6e2985df78ec87fb3a65d
+MISC metadata.xml 171 RMD160 ed284df01c230fc7990a6b5888b39166d23f29ba SHA1 f3d64a69044b710e23fb874b3ee4cd338858c8b4 SHA256 a7b30fbacd0e4c312c07a3efac112a3794c81d134442d8104325734d03425adf
diff --git a/app-portage/smart-live-rebuild/metadata.xml b/app-portage/smart-live-rebuild/metadata.xml
new file mode 100644
index 000000000..6f1d493c5
--- /dev/null
+++ b/app-portage/smart-live-rebuild/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>maintainer-wanted</herd>
+</pkgmetadata>
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-0.1.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-0.1.ebuild
new file mode 100644
index 000000000..b4ac9bed7
--- /dev/null
+++ b/app-portage/smart-live-rebuild/smart-live-rebuild-0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+PYTHON_DEPEND=2
+inherit python
+
+DESCRIPTION="Update live packages and emerge the modified ones"
+HOMEPAGE="http://proj.mgorny.alt.pl/misc/#smart-live-rebuild"
+SRC_URI="http://dl.mgorny.alt.pl/misc/${P}.py.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+src_compile() {
+ python_convert_shebangs 2 ${P}.py
+}
+
+src_install() {
+ newbin ${P}.py ${PN} || die
+}