summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Jackson <mjo@gentoo.org>2011-03-08 21:49:52 +0000
committerMartin Jackson <mjo@gentoo.org>2011-03-08 21:49:52 +0000
commit645988d8b67a5327ee0667748f37263355337a4c (patch)
treef0e1632a92dc9e2df770e9d4ba8242b44f348ba2 /app-misc
parentmedia-sound/despotify: Compile during src_compile() instead of src_install() ... (diff)
downloadsunrise-reviewed-645988d8b67a5327ee0667748f37263355337a4c.tar.gz
sunrise-reviewed-645988d8b67a5327ee0667748f37263355337a4c.tar.bz2
sunrise-reviewed-645988d8b67a5327ee0667748f37263355337a4c.zip
app-misc/reptyr: New ebuild to address bug 357981.
svn path=/sunrise/; revision=11804
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/reptyr/ChangeLog8
-rw-r--r--app-misc/reptyr/Manifest4
-rw-r--r--app-misc/reptyr/metadata.xml8
-rw-r--r--app-misc/reptyr/reptyr-0.2.ebuild27
4 files changed, 47 insertions, 0 deletions
diff --git a/app-misc/reptyr/ChangeLog b/app-misc/reptyr/ChangeLog
new file mode 100644
index 000000000..969ae4130
--- /dev/null
+++ b/app-misc/reptyr/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-misc/reptyr
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 08 Mar 2011; Michael Orlitzky <michael@orlitzky.com> +reptyr-0.2.ebuild,
+ +metadata.xml:
+ New ebuild to address bug 357981.
+
diff --git a/app-misc/reptyr/Manifest b/app-misc/reptyr/Manifest
new file mode 100644
index 000000000..61f5826ba
--- /dev/null
+++ b/app-misc/reptyr/Manifest
@@ -0,0 +1,4 @@
+DIST reptyr-0.2.tar.gz 12187 RMD160 a46bdfc60838a580d7caa5a33a048bbd3a66ae1f SHA1 e9d305d9a0b8d9a80644e7cf2987f8078350ed80 SHA256 5fa9466fbbd530aeb065e24816bd41a9c040f7f39be8518acf313f5674d79971
+EBUILD reptyr-0.2.ebuild 573 RMD160 7c36ed1948ef0054d4fda0298575ebbf1c064c08 SHA1 6758b5bdd01fbb9d1dcd39a474a67a75ba3daa33 SHA256 0258058779799c38cac7ffd3b0cc6601ae4275500d93644736b24770e0380c7a
+MISC ChangeLog 245 RMD160 f6e0feefe21b18cfc3476d637938fb96460f4a20 SHA1 d13bc2bac143a60a80367a8604c0082fb7d7aa9e SHA256 6964f24be66775f7ca59ca180e02745ef76b211c7d13f6053c638bf98828cfa1
+MISC metadata.xml 241 RMD160 d1bcf027ff9f0cf1953659be5b89b59522c6f063 SHA1 7dff00c0281f5ed66259645e76b04e8ab0241a77 SHA256 fb616eb93c0779c7c5dbf3b445656fb1636d6668443155cb95a8325cd988500f
diff --git a/app-misc/reptyr/metadata.xml b/app-misc/reptyr/metadata.xml
new file mode 100644
index 000000000..7ee8acd8e
--- /dev/null
+++ b/app-misc/reptyr/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>maintainer-wanted@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-misc/reptyr/reptyr-0.2.ebuild b/app-misc/reptyr/reptyr-0.2.ebuild
new file mode 100644
index 000000000..eaf360e4c
--- /dev/null
+++ b/app-misc/reptyr/reptyr-0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+DESCRIPTION="Reparent a running program to a new terminal"
+HOMEPAGE="https://github.com/nelhage/${PN}"
+SRC_URI="http://github.com/nelhage/${PN}/tarball/${P} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ mv "nelhage-${PN}"-* "${S}"
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "install failed"
+}