aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/Forthon/Forthon-0.8.7.ebuild34
-rw-r--r--dev-python/Forthon/Manifest1
-rw-r--r--dev-python/Forthon/metadata.xml8
-rw-r--r--licenses/Forthon32
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/Forthon/Forthon-0.8.7.ebuild b/dev-python/Forthon/Forthon-0.8.7.ebuild
new file mode 100644
index 000000000..c1512f10e
--- /dev/null
+++ b/dev-python/Forthon/Forthon-0.8.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Python interface generator for Fortran based codes"
+HOMEPAGE="http://hifweb.lbl.gov/Forthon http://pypi.python.org/pypi/Forthon"
+SRC_URI="http://hifweb.lbl.gov/${PN}/${P}.tgz"
+
+LICENSE="Forthon"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+src_prepare() {
+ sed -i -e "s/'Notice',//" setup.py || die
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+ dohtml docs/index.html
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r {example,example2,simpleexample}
+ fi
+}
diff --git a/dev-python/Forthon/Manifest b/dev-python/Forthon/Manifest
new file mode 100644
index 000000000..ca42a39e7
--- /dev/null
+++ b/dev-python/Forthon/Manifest
@@ -0,0 +1 @@
+DIST Forthon-0.8.7.tgz 86413 SHA256 fb26789ef3ce2b3880573c48b68c9d35d1d0aac1d0fdd1955fb207816c143e69 SHA512 e3c60901cdc83abc1d28611cfd524eff44241e499c593c43ac0b77c52b48ad1c662b92adf1c17a50fb5fbd6c046524320c21fb3eea9e5c26c188ab04004f575d WHIRLPOOL 1e8a0e51c6b1a5b0c89ac246354fad0b2920010f39c03f9d89d338e98950a9deee756f0d5287b81b65506ac44e120b642a750d1a83d013a108add0b4ae610069
diff --git a/dev-python/Forthon/metadata.xml b/dev-python/Forthon/metadata.xml
new file mode 100644
index 000000000..6629da3fa
--- /dev/null
+++ b/dev-python/Forthon/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xarthisius@gentoo.org</email>
+ <name>Kacper Kowalik</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/licenses/Forthon b/licenses/Forthon
new file mode 100644
index 000000000..2331703d7
--- /dev/null
+++ b/licenses/Forthon
@@ -0,0 +1,32 @@
+UCRL-CODE-155927
+
+This work was produced at the University of California, Lawrence
+Livermore National Laboratory (UC LLNL) under contract no. W-7405-ENG-48
+(Contract 48) between the U.S. Department of Energy (DOE) and The
+Regents of the University of California (University) for the operation
+of UC LLNL. The rights of the Federal Government are reserved under
+Contract 48 subject to the restrictions agreed upon by the DOE and
+University as allowed under DOE Acquisition Letter 97-1.
+
+DISCLAIMER
+
+This work was prepared as an account of work sponsored by an agency of
+the United States Government. Neither the United States Government nor
+the University of California nor any of their employees, makes any
+warranty, express or implied, or assumes any liability or responsibility
+for the accuracy, completeness, or usefulness of any information,
+apparatus, product, or process disclosed, or represents that its use
+would not infringe privately-owned rights. Reference herein to any
+specific commercial products, process, or service by trade name,
+trademark, manufacturer or otherwise does not necessarily constitute or
+imply its endorsement, recommendation, or favoring by the United States
+Government or the University of California. The views and opinions of
+authors expressed herein do not necessarily state or reflect those of
+the United States Government or the University of California, and shall
+not be used for advertising or product endorsement purposes.
+
+NOTIFICATION OF COMMERCIAL USE
+
+Commercialization of this product is prohibited without notifying the
+Department of Energy (DOE) or Lawrence Livermore National Laboratory (LLNL).
+