aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-11-16 16:25:57 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-11-16 16:25:57 +0100
commit269f8ec2296020516eed5b613c332d752349ef8f (patch)
tree9578022e5248e37c6963c0df222ef0d61b21dc5b /sci-biology/lastz
parentsci-biology/gbench: add missing SLOT (diff)
downloadsci-269f8ec2296020516eed5b613c332d752349ef8f.tar.gz
sci-269f8ec2296020516eed5b613c332d752349ef8f.tar.bz2
sci-269f8ec2296020516eed5b613c332d752349ef8f.zip
sci-biology/lastz: fix long-lasting ebuild errors and version bump
Seems Gentoo newer compiled/installed the lastz_32 binary, which allows indexing larger genomes. This ebuild fixes that for current version and contains practically same Makefile-related patch as before. Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'sci-biology/lastz')
-rw-r--r--sci-biology/lastz/Manifest2
-rw-r--r--sci-biology/lastz/files/lastz-1.04.00-build.patch (renamed from sci-biology/lastz/files/lastz-1.03.66-build.patch)22
-rw-r--r--sci-biology/lastz/lastz-1.04.00.ebuild (renamed from sci-biology/lastz/lastz-1.03.66.ebuild)11
3 files changed, 27 insertions, 8 deletions
diff --git a/sci-biology/lastz/Manifest b/sci-biology/lastz/Manifest
index b8f2a76b1..1b4cc1eff 100644
--- a/sci-biology/lastz/Manifest
+++ b/sci-biology/lastz/Manifest
@@ -1 +1 @@
-DIST lastz-1.03.66.tar.gz 727104 SHA256 8eb2db3fcf235065a099536f3a41323df25c6643d30b0db3a79f4b2f7430a5d0 SHA512 904c91b4f36ff94805096bd52fe3790801199739a43e5b14d06ceda06b4d38cde8f202b3492245ff5f1efc4d9070f6807fe1e19db802759fe1f23f45133e314d WHIRLPOOL 0440fd08a0a7620e094e68cff746bcbd95f0a6cf31526728f9ad2dd2697cc22ba2fda99865d83504b206d1ca986b2003b614408c0a9275889119804c702885c6
+DIST lastz-1.04.00.tar.gz 734145 SHA256 dd2e417c088a794532125d4c3e83a2c4ce39e6d287ed69312fb8c665f885ed52 SHA512 fa027141d8c797e9c425755b928bd40616ea193bfbd99ebbabc7bc44042edb894eafc493e9953a48cda94702109a9ec295d12c334f3db225e9880d51488e7972 WHIRLPOOL 8b4ef3bd3c9cdd4d3fdffc294d232a93b33399bd46b62f58136319e40c65220329f891b975fa317c56932b779737e4e4ea4eb317d52be8b9ef438db74db754c4
diff --git a/sci-biology/lastz/files/lastz-1.03.66-build.patch b/sci-biology/lastz/files/lastz-1.04.00-build.patch
index 0b9a948d3..d3705c514 100644
--- a/sci-biology/lastz/files/lastz-1.03.66-build.patch
+++ b/sci-biology/lastz/files/lastz-1.04.00-build.patch
@@ -1,5 +1,5 @@
---- src/Makefile.old 2015-05-02 15:07:56.169136255 +0200
-+++ src/Makefile 2015-05-02 15:10:02.249137955 +0200
+--- lastz-distrib-1.04.00/src/Makefile.ori 2017-11-16 16:09:47.232140878 +0100
++++ lastz-distrib-1.04.00/src/Makefile 2017-11-16 16:14:12.589271305 +0100
@@ -1,7 +1,7 @@
include ../make-include.mak
include version.mak
@@ -9,16 +9,28 @@
# default targets
-@@ -71,7 +71,7 @@
- -DSUBVERSION_REV="\"${SUBVERSION_REV}"\"
+@@ -54,7 +54,8 @@
+ #
+ #---------
+
+-definedForAll = -Wall -Wextra -Werror -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
++mycflags = -O3 -Wall -Wextra -Werror
++definedForAll = -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+ flagsFor32 = -Dmax_sequence_index=32 -Dmax_malloc_index=40 -Ddiag_hash_size=4194304
+ allowBackToBackGaps ?= 0 # by default allowBackToBackGaps
+@@ -70,8 +71,8 @@
+ -DREVISION_DATE="\"${REVISION_DATE}"\" \
+ -DSUBVERSION_REV="\"${SUBVERSION_REV}"\"
+-
-CFLAGS = -O3 ${definedForAll} ${VERSION_FLAGS}
++CFLAGS ?= ${mycflags}
+CFLAGS += ${definedForAll} ${VERSION_FLAGS}
srcFiles = lastz infer_scores \
-@@ -101,13 +101,13 @@
+@@ -101,13 +102,13 @@
lastz: $(foreach part,${srcFiles},${part}.o)
diff --git a/sci-biology/lastz/lastz-1.03.66.ebuild b/sci-biology/lastz/lastz-1.04.00.ebuild
index bc6925199..6acd3d39c 100644
--- a/sci-biology/lastz/lastz-1.03.66.ebuild
+++ b/sci-biology/lastz/lastz-1.04.00.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -25,8 +25,15 @@ src_prepare() {
tc-export CC
}
+src_compile(){
+ emake
+ emake lastz_32
+}
+
src_install(){
- dobin src/lastz src/lastz_D
+ emake install
+ emake install_32
+ dobin src/lastz src/lastz_D src/lastz_32
dodoc README.lastz.html
dohtml lav_format.html
}