aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrei Zavada <johnhommer@gmail.com>2017-01-05 17:15:35 +0200
committerJustin Lecher <jlec@gentoo.org>2017-01-05 15:15:35 +0000
commit76dadfe56cfad3483ead945d3a9ad46f38dfd89c (patch)
tree181c4c0b55cdc9842174640c1540b7410cfbbba4 /sci-biology/aghermann/aghermann-1.1.2.ebuild
parentsci-biology/fsl: fixed outstanding FSLDIR and GUI issues (#716) (diff)
downloadsci-76dadfe56cfad3483ead945d3a9ad46f38dfd89c.tar.gz
sci-76dadfe56cfad3483ead945d3a9ad46f38dfd89c.tar.bz2
sci-76dadfe56cfad3483ead945d3a9ad46f38dfd89c.zip
Version bumps for sci-biology/{aghermann,cnrun} (#717)
* sci-biology/aghermann: Version bump, update deps & SRC_URI Package-Manager: Portage-2.3.3, Repoman-2.3.1 * sci-biology/cnrun: Version bump, update SRC_URI Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-biology/aghermann/aghermann-1.1.2.ebuild')
-rw-r--r--sci-biology/aghermann/aghermann-1.1.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-biology/aghermann/aghermann-1.1.2.ebuild b/sci-biology/aghermann/aghermann-1.1.2.ebuild
new file mode 100644
index 000000000..bfe13db15
--- /dev/null
+++ b/sci-biology/aghermann/aghermann-1.1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+DESCRIPTION="A sleep-research experiment manager, EDF viewer & Process S simulator"
+HOMEPAGE="http://johnhommer.com/academic/code/aghermann"
+SRC_URI="http://alfinston.dlinkddns.com/johnhommer.com/code/aghermann/source/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/lua:*
+ dev-libs/libconfig
+ media-libs/libsamplerate
+ sci-libs/fftw:3.0
+ sci-libs/gsl
+ sci-libs/itpp
+ x11-libs/gtk+:3
+ x11-libs/vte:2.91"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf --bindir="${EPREFIX}"/usr/bin
+}