aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2024-03-21 17:34:50 -0400
committerHorea Christian <chr@chymera.eu>2024-03-21 18:15:29 -0400
commit660cac741c12de9ea6e4b98195b2be6a07821f0e (patch)
tree1a4c03d70e2d852a34b92e1f2b7773efe8156399 /dev-python
parentdev-python/pynwb: add 2.6.0, drop 2.3.2 (diff)
downloadsci-660cac741c12de9ea6e4b98195b2be6a07821f0e.tar.gz
sci-660cac741c12de9ea6e4b98195b2be6a07821f0e.tar.bz2
sci-660cac741c12de9ea6e4b98195b2be6a07821f0e.zip
dev-python/hdmf: version and PYTHON_COMPAT bump, treeclean
Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hdmf/Manifest4
-rw-r--r--dev-python/hdmf/hdmf-3.13.0.ebuild (renamed from dev-python/hdmf/hdmf-3.11.0.ebuild)4
-rw-r--r--dev-python/hdmf/hdmf-3.5.1.ebuild28
-rw-r--r--dev-python/hdmf/hdmf-3.5.2.ebuild29
4 files changed, 3 insertions, 62 deletions
diff --git a/dev-python/hdmf/Manifest b/dev-python/hdmf/Manifest
index b2e716d9d..204753b4e 100644
--- a/dev-python/hdmf/Manifest
+++ b/dev-python/hdmf/Manifest
@@ -1,3 +1 @@
-DIST hdmf-3.11.0.tar.gz 15845296 BLAKE2B 4526496bd8290891a9058397c9916fce82667bc86541d55853525642ecd8a80ca6a60711bc0eb4ad637f2359ae9409f023da45c8e80aba0cbb9d8a4cf9009095 SHA512 1ec59990e30253036d367be0419c7bfd548866d3006cdc23785d01976621a8a4f86f7613d913084b1e12712f3a99b7e2fba80f197f72d9be8fb8e315073db522
-DIST hdmf-3.5.1.tar.gz 324778 BLAKE2B b82d2389466be8e8b4acd843beaafe69b731a38045abab0a741fb7a6143e8ed8f60d570603629c7485f7f7a261047bcc9e21ebeb61802e6d81b35aa276d09af0 SHA512 1545f0c1c6b2bac66437941e631adaa45a42c18436ed68d5ee21a7cafe950a85e2843a4b2258b3f5c0ece5fd6d3ef6f0fd596a83bacd208750bfb5b78a1d5815
-DIST hdmf-3.5.2.tar.gz 567466 BLAKE2B 99872885aec1b0aff30dfde17cc3c2f5f30e9da7f3ac5aa77dad203fe795ad6c207bdafd6d19548bf8c3f901a1ec8655b048d9ba41be11eaca3a7c55e6de2825 SHA512 47f8de397fe3defe814db3da7f2bf7ec3814bf3a1d9389c6fe823e229ddea441c97122e41a11883f1c7b5968a841d8fdd0c7314e9d82d4e5ea43a713a40afbfa
+DIST hdmf-3.13.0.tar.gz 15855926 BLAKE2B 8eb386540768a83954745c02f7142d2a0b466ef670baaf13a1dfee0ce02261f0f89a9b173dfb8d2673d1f538c35e800117f6f0fe2ca77e5ca6a94b01e9908917 SHA512 5d6f97abb28b46136b3a62f915f8c14cc48e49c1ec3d44e3d863b1c3e7aebb1cfea428b77311ca51dbf5ef9a1e529e73cdb477d863e3d0cd6641fbf79a043f20
diff --git a/dev-python/hdmf/hdmf-3.11.0.ebuild b/dev-python/hdmf/hdmf-3.13.0.ebuild
index 2463ccc1a..7068afb01 100644
--- a/dev-python/hdmf/hdmf-3.11.0.ebuild
+++ b/dev-python/hdmf/hdmf-3.13.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
DESCRIPTION="The Hierarchical Data Modeling Framework"
@@ -25,7 +25,7 @@ RDEPEND="
"
PATCHES=(
- "${FILESDIR}/${P}-no_test_coverage.patch"
+ "${FILESDIR}/${PN}-3.11.0-no_test_coverage.patch"
)
distutils_enable_tests pytest
diff --git a/dev-python/hdmf/hdmf-3.5.1.ebuild b/dev-python/hdmf/hdmf-3.5.1.ebuild
deleted file mode 100644
index 883b5b95b..000000000
--- a/dev-python/hdmf/hdmf-3.5.1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-inherit distutils-r1
-
-DESCRIPTION="The Hierarchical Data Modeling Framework"
-HOMEPAGE="https://github.com/hdmf-dev/hdmf"
-SRC_URI="https://github.com/hdmf-dev/hdmf/releases/download/${PV}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/h5py[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- "
-BDEPEND=""
-
-distutils_enable_tests pytest
diff --git a/dev-python/hdmf/hdmf-3.5.2.ebuild b/dev-python/hdmf/hdmf-3.5.2.ebuild
deleted file mode 100644
index ee978516e..000000000
--- a/dev-python/hdmf/hdmf-3.5.2.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-inherit distutils-r1 pypi
-
-DESCRIPTION="The Hierarchical Data Modeling Framework"
-HOMEPAGE="https://github.com/hdmf-dev/hdmf"
-SRC_URI="$(pypi_sdist_url hdmf)"
-#SRC_URI="https://github.com/hdmf-dev/hdmf/releases/download/${PV}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/h5py[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- "
-BDEPEND=""
-
-distutils_enable_tests pytest