aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFilip Kobierski <fkobi@pm.me>2024-11-15 15:15:04 +0100
committerNowa Ammerlaan <nowa@gentoo.org>2024-11-19 15:05:23 +0100
commit4d760cb67f29928561290af5b4095b92f3fcda8e (patch)
tree78b4b57a847003f076037bf76d8730008137442a
parentdev-python/fiona: fix pypi redirection (diff)
downloadsci-4d760cb67f29928561290af5b4095b92f3fcda8e.tar.gz
sci-4d760cb67f29928561290af5b4095b92f3fcda8e.tar.bz2
sci-4d760cb67f29928561290af5b4095b92f3fcda8e.zip
dev-python/fiona: drop 1.9.0
Signed-off-by: Filip Kobierski <fkobi@pm.me> Signed-off-by: Nowa Ammerlaan <nowa@gentoo.org>
-rw-r--r--dev-python/fiona/Manifest1
-rw-r--r--dev-python/fiona/fiona-1.9.0.ebuild76
2 files changed, 0 insertions, 77 deletions
diff --git a/dev-python/fiona/Manifest b/dev-python/fiona/Manifest
index 9d96b3c82..193923d1a 100644
--- a/dev-python/fiona/Manifest
+++ b/dev-python/fiona/Manifest
@@ -1,3 +1,2 @@
DIST fiona-1.10.1.gh.tar.gz 691246 BLAKE2B 53a6dd4cc36825aa27cff4edb53c36d5a48874ade9038b5a08bd846bda75a41136b39d6e0ffaa0a4e104b16e10af4cc051ab0b2602dfaa552eb3c282a51824ba SHA512 d84e973de81a53da44dd630d88eee0c1a3a8c5bef58ae70aef32ac7cebff590b9244860ee2674f3e97fdfd7a24ad07061355bb2c48d506bec5aec5e90adff87a
-DIST fiona-1.9.0.gh.tar.gz 290797 BLAKE2B 1cd2a4a26d23d057433889937b4fecefb1e1585dc6b507e297ef3bab8cf72f734bc080bab8487d58c636312bca1330960f78fc2916d27c9a7247df087818c9b3 SHA512 f59d148cfc4f1cab6d89660146522920fab8b6fb1120ad8f3d3e8349d5fa823860984f8fd331e2fc3183a4a186a165508db8dcbcbdf4b943a7dad82d8d51d866
DIST fiona-1.9.6.gh.tar.gz 391486 BLAKE2B bdfc3a9ae972a6cc0bd9e6fa79879183bd87bcbdee1a543bd66f624b633d6ad3d1ab2264176a4d7eabc80680377f0438821d36e1fa111210e37f6788a9efe985 SHA512 91899a79b590a985d3cc266d9aeb346659ef531618e0aa099c9aeb589fd4bea912d9b0f9212b35a44d33f70e61efb627b7af7264631807cab77d3968b4464c2f
diff --git a/dev-python/fiona/fiona-1.9.0.ebuild b/dev-python/fiona/fiona-1.9.0.ebuild
deleted file mode 100644
index 7bc415b14..000000000
--- a/dev-python/fiona/fiona-1.9.0.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-DISTUTILS_USE_PEP517="setuptools"
-inherit distutils-r1
-
-DESCRIPTION="API for reading/writing vector geospatial data"
-HOMEPAGE="https://github.com/Toblerity/fiona"
-SRC_URI="https://github.com/Toblerity/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
-S="${WORKDIR}/Fiona-${PV}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- sci-libs/gdal[geos,sqlite]
- dev-python/attrs[${PYTHON_USEDEP}]
- dev-python/click-plugins[${PYTHON_USEDEP}]
- dev-python/cligj[${PYTHON_USEDEP}]
- dev-python/munch[${PYTHON_USEDEP}]
- dev-python/certifi[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- test? (
- dev-python/boto3[${PYTHON_USEDEP}]
- sci-libs/gdal[geos,sqlite]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # disable tests due to networking blocked
- tests/test_vfs.py::test_open_http
- tests/test_vfs.py::test_open_zip_https
- tests/test_collection.py::test_collection_http
- tests/test_collection.py::test_collection_zip_http
-
- # disable tests failing due to deprecated GDAL features
- tests/test_data_paths.py::test_gdal_data_wheel
- tests/test_data_paths.py::test_proj_data_wheel
- tests/test_data_paths.py::test_env_gdal_data_wheel
- tests/test_data_paths.py::test_env_proj_data_wheel
- tests/test_datetime.py::test_datefield[GPSTrackMaker-datetime]
- tests/test_datetime.py::test_datefield_null[GPSTrackMaker-datetime]
- tests/test_drvsupport.py::test_write_or_driver_error[GPSTrackMaker]
- tests/test_drvsupport.py::test_no_append_driver_cannot_append[GPSTrackMaker]
- tests/test_drvsupport.py::test_no_append_driver_cannot_append[PCIDSK]
- tests/test_drvsupport.py::test_write_or_driver_error[DGN]
-
- # failure in flatgeobuf impl
- tests/test_drvsupport.py::test_no_append_driver_cannot_append[FlatGeobuf]
-
- # geos
- #tests/test_collection.py::test_mask_polygon_triangle
- #tests/test_collection.py::test_mask_polygon_triangle
- #tests/test_collection.py::test_mask_polygon_triangle
-
- # sqlite
- #tests/test_schema.py::test_geometry_only_schema_write[GPKG]
- #tests/test_schema.py::test_geometry_only_schema_update[GPKG]
- #tests/test_schema.py::test_property_only_schema_write[GPKG]
- #tests/test_schema.py::test_property_only_schema_update[GPKG]
- )
-
- mv fiona{,.bak} || die # Avoid non-working local import
- epytest ${deselect[@]/#/--deselect }
- mv fiona{.bak,} || die
-}