summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <alex@a3li.li>2011-08-30 21:06:21 +0200
committerAlex Legler <alex@a3li.li>2011-08-30 21:06:21 +0200
commit70339f559fe42d543cc6b4d6a44e967c8cc97b40 (patch)
tree5ecce538ea1c73dac78a146b07982205324ada53 /patchsets
parentPatches for ruby 1.8.7_p334-r2 (diff)
downloadruby-scripts-70339f559fe42d543cc6b4d6a44e967c8cc97b40.tar.gz
ruby-scripts-70339f559fe42d543cc6b4d6a44e967c8cc97b40.tar.bz2
ruby-scripts-70339f559fe42d543cc6b4d6a44e967c8cc97b40.zip
Add 1.9.2_p290 patchsetpatchset-1.9.2_p290
Diffstat (limited to 'patchsets')
-rw-r--r--patchsets/distfiles/ruby-patches-1.9.2_p290.tar.bz2bin0 -> 2246 bytes
-rw-r--r--patchsets/patches-1.9.2_p290/004_gfbsd7.patch39
-rw-r--r--patchsets/patches-1.9.2_p290/005_no-undefined-ext.patch13
-rw-r--r--patchsets/patches-1.9.2_p290/007_berkdb-5.0.patch31
-rw-r--r--patchsets/patches-1.9.2_p290/009_no-gems.patch41
-rw-r--r--patchsets/patches-1.9.2_p290/series6
6 files changed, 130 insertions, 0 deletions
diff --git a/patchsets/distfiles/ruby-patches-1.9.2_p290.tar.bz2 b/patchsets/distfiles/ruby-patches-1.9.2_p290.tar.bz2
new file mode 100644
index 0000000..c205467
--- /dev/null
+++ b/patchsets/distfiles/ruby-patches-1.9.2_p290.tar.bz2
Binary files differ
diff --git a/patchsets/patches-1.9.2_p290/004_gfbsd7.patch b/patchsets/patches-1.9.2_p290/004_gfbsd7.patch
new file mode 100644
index 0000000..d5c2fea
--- /dev/null
+++ b/patchsets/patches-1.9.2_p290/004_gfbsd7.patch
@@ -0,0 +1,39 @@
+Index: ruby-1.9.2-rc2/configure.in
+===================================================================
+--- ruby-1.9.2-rc2.orig/configure.in
++++ ruby-1.9.2-rc2/configure.in
+@@ -1683,7 +1683,7 @@ if test "$rb_cv_binary_elf" = yes; then
+ fi
+
+ AS_CASE(["$target_os"],
+-[linux* | gnu* | k*bsd*-gnu | bsdi* | kopensolaris*-gnu], [
++[linux* | gnu* | k*bsd*-gnu | bsdi* | kopensolaris*-gnu | freebsd* | dragonfly*], [
+ if test "$rb_cv_binary_elf" = no; then
+ with_dln_a_out=yes
+ else
+@@ -1772,7 +1772,7 @@ if test "$with_dln_a_out" != yes; then
+ [bsdi3*], [ AS_CASE(["$CC"],
+ [*shlicc*], [ : ${LDSHARED='$(CC) -r'}
+ rb_cv_dlopen=yes])],
+- [linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | kopensolaris*-gnu], [
++ [linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | kopensolaris*-gnu | freebsd7*], [
+ : ${LDSHARED='$(CC) -shared'}
+ if test "$rb_cv_binary_elf" = yes; then
+ LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
+@@ -1785,7 +1785,6 @@ if test "$with_dln_a_out" != yes; then
+ [freebsd*|dragonfly*], [
+ : ${LDSHARED='$(CC) -shared'}
+ if test "$rb_cv_binary_elf" = yes; then
+- LDFLAGS="$LDFLAGS -rdynamic"
+ DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$(.TARGET)'
+ else
+ test "$GCC" = yes && test "$rb_cv_prog_gnu_ld" = yes || LDSHARED="ld -Bshareable"
+@@ -2066,7 +2065,7 @@ if test "$enable_shared" = 'yes'; then
+ [sunos4*], [
+ LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
+ ],
+- [linux* | gnu* | k*bsd*-gnu | atheos* | kopensolaris*-gnu], [
++ [linux* | gnu* | k*bsd*-gnu | atheos* | kopensolaris*-gnu | freebsd7*], [
+ LIBRUBY_DLDFLAGS='-Wl,-soname,lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR)'
+ LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
+ ],
diff --git a/patchsets/patches-1.9.2_p290/005_no-undefined-ext.patch b/patchsets/patches-1.9.2_p290/005_no-undefined-ext.patch
new file mode 100644
index 0000000..1a4ca31
--- /dev/null
+++ b/patchsets/patches-1.9.2_p290/005_no-undefined-ext.patch
@@ -0,0 +1,13 @@
+Index: ruby-1.9.2-rc2/configure.in
+===================================================================
+--- ruby-1.9.2-rc2.orig/configure.in
++++ ruby-1.9.2-rc2/configure.in
+@@ -1775,7 +1775,7 @@ if test "$with_dln_a_out" != yes; then
+ [linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | kopensolaris*-gnu | freebsd7*], [
+ : ${LDSHARED='$(CC) -shared'}
+ if test "$rb_cv_binary_elf" = yes; then
+- LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
++ LDFLAGS="$LDFLAGS -Wl,-export-dynamic -Wl,--no-undefined"
+ fi
+ rb_cv_dlopen=yes],
+ [interix*], [ : ${LDSHARED='$(CC) -shared'}
diff --git a/patchsets/patches-1.9.2_p290/007_berkdb-5.0.patch b/patchsets/patches-1.9.2_p290/007_berkdb-5.0.patch
new file mode 100644
index 0000000..bc32020
--- /dev/null
+++ b/patchsets/patches-1.9.2_p290/007_berkdb-5.0.patch
@@ -0,0 +1,31 @@
+Index: ruby-1.9.2-rc2/ext/dbm/extconf.rb
+===================================================================
+--- ruby-1.9.2-rc2.orig/ext/dbm/extconf.rb
++++ ruby-1.9.2-rc2/ext/dbm/extconf.rb
+@@ -21,12 +21,12 @@ headers = {
+ def headers.db_check(db)
+ db_prefix = nil
+ have_gdbm = false
+- hsearch = nil
++ db_defs = nil
+
+ case db
+ when /^db2?$/
+ db_prefix = "__db_n"
+- hsearch = "-DDB_DBM_HSEARCH "
++ db_defs = %w[-DDB_DBM_HSEARCH -DHAVE_DBM]
+ when "gdbm"
+ have_gdbm = true
+ when "gdbm_compat"
+@@ -36,9 +36,9 @@ def headers.db_check(db)
+ db_prefix ||= ""
+
+ if (have_library(db, db_prefix+"dbm_open") || have_func(db_prefix+"dbm_open")) and
+- hdr = self.fetch(db, ["ndbm.h"]).find {|h| have_type("DBM", h, hsearch)}
++ hdr = self.fetch(db, ["ndbm.h"]).find {|h| have_type("DBM", h, db_defs.join(" "))}
+ have_func(db_prefix+"dbm_clearerr") unless have_gdbm
+- $defs << hsearch if hsearch
++ $defs += db_defs if db_defs
+ $defs << '-DDBM_HDR="<'+hdr+'>"'
+ true
+ else
diff --git a/patchsets/patches-1.9.2_p290/009_no-gems.patch b/patchsets/patches-1.9.2_p290/009_no-gems.patch
new file mode 100644
index 0000000..82b7f7e
--- /dev/null
+++ b/patchsets/patches-1.9.2_p290/009_no-gems.patch
@@ -0,0 +1,41 @@
+diff -Naur ruby-1.9.2-p290.orig/tool/rbinstall.rb ruby-1.9.2-p290/tool/rbinstall.rb
+--- ruby-1.9.2-p290.orig/tool/rbinstall.rb 2011-01-16 14:18:57.000000000 +0100
++++ ruby-1.9.2-p290/tool/rbinstall.rb 2011-08-29 11:20:23.365904481 +0200
+@@ -492,36 +492,7 @@
+ end
+
+ install?(:ext, :comm, :gem) do
+- directories = []
+- IO.foreach(File.join(srcdir, "lib/rubygems.rb")) do |line|
+- if /^\s*DIRECTORIES\s*=\s*%w\[(.*?)\]/ =~ line
+- directories = $1.split
+- break
+- end
+- end
+- gpath = CONFIG["sitelibdir"].sub(%r'/site_ruby/(?=[^/]+)', '/gems/')
+- prepare "default gems", gpath, directories
+-
+- destdir = File.join(gpath, directories.grep(/^spec/)[0])
+- default_gems = [
+- ['rake', 'rake.rb'],
+- ['rdoc', 'rdoc.rb'],
+- ['minitest', 'minitest/unit.rb'],
+- ]
+- default_gems.each do |name, src|
+- src = File.join(srcdir, "lib", src)
+- version = open(src) {|f| f.find {|s| /^\s*\w*VERSION\s*=(?!=)/ =~ s}} or next
+- version = version.split(%r"=\s*", 2)[1].strip[/\A([\'\"])(.*?)\1/, 2]
+- puts "#{" "*30}#{name} #{version}"
+- gemspec = <<-GEMSPEC
+-Gem::Specification.new do |s|
+- s.name = #{name.dump}
+- s.version = #{version.dump}
+- s.summary = "This #{name} is bundled with Ruby"
+-end
+- GEMSPEC
+- open_for_install(File.join(destdir, "#{name}-#{version}.gemspec"), $data_mode) { gemspec }
+- end
++ # gems are unbundled
+ end
+
+ parse_args()
diff --git a/patchsets/patches-1.9.2_p290/series b/patchsets/patches-1.9.2_p290/series
new file mode 100644
index 0000000..7cb11b8
--- /dev/null
+++ b/patchsets/patches-1.9.2_p290/series
@@ -0,0 +1,6 @@
+004_gfbsd7.patch
+005_no-undefined-ext.patch
+006_no-rake.patch
+007_berkdb-5.0.patch
+008_CVE-2010-0541.patch
+009_no-gems.patch