aboutsummaryrefslogtreecommitdiff
path: root/tools
diff options
context:
space:
mode:
authorAndrew Gaffney <agaffney@gentoo.org>2009-03-13 12:51:55 +0000
committerAndrew Gaffney <agaffney@gentoo.org>2009-03-13 12:51:55 +0000
commit928ea3e5807e0f911904a790580bf63a75e35ed1 (patch)
tree8cb0ecadcb970dfe64b1852beff755e0cd5ac9fe /tools
parentAdd --test flag (diff)
downloadreleng-928ea3e5807e0f911904a790580bf63a75e35ed1.tar.gz
releng-928ea3e5807e0f911904a790580bf63a75e35ed1.tar.bz2
releng-928ea3e5807e0f911904a790580bf63a75e35ed1.zip
Fix typo with multiple kernel code
svn path=/trunk/; revision=623
Diffstat (limited to 'tools')
-rw-r--r--tools/ChangeLog3
-rwxr-xr-xtools/catalyst-auto6
2 files changed, 6 insertions, 3 deletions
diff --git a/tools/ChangeLog b/tools/ChangeLog
index a04f2e90..df0c4e65 100644
--- a/tools/ChangeLog
+++ b/tools/ChangeLog
@@ -3,6 +3,9 @@
# $Id$
13 Mar 2009; Andrew Gaffney <agaffney@gentoo.org> catalyst-auto:
+ Fix typo with multiple kernel code
+
+ 13 Mar 2009; Andrew Gaffney <agaffney@gentoo.org> catalyst-auto:
Add --test flag
02 Mar 2009; Andrew Gaffney <agaffney@gentoo.org> catalyst-auto:
diff --git a/tools/catalyst-auto b/tools/catalyst-auto
index 03694545..6834c49b 100755
--- a/tools/catalyst-auto
+++ b/tools/catalyst-auto
@@ -166,9 +166,9 @@ for i in $(find -name '*.spec'); do
sed -i '/^livecd\/iso/s|'${old_version_stamp}'|'${new_version_stamp}'|' ${i}
- kconfig_line=$(grep '^boot/kernel/[^/]\+/config:' ${i})
- if [ -n "${kconfig_line}" ]; then
- echo "${kconfig_file}" | while read line; do
+ kconfig_lines=$(grep '^boot/kernel/[^/]\+/config:' ${i})
+ if [ -n "${kconfig_lines}" ]; then
+ echo "${kconfig_lines}" | while read line; do
key=$(echo "${line}" | cut -d: -f1)
filename=$(basename $(echo "${line}" | cut -d: -f2))
sed -i "s|^${key}:.*\$|${key}: ${TMPDIR}/kconfig/${filename}|" ${i}