aboutsummaryrefslogtreecommitdiff
path: root/tools
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2012-02-09 15:58:30 +0000
committerRaúl Porcel <armin76@gentoo.org>2012-02-09 15:58:30 +0000
commit8e2a4cec660094a2ae2682fad3658ea5a7456983 (patch)
tree82b2ba548019102c5cbe21f45bd9cc794c5fcb3d /tools
parentgcc-4.5 is stable now (diff)
downloadreleng-8e2a4cec660094a2ae2682fad3658ea5a7456983.tar.gz
releng-8e2a4cec660094a2ae2682fad3658ea5a7456983.tar.bz2
releng-8e2a4cec660094a2ae2682fad3658ea5a7456983.zip
Update confs to use git
Diffstat (limited to 'tools')
-rw-r--r--tools/catalyst-auto-alpha.conf9
-rw-r--r--tools/catalyst-auto-hppa.conf7
-rw-r--r--tools/catalyst-auto-ia64.conf9
-rw-r--r--tools/catalyst-auto-ppc.conf11
-rw-r--r--tools/catalyst-auto-ppc64.conf11
-rw-r--r--tools/catalyst-auto-sparc64.conf11
6 files changed, 33 insertions, 25 deletions
diff --git a/tools/catalyst-auto-alpha.conf b/tools/catalyst-auto-alpha.conf
index 17231cfb..1d1bc2f0 100644
--- a/tools/catalyst-auto-alpha.conf
+++ b/tools/catalyst-auto-alpha.conf
@@ -1,9 +1,9 @@
# This is the config file for the catalyst-auto script. It should be pretty
# self-explanatory.
-SVNDIR=/home/armin76/releng
+GITDIR=/home/armin76/releng
-SPECS_DIR=${SVNDIR}/trunk/releases/weekly/specs/alpha
+SPECS_DIR=${GITDIR}/releases/weekly/specs/alpha
SPECS="stage1.spec stage2.spec stage3.spec"
#SPECS="${SPECS} installcd-stage1.spec installcd-stage2-minimal.spec"
@@ -12,7 +12,7 @@ SPECS="stage1.spec stage2.spec stage3.spec"
OPTIONAL_SPECS="installcd-stage1.spec installcd-stage2-minimal.spec"
-KCONFIG_DIR=${SVNDIR}/trunk/releases/weekly/kconfig/alpha
+KCONFIG_DIR=${GITDIR}/releases/weekly/kconfig/alpha
EMAIL_TO=releng@gentoo.org,gentoo-releng-autobuilds@lists.gentoo.org
#EMAIL_FROM=catalyst@monolith.alpha.dev.gentoo.org
@@ -22,7 +22,8 @@ EMAIL_SUBJECT_PREPEND="[alpha-auto]"
CATALYST_CONFIG=/etc/catalyst/catalyst.conf
pre_build() {
- svn up ${SVNDIR}
+ cd ${GITDIR}
+ git pull
}
post_build() {
diff --git a/tools/catalyst-auto-hppa.conf b/tools/catalyst-auto-hppa.conf
index 2b873c4c..ee8deac9 100644
--- a/tools/catalyst-auto-hppa.conf
+++ b/tools/catalyst-auto-hppa.conf
@@ -1,9 +1,9 @@
# This is the config file for the catalyst-auto script. It should be pretty
# self-explanatory.
-SVNDIR=/home/armin76/releng
+GITDIR=/home/armin76/releng
-SPECS_DIR=${SVNDIR}/trunk/releases/weekly/specs/hppa
+SPECS_DIR=${GITDIR}/releases/weekly/specs/hppa
SETS="hppa1_1 hppa2_0"
@@ -20,7 +20,8 @@ EMAIL_SUBJECT_PREPEND="[hppa-auto]"
CATALYST_CONFIG=/etc/catalyst/catalyst.conf
pre_build() {
- svn up ${SVNDIR}
+ cd ${GITDIR}
+ git pull
}
post_build() {
diff --git a/tools/catalyst-auto-ia64.conf b/tools/catalyst-auto-ia64.conf
index db9ec23b..46eae3dd 100644
--- a/tools/catalyst-auto-ia64.conf
+++ b/tools/catalyst-auto-ia64.conf
@@ -1,9 +1,9 @@
# This is the config file for the catalyst-auto script. It should be pretty
# self-explanatory.
-SVNDIR=/root/releng
+GITDIR=/root/releng
-SPECS_DIR=${SVNDIR}/trunk/releases/weekly/specs/ia64
+SPECS_DIR=${GITDIR}/releases/weekly/specs/ia64
SPECS="stage1.spec stage2.spec stage3.spec"
#SPECS="${SPECS} installcd-stage1.spec installcd-stage2-minimal.spec"
@@ -12,7 +12,7 @@ SPECS="stage1.spec stage2.spec stage3.spec"
OPTIONAL_SPECS="installcd-stage1.spec installcd-stage2-minimal.spec"
-KCONFIG_DIR=${SVNDIR}/trunk/releases/weekly/kconfig/ia64
+KCONFIG_DIR=${GITDIR}/releases/weekly/kconfig/ia64
EMAIL_TO=releng@gentoo.org,gentoo-releng-autobuilds@lists.gentoo.org
EMAIL_FROM=catalyst@dolphin.ia64.dev.gentoo.org
@@ -21,7 +21,8 @@ EMAIL_SUBJECT_PREPEND="[ia64-auto]"
CATALYST_CONFIG=/etc/catalyst/catalyst.conf
pre_build() {
- svn up ${SVNDIR}
+ cd ${GITDIR}
+ git pull
}
post_build() {
diff --git a/tools/catalyst-auto-ppc.conf b/tools/catalyst-auto-ppc.conf
index 6ca9f54a..08d76da4 100644
--- a/tools/catalyst-auto-ppc.conf
+++ b/tools/catalyst-auto-ppc.conf
@@ -1,9 +1,9 @@
# This is the config file for the catalyst-auto script. It should be pretty
# self-explanatory.
-SVNDIR=/home/armin76/releng
+GITDIR=/home/armin76/releng
-SPECS_DIR=${SVNDIR}/trunk/releases/weekly/specs/ppc/ppc32
+SPECS_DIR=${GITDIR}/releases/weekly/specs/ppc/ppc32
SPECS="stage1.spec stage2.spec stage3.spec"
#SPECS="${SPECS} installcd-stage1.spec installcd-stage2-minimal.spec"
@@ -12,16 +12,17 @@ SPECS="stage1.spec stage2.spec stage3.spec"
#OPTIONAL_SPECS="installcd-stage1.spec installcd-stage2-minimal.spec"
-KCONFIG_DIR=${SVNDIR}/trunk/releases/weekly/kconfig/powerpc
+KCONFIG_DIR=${GITDIR}/releases/weekly/kconfig/powerpc
EMAIL_TO=releng@gentoo.org,gentoo-releng-autobuilds@lists.gentoo.org
-EMAIL_FROM=catalyst@rooster.ppc64.dev.gentoo.org
+EMAIL_FROM=catalyst@timberdoodle.ppc64.dev.gentoo.org
EMAIL_SUBJECT_PREPEND="[ppc-auto]"
CATALYST_CONFIG=/etc/catalyst/catalyst.conf
pre_build() {
- svn up ${SVNDIR}
+ cd ${GITDIR}
+ git pull
}
post_build() {
diff --git a/tools/catalyst-auto-ppc64.conf b/tools/catalyst-auto-ppc64.conf
index b8bdec66..6888164b 100644
--- a/tools/catalyst-auto-ppc64.conf
+++ b/tools/catalyst-auto-ppc64.conf
@@ -1,9 +1,9 @@
# This is the config file for the catalyst-auto script. It should be pretty
# self-explanatory.
-SVNDIR=/home/armin76/releng
+GITDIR=/home/armin76/releng
-SPECS_DIR=${SVNDIR}/trunk/releases/weekly/specs/ppc/ppc64
+SPECS_DIR=${GITDIR}/releases/weekly/specs/ppc/ppc64
SPECS="stage1-32ul.spec stage2-32ul.spec stage3-32ul.spec stage1-64ul.spec stage2-64ul.spec stage3-64ul.spec"
@@ -13,16 +13,17 @@ SPECS="stage1-32ul.spec stage2-32ul.spec stage3-32ul.spec stage1-64ul.spec stage
OPTIONAL_SPECS="installcd-stage1.spec installcd-stage2-minimal.spec"
-KCONFIG_DIR=${SVNDIR}/trunk/releases/weekly/kconfig/powerpc
+KCONFIG_DIR=${GITDIR}/releases/weekly/kconfig/powerpc
EMAIL_TO=releng@gentoo.org,gentoo-releng-autobuilds@lists.gentoo.org
-EMAIL_FROM=catalyst@rooster.ppc64.dev.gentoo.org
+EMAIL_FROM=catalyst@timberdoodle.ppc64.dev.gentoo.org
EMAIL_SUBJECT_PREPEND="[ppc64-auto]"
CATALYST_CONFIG=/etc/catalyst/catalyst.conf
pre_build() {
- svn up ${SVNDIR}
+ cd ${GITDIR}
+ git pull
}
post_build() {
diff --git a/tools/catalyst-auto-sparc64.conf b/tools/catalyst-auto-sparc64.conf
index cbe32fee..04e4b81d 100644
--- a/tools/catalyst-auto-sparc64.conf
+++ b/tools/catalyst-auto-sparc64.conf
@@ -1,7 +1,9 @@
# This is the config file for the catalyst-auto script. It should be pretty
# self-explanatory.
-SPECS_DIR=/root/releng/svn-releng/trunk/releases/weekly/specs/sparc/sparc64
+GITDIR=/root/releng/
+
+SPECS_DIR=${GITDIR}/releases/weekly/specs/sparc/sparc64
SPECS="stage1.spec stage2.spec stage3.spec"
#SPECS="${SPECS} installcd-stage1.spec installcd-stage2-minimal.spec"
@@ -10,16 +12,17 @@ SPECS="stage1.spec stage2.spec stage3.spec"
OPTIONAL_SPECS="installcd-stage1.spec installcd-stage2-minimal.spec"
-KCONFIG_DIR=/root/releng/svn-releng/trunk/releases/weekly/kconfig/sparc
+KCONFIG_DIR=${GITDIR}/releases/weekly/kconfig/sparc
EMAIL_TO=releng@gentoo.org,gentoo-releng-autobuilds@lists.gentoo.org
-EMAIL_FROM=catalyst@bender.sparc64.dev.gentoo.org
+EMAIL_FROM=catalyst@bender.sparc.dev.gentoo.org
EMAIL_SUBJECT_PREPEND="[sparc64-auto]"
CATALYST_CONFIG=/etc/catalyst/catalyst.conf
pre_build() {
- svn up /root/releng/svn-releng/
+ cd ${GITDIR}
+ git pull
}
post_build() {