aboutsummaryrefslogtreecommitdiff
path: root/tools
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2023-12-14 23:33:18 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2023-12-14 23:33:18 +0100
commit3e97eeedb8b0fa38b327bc152523851f11ef7f23 (patch)
tree59e318093278b807ba0c4334e96dd46fb32643ef /tools
parentStop building and uploading amd64 systemd split-usr stages (diff)
downloadreleng-3e97eeedb8b0fa38b327bc152523851f11ef7f23.tar.gz
releng-3e97eeedb8b0fa38b327bc152523851f11ef7f23.tar.bz2
releng-3e97eeedb8b0fa38b327bc152523851f11ef7f23.zip
Stop building and uploading arm systemd split-usr stages, sync with openrc
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'tools')
-rw-r--r--tools/catalyst-auto-arm.conf26
1 files changed, 1 insertions, 25 deletions
diff --git a/tools/catalyst-auto-arm.conf b/tools/catalyst-auto-arm.conf
index 7610aa91..fe7383d8 100644
--- a/tools/catalyst-auto-arm.conf
+++ b/tools/catalyst-auto-arm.conf
@@ -30,39 +30,33 @@ SETS="
"
SET_armv4tl_openrc_SPECS="armv4tl/stage1-openrc.spec armv4tl/stage3-openrc.spec"
-SET_armv4tl_systemd_SPECS="armv4tl/stage1-systemd.spec armv4tl/stage3-systemd.spec"
SET_armv4tl_systemd_mu_SPECS="armv4tl/stage1-systemd-mu.spec armv4tl/stage3-systemd-mu.spec"
SET_armv5tel_openrc_SPECS="armv5tel/stage1-openrc.spec armv5tel/stage3-openrc.spec"
-SET_armv5tel_systemd_SPECS="armv5tel/stage1-systemd.spec armv5tel/stage3-systemd.spec"
SET_armv5tel_systemd_mu_SPECS="armv5tel/stage1-systemd-mu.spec armv5tel/stage3-systemd-mu.spec"
SET_armv6j_hf_openrc_SPECS="armv6j/stage1-hardfloat-openrc.spec armv6j/stage3-hardfloat-openrc.spec"
-SET_armv6j_hf_systemd_SPECS="armv6j/stage1-hardfloat-systemd.spec armv6j/stage3-hardfloat-systemd.spec"
SET_armv6j_hf_systemd_mu_SPECS="armv6j/stage1-hardfloat-systemd-mu.spec armv6j/stage3-hardfloat-systemd-mu.spec"
SET_armv6j_sf_openrc_SPECS="armv6j/stage1-openrc.spec armv6j/stage3-openrc.spec"
-SET_armv6j_sf_systemd_SPECS="armv6j/stage1-systemd.spec armv6j/stage3-systemd.spec"
SET_armv6j_sf_systemd_mu_SPECS="armv6j/stage1-systemd-mu.spec armv6j/stage3-systemd-mu.spec"
SET_armv6j_hf_musl_openrc_SPECS="armv6j-musl/stage1-hardfloat.spec armv6j-musl/stage3-hardfloat.spec"
SET_armv6j_hf_musl_hardened_openrc_SPECS="armv6j-musl-hardened/stage1-hardfloat.spec armv6j-musl-hardened/stage3-hardfloat.spec"
SET_armv7a_hf_openrc_SPECS="armv7a/stage1-hardfloat-openrc.spec armv7a/stage3-hardfloat-openrc.spec"
-SET_armv7a_hf_systemd_SPECS="armv7a/stage1-hardfloat-systemd.spec armv7a/stage3-hardfloat-systemd.spec"
SET_armv7a_hf_systemd_mu_SPECS="armv7a/stage1-hardfloat-systemd-mu.spec armv7a/stage3-hardfloat-systemd-mu.spec"
SET_armv7a_hf_musl_openrc_SPECS="armv7a-musl/stage1-hardfloat.spec armv7a-musl/stage3-hardfloat.spec"
SET_armv7a_hf_musl_hardened_openrc_SPECS="armv7a-musl-hardened/stage1-hardfloat.spec armv7a-musl-hardened/stage3-hardfloat.spec"
SET_armv7a_sf_openrc_SPECS="armv7a/stage1-openrc.spec armv7a/stage3-openrc.spec"
-SET_armv7a_sf_systemd_SPECS="armv7a/stage1-systemd.spec armv7a/stage3-systemd.spec"
SET_armv7a_sf_systemd_mu_SPECS="armv7a/stage1-systemd-mu.spec armv7a/stage3-systemd-mu.spec"
update_symlinks() {
# Symlink the latest stages3 to build from
local d f
- for d in "${BUILD_SRCDIR_BASE}/builds/default" "${BUILD_SRCDIR_BASE}/builds/musl" "${BUILD_SRCDIR_BASE}/builds/musl-hardened" "${BUILD_SRCDIR_BASE}/builds/mergedusr" ; do
+ for d in "${BUILD_SRCDIR_BASE}/builds"/* ; do
mkdir -p "${d}"
pushd "${d}" >/dev/null
for f in $(ls stage3*xz | grep -v latest | give_latest_from_dates) ; do
@@ -81,44 +75,26 @@ post_build() {
case ${spec} in
armv4tl/stage3-openrc.spec)
upload stage3-armv4tl-openrc-${TIMESTAMP}*.xz*
- ;;
- armv4tl/stage3-systemd.spec)
- upload stage3-armv4tl-systemd-${TIMESTAMP}*.xz*
upsync_binpackages "${BUILD_SRCDIR_BASE}/packages/default/stage3-armv4tl" arm/17.0/armv4tl
;;
armv5tel/stage3-openrc.spec)
upload stage3-armv5tel-openrc-${TIMESTAMP}*.xz*
- ;;
- armv5tel/stage3-systemd.spec)
- upload stage3-armv5tel-systemd-${TIMESTAMP}*.xz*
upsync_binpackages "${BUILD_SRCDIR_BASE}/packages/default/stage3-armv5tel" arm/17.0/armv5tel
;;
armv6j/stage3-openrc.spec)
upload stage3-armv6j-openrc-${TIMESTAMP}*.xz*
- ;;
- armv6j/stage3-systemd.spec)
- upload stage3-armv6j-systemd-${TIMESTAMP}*.xz*
upsync_binpackages "${BUILD_SRCDIR_BASE}/packages/default/stage3-armv6j" arm/17.0/armv6j
;;
armv6j/stage3-hardfloat-openrc.spec)
upload stage3-armv6j_hardfp-openrc-${TIMESTAMP}*.xz*
- ;;
- armv6j/stage3-hardfloat-systemd.spec)
- upload stage3-armv6j_hardfp-systemd-${TIMESTAMP}*.xz*
upsync_binpackages "${BUILD_SRCDIR_BASE}/packages/default/stage3-armv6j_hardfp" arm/17.0/armv6j_hardfp
;;
armv7a/stage3-openrc.spec)
upload stage3-armv7a-openrc-${TIMESTAMP}*.xz*
- ;;
- armv7a/stage3-systemd.spec)
- upload stage3-armv7a-systemd-${TIMESTAMP}*.xz*
upsync_binpackages "${BUILD_SRCDIR_BASE}/packages/default/stage3-armv7a" arm/17.0/armv7a
;;
armv7a/stage3-hardfloat-openrc.spec)
upload stage3-armv7a_hardfp-openrc-${TIMESTAMP}*.xz*
- ;;
- armv7a/stage3-hardfloat-systemd.spec)
- upload stage3-armv7a_hardfp-systemd-${TIMESTAMP}*.xz*
upsync_binpackages "${BUILD_SRCDIR_BASE}/packages/default/stage3-armv7a_hardfp" arm/17.0/armv7a_hardfp
;;
esac