aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2021-04-05 20:57:34 +0200
committerJimi Huotari <chiitoo@gentoo.org>2021-04-10 21:42:35 +0300
commitf1af6b5805597842134f0b4074bd4148747de1ff (patch)
tree200f81bdb400a6e4f6546748d4bc00cd1fbbd1fe /media-gfx
parentx11-libs/libfm-qt: fix QA warning (diff)
downloadqt-f1af6b5805597842134f0b4074bd4148747de1ff.tar.gz
qt-f1af6b5805597842134f0b4074bd4148747de1ff.tar.bz2
qt-f1af6b5805597842134f0b4074bd4148747de1ff.zip
media-gfx/lximage-qt: fix QA warning
Fix a QA warning regarding desktop database cache. Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/qt/pull/235 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/lximage-qt/lximage-qt-9999.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/media-gfx/lximage-qt/lximage-qt-9999.ebuild b/media-gfx/lximage-qt/lximage-qt-9999.ebuild
index a3b7f236..ae246ee3 100644
--- a/media-gfx/lximage-qt/lximage-qt-9999.ebuild
+++ b/media-gfx/lximage-qt/lximage-qt-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake
+inherit cmake xdg-utils
DESCRIPTION="LXImage Image Viewer - GPicView replacement"
HOMEPAGE="https://lxqt.org/"
@@ -40,3 +40,11 @@ DEPEND="
x11-libs/libXfixes
"
RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}