aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-04-20 20:35:02 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-04-20 20:35:02 +0200
commit74f9320a877a8e04bd88427e9ec5fe1724ed2206 (patch)
tree087fd0c899d76eb6aa2b4cf75d515006e078d0a9 /dev-qt/linguist
parentdev-qt: Drop Qt 5.14 stable branch (diff)
downloadqt-74f9320a877a8e04bd88427e9ec5fe1724ed2206.tar.gz
qt-74f9320a877a8e04bd88427e9ec5fe1724ed2206.tar.bz2
qt-74f9320a877a8e04bd88427e9ec5fe1724ed2206.zip
dev-qt: Add Qt 5.15.0_beta4
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/linguist')
-rw-r--r--dev-qt/linguist/Manifest1
-rw-r--r--dev-qt/linguist/linguist-5.15.0_beta4.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-qt/linguist/Manifest b/dev-qt/linguist/Manifest
index ef8f25d4..a8311775 100644
--- a/dev-qt/linguist/Manifest
+++ b/dev-qt/linguist/Manifest
@@ -1 +1,2 @@
DIST qttools-everywhere-src-5.15.0-beta3.tar.xz 8848720 BLAKE2B d9cded536a75a3ac8f78f1c4cce5121546fd558e2ca60b0e487a392026ee6d6a7b9e2e42869cab6c56a3e61317deb0441e1994589be7528facad7abc440a151e SHA512 48838585d16789450146fd726087c117e567003a9660f2a07898460cb4bbd0becc4df2408c2cac84c8f1986f9894a24d32b82b4783d4284c83cac9b7f4fb25a4
+DIST qttools-everywhere-src-5.15.0-beta4.tar.xz 8850836 BLAKE2B a8ec7316ae9c004ac2fc87c5fda162944e03c7d83c0c16627fdb0a4fb48808d6e18be57a7fb90c31b4094c24b929fc620725355cd8b03db3fabf51aeaccb71df SHA512 90a71dd80d6435e782d24c6c3e3b7e76aa0c425f42d8ea1e6164f4364ffcf4d77fd6bace36ebe4340c3015a3dcf775ab96c0faead01d56bccf8187fbd0c27a2a
diff --git a/dev-qt/linguist/linguist-5.15.0_beta4.ebuild b/dev-qt/linguist/linguist-5.15.0_beta4.ebuild
new file mode 100644
index 00000000..4aa1294c
--- /dev/null
+++ b/dev-qt/linguist/linguist-5.15.0_beta4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+QT5_MODULE="qttools"
+inherit desktop qt5-build xdg-utils
+
+DESCRIPTION="Graphical tool for translating Qt applications"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~x86"
+fi
+
+IUSE=""
+
+DEPEND="
+ ~dev-qt/designer-${PV}
+ ~dev-qt/qtcore-${PV}:5=
+ ~dev-qt/qtgui-${PV}:5=
+ ~dev-qt/qtprintsupport-${PV}
+ ~dev-qt/qtwidgets-${PV}
+ ~dev-qt/qtxml-${PV}
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/linguist/linguist
+)
+
+src_install() {
+ qt5-build_src_install
+
+ local size
+ for size in 16 32 48 64 128; do
+ newicon -s ${size} src/linguist/linguist/images/icons/linguist-${size}-32.png linguist.png
+ done
+ make_desktop_entry "${QT5_BINDIR}"/linguist 'Qt 5 Linguist' linguist 'Qt;Development;Translation'
+}
+
+pkg_postinst() {
+ qt5-build_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ qt5-build_pkg_postrm
+ xdg_icon_cache_update
+}