aboutsummaryrefslogtreecommitdiff
path: root/lib
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-08-31 10:35:11 +0200
committerSam James <sam@gentoo.org>2024-09-11 02:38:59 +0100
commit9f919c387fbc4c8526535b03fb781ab2a01ddfdd (patch)
treef501f0581a3704207c21cce7ce8c6c3c9460cda5 /lib
parentNEWS, meson.build: prepare for portage-3.0.66 (diff)
downloadportage-9f919c387fbc4c8526535b03fb781ab2a01ddfdd.tar.gz
portage-9f919c387fbc4c8526535b03fb781ab2a01ddfdd.tar.bz2
portage-9f919c387fbc4c8526535b03fb781ab2a01ddfdd.zip
JobStatusDisplay: fix setting the default width to 100
This fixes a28a0fd66002 ("JobStatusDisplay: increase the default width to 100") which attempted to set the default width to 100. However, the out of bounds check in _set_width() was not adjusted. Therefore, the default width was effectively still 80. Fixes: a28a0fd6600242a2e062a0fd2d7d5be95296b7ae Signed-off-by: Florian Schmaus <flow@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'lib')
-rw-r--r--lib/_emerge/JobStatusDisplay.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/_emerge/JobStatusDisplay.py b/lib/_emerge/JobStatusDisplay.py
index 78fd8f761..6506aed7d 100644
--- a/lib/_emerge/JobStatusDisplay.py
+++ b/lib/_emerge/JobStatusDisplay.py
@@ -71,8 +71,8 @@ class JobStatusDisplay:
def _set_width(self, width):
if width == getattr(self, "width", None):
return
- if width <= 0 or width > 80:
- width = 80
+ if width <= 0 or width > 100:
+ width = 100
object.__setattr__(self, "width", width)
object.__setattr__(self, "_jobs_column_width", width - 32)