diff options
-rw-r--r-- | .gitignore | 1 | ||||
-rwxr-xr-x | setup.py | 6 |
2 files changed, 6 insertions, 1 deletions
@@ -3,3 +3,4 @@ /build /dist /doc/*.html +/doc/html/ @@ -5,7 +5,7 @@ from distutils.core import setup, Command, Distribution -import os.path, sys +import os.path, subprocess, sys sys.path.insert(0, os.path.dirname(__file__)) try: @@ -80,6 +80,10 @@ class DocCommand(Command): m.convertFile(f, d) self.outfiles.append(d) + print('Creating API docs') + subprocess.check_call(['epydoc', '--verbose', '--html', + '--output', os.path.join('doc', 'html'), 'pmstestsuite']) + def get_inputs(self): return self.docs or [] |