aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'modules/pam_unix/Makefile')
-rw-r--r--modules/pam_unix/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/modules/pam_unix/Makefile b/modules/pam_unix/Makefile
index 314c0e0..ae80af4 100644
--- a/modules/pam_unix/Makefile
+++ b/modules/pam_unix/Makefile
@@ -17,18 +17,17 @@ MANMODE = 644
PROJ = $(LIBSHARED)
-OBJS = pam_unix.c
+OBJS = pam_unix.o
all:
case "`uname -s`" in \
- Linux) $(MAKE) -I$(INCDIR) CFLAGS="$(CFLAGS) -DHAVE_SHADOW" \
- -L$(LDDIR) LDFLAGS="$(LDFLAGS)" LDLIBS="$(LDLIBS)" \
- $(PROJ);;\
+ Linux) $(MAKE) CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" \
+ LDLIBS="$(LDLIBS)" $(PROJ);;\
FreeBSD) echo "Not yet supported.";;\
*) echo "OS not supported.";;\
esac
-$(LIBSHARED): $(OBJS) $(MAP)
+$(LIBSHARED): $(OBJS)
$(LD) $(LDFLAGS) $(OBJS) $(LDLIBS) -o $(LIBSHARED)
.c.o: