summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/x2goclient/x2goclient-2.99.3.ebuild')
-rw-r--r--net-misc/x2goclient/x2goclient-2.99.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/x2goclient/x2goclient-2.99.3.ebuild b/net-misc/x2goclient/x2goclient-2.99.3.ebuild
new file mode 100644
index 0000000..54abc62
--- /dev/null
+++ b/net-misc/x2goclient/x2goclient-2.99.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+inherit qt4 versionator
+
+MAJOR_PV="$(get_version_component_range 1-2)"
+FULL_PV="${MAJOR_PV}-$(get_version_component_range 3)"
+DESCRIPTION="The X2Go Qt client"
+HOMEPAGE="http://x2go.berlios.de"
+SRC_URI="http://x2go.obviously-nice.de/deb/pool-lenny/${PN}/${PN}_${FULL_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap"
+
+DEPEND="net-misc/nx
+ || ( ( x11-libs/qt-core:4 x11-libs/qt-gui:4 x11-libs/qt-svg:4 )
+ >=x11-libs/qt-4.3:4 )
+ ldap? ( net-nds/openldap )"
+
+S=${WORKDIR}/${PN}-${MAJOR_PV}
+
+src_prepare() {
+ use ldap || epatch "${FILESDIR}"/${PN}-2.0.1-noldap.patch
+}
+
+src_compile() {
+ eqmake4
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+}