aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mk/scripts.mk')
-rw-r--r--mk/scripts.mk13
1 files changed, 10 insertions, 3 deletions
diff --git a/mk/scripts.mk b/mk/scripts.mk
index 7e512f0..d278ac1 100644
--- a/mk/scripts.mk
+++ b/mk/scripts.mk
@@ -14,7 +14,13 @@ _LCL_SED:= $(shell ${_LCL_SED_SH})
SED_REPLACE= -e 's:@SHELL@:${SH}:g' -e 's:@LIB@:${LIBNAME}:g' -e 's:@SYSCONFDIR@:${SYSCONFDIR}:g' -e 's:@CONFDIR@:${CONFDIR}:g' -e 's:@LIBEXECDIR@:${LIBEXECDIR}:g' -e 's:@PREFIX@:${PREFIX}:g' -e 's:@BINDIR@:${BINDIR}:g' -e 's:@SBINDIR@:${SBINDIR}:g' -e 's:@INITDIR@:${INITDIR}:g' ${_PKG_SED} ${_LCL_SED}
-SHELLCHECK_CMD = shellcheck -s sh --exclude SC1008 -f gcc
+# SC1008: shebang
+# SC2039: warning: In POSIX sh, 'local' is undefined.
+# SC2086: splitting
+# SC2155: declare/assign
+# warning: domain is referenced but not assigned. [SC2154]
+# note: Don't use variables in the printf format string. Use printf "..%s.." "$foo". [SC2059]
+SHELLCHECK_CMD = shellcheck -s sh --exclude SC1008,SC2039,SC2086,SC2155,SC2154,SC2059 -f gcc
# Tweak our shell scripts
%.sh: %.sh.in
@@ -57,7 +63,8 @@ CLEANFILES+= ${OBJS}
clean:
@if test -n "${CLEANFILES}"; then echo "rm -f ${CLEANFILES}"; rm -f ${CLEANFILES}; fi
-shellcheck: ${SRCS}
- @$(SHELLCHECK_CMD) $<
+shellcheck: $(filter net.lo.in net.example.in %.sh.in, ${SRCS}) $(filter %.sh, ${INC})
+ @${ECHO} CHECKING $^
+ @$(SHELLCHECK_CMD) $^
include ${MK}/gitignore.mk