aboutsummaryrefslogtreecommitdiff
path: root/mk/os.mk
diff options
context:
space:
mode:
authorWilliam Hubbs <w.d.hubbs@gmail.com>2013-03-18 17:10:58 -0500
committerWilliam Hubbs <w.d.hubbs@gmail.com>2013-04-06 17:26:10 -0500
commit1e6cef540789ce8b781eb3037ff7058c1a07c07d (patch)
treece43b4782513deea473fc9aa3348c146307dda4f /mk/os.mk
downloadnetifrc-1e6cef540789ce8b781eb3037ff7058c1a07c07d.tar.gz
netifrc-1e6cef540789ce8b781eb3037ff7058c1a07c07d.tar.bz2
netifrc-1e6cef540789ce8b781eb3037ff7058c1a07c07d.zip
initial commit ported from OpenRc
Diffstat (limited to 'mk/os.mk')
-rw-r--r--mk/os.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/mk/os.mk b/mk/os.mk
new file mode 100644
index 0000000..c306f05
--- /dev/null
+++ b/mk/os.mk
@@ -0,0 +1,11 @@
+# Copyright (c) 2008 Roy Marples <roy@marples.name>
+# Released under the 2-clause BSD license.
+
+# Generic definitions
+
+_OS_SH= uname -s
+_OS:= $(shell ${_OS_SH})
+OS?= ${_OS}
+include ${MK}/os-${OS}.mk
+
+RC_LIB= /$(LIBNAME)/rc