aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Everitt <gentoo@veremit.xyz>2020-09-08 18:24:20 +0100
committerJory Pratt <anarchy@gentoo.org>2020-11-08 14:06:56 -0600
commit239e233b5b2eed128d9d425aabd6b26ed65a931b (patch)
tree7084ad60f8e8f4ae3972afedafda007a77886c73 /net-misc
parentdev-java/icedtea-bin: sync stable keywords with ::gentoo (diff)
downloadmusl-239e233b5b2eed128d9d425aabd6b26ed65a931b.tar.gz
musl-239e233b5b2eed128d9d425aabd6b26ed65a931b.tar.bz2
musl-239e233b5b2eed128d9d425aabd6b26ed65a931b.zip
net-misc/connman: Sync with ::gentoo, bump to 1.38, update patches
Closes: https://github.com/gentoo/musl/pull/346 Package-Manager: Portage-2.3.84, Repoman-2.3.11 Signed-off-by: Michael Everitt <gentoo@veremit.xyz> Signed-off-by: Jory Pratt <anarchy@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/connman/Manifest1
-rw-r--r--net-misc/connman/connman-1.38.ebuild106
-rw-r--r--net-misc/connman/connman-9999.ebuild106
-rw-r--r--net-misc/connman/files/connman-1.38-musl-fixes.patch81
-rw-r--r--net-misc/connman/files/connman-9999-musl-fixes.patch81
-rw-r--r--net-misc/connman/metadata.xml9
6 files changed, 380 insertions, 4 deletions
diff --git a/net-misc/connman/Manifest b/net-misc/connman/Manifest
index f6fd7eaf..8900f8b4 100644
--- a/net-misc/connman/Manifest
+++ b/net-misc/connman/Manifest
@@ -1 +1,2 @@
DIST connman-1.35.tar.xz 686092 BLAKE2B 706d8333dc2fcbee8d0ef3849325c4975dfe312a7a542ee96859a1724e05b1302c244a0108ab70033b398301c235fb13cb9509e9147dc2bb049e900f3799cd98 SHA512 2234b4d18b038f9a33939035cddebd31c74ce962e5616c2c30b2912476612ef3f7d5b9edca64bf6e69fa358252ed432124e036ac3516b291b86695cb9a96c6a8
+DIST connman-1.38.tar.xz 749288 BLAKE2B 3f0ec95c87d9b3bf4f188e2523cb8ed97f462953ed95180fadf98bfe0d01c67a3b73e18e39d616e9299fa0251b9a86afea6161b9e280ae6999eb66e6bd5c4406 SHA512 9c8f77c4dd62763ccb9ea5cc5d285a8a1c51bb09a82eafc73246231557a4f627ae1e5e4a9df5e104457390ebba643349d7d67800a4ee4c17c6dceff192afe8d4
diff --git a/net-misc/connman/connman-1.38.ebuild b/net-misc/connman/connman-1.38.ebuild
new file mode 100644
index 00000000..bf2a96da
--- /dev/null
+++ b/net-misc/connman/connman-1.38.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+inherit autotools systemd tmpfiles
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/network/connman/connman.git"
+else
+ SRC_URI="https://www.kernel.org/pub/linux/network/${PN}/${P}.tar.xz"
+ KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
+fi
+
+DESCRIPTION="Provides a daemon for managing internet connections"
+HOMEPAGE="https://01.org/connman"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="bluetooth debug doc +ethernet examples iptables iwd l2tp networkmanager
++nftables ofono openconnect openvpn policykit pptp tools vpnc +wifi wireguard
+wispr"
+
+REQUIRED_USE="^^ ( iptables nftables )"
+BDEPEND="virtual/pkgconfig"
+RDEPEND=">=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.2.24
+ sys-libs/readline:0=
+ bluetooth? ( net-wireless/bluez )
+ iptables? ( >=net-firewall/iptables-1.4.8 )
+ iwd? ( net-wireless/iwd )
+ l2tp? ( net-dialup/xl2tpd )
+ nftables? (
+ >=net-libs/libnftnl-1.0.4:0=
+ >=net-libs/libmnl-1.0.0:0= )
+ ofono? ( net-misc/ofono )
+ openconnect? ( net-vpn/openconnect )
+ openvpn? ( net-vpn/openvpn )
+ policykit? ( sys-auth/polkit )
+ pptp? ( net-dialup/pptpclient )
+ vpnc? ( net-vpn/vpnc )
+ wifi? ( >=net-wireless/wpa_supplicant-2.0[dbus] )
+ wireguard? ( >=net-libs/libmnl-1.0.0:0= )
+ wispr? ( net-libs/gnutls )"
+
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.39"
+
+PATCHES=(
+ # musl fixes
+ "${FILESDIR}/${PN}-musl-libresolv.patch"
+ "${FILESDIR}/${P}-musl-fixes.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --with-systemdunitdir=$(systemd_get_systemunitdir) \
+ --with-tmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d \
+ --enable-client \
+ --enable-datafiles \
+ --enable-loopback=builtin \
+ $(use_enable bluetooth bluetooth builtin) \
+ $(use_enable debug) \
+ $(use_enable ethernet ethernet builtin) \
+ $(use_enable examples test) \
+ $(use_enable iwd) \
+ $(use_enable l2tp l2tp builtin) \
+ $(use_enable networkmanager nmcompat) \
+ $(use_enable ofono ofono builtin) \
+ $(use_enable openconnect openconnect builtin) \
+ $(use_enable openvpn openvpn builtin) \
+ $(use_enable policykit polkit builtin) \
+ $(use_enable pptp pptp builtin) \
+ $(use_enable tools) \
+ $(use_enable vpnc vpnc builtin) \
+ $(use_enable wifi wifi builtin) \
+ $(use_enable wireguard) \
+ $(use_enable wispr wispr builtin) \
+ --with-firewall=$(usex iptables "iptables" "nftables" ) \
+ --disable-iospm \
+ --disable-hh2serial-gps
+}
+
+src_install() {
+ default
+ dobin client/connmanctl
+
+ if use doc; then
+ dodoc doc/*.txt
+ fi
+ keepdir /usr/lib/${PN}/scripts
+ keepdir /var/lib/${PN}
+ newinitd "${FILESDIR}"/${PN}.initd2 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process /usr/lib/tmpfiles.d/connman_resolvconf.conf
+} \ No newline at end of file
diff --git a/net-misc/connman/connman-9999.ebuild b/net-misc/connman/connman-9999.ebuild
new file mode 100644
index 00000000..082263b7
--- /dev/null
+++ b/net-misc/connman/connman-9999.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+inherit autotools systemd tmpfiles
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/network/connman/connman.git"
+else
+ SRC_URI="https://www.kernel.org/pub/linux/network/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Provides a daemon for managing internet connections"
+HOMEPAGE="https://01.org/connman"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="bluetooth debug doc +ethernet examples iptables iwd l2tp networkmanager
++nftables ofono openconnect openvpn policykit pptp tools vpnc +wifi wireguard
+wispr"
+
+REQUIRED_USE="^^ ( iptables nftables )"
+BDEPEND="virtual/pkgconfig"
+RDEPEND=">=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.2.24
+ sys-libs/readline:0=
+ bluetooth? ( net-wireless/bluez )
+ iptables? ( >=net-firewall/iptables-1.4.8 )
+ iwd? ( net-wireless/iwd )
+ l2tp? ( net-dialup/xl2tpd )
+ nftables? (
+ >=net-libs/libnftnl-1.0.4:0=
+ >=net-libs/libmnl-1.0.0:0= )
+ ofono? ( net-misc/ofono )
+ openconnect? ( net-vpn/openconnect )
+ openvpn? ( net-vpn/openvpn )
+ policykit? ( sys-auth/polkit )
+ pptp? ( net-dialup/pptpclient )
+ vpnc? ( net-vpn/vpnc )
+ wifi? ( >=net-wireless/wpa_supplicant-2.0[dbus] )
+ wireguard? ( >=net-libs/libmnl-1.0.0:0= )
+ wispr? ( net-libs/gnutls )"
+
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.39"
+
+PATCHES=(
+ # musl fixes
+ "${FILESDIR}/${PN}-musl-libresolv.patch"
+ "${FILESDIR}/${P}-musl-fixes.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --with-systemdunitdir=$(systemd_get_systemunitdir) \
+ --with-tmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d \
+ --enable-client \
+ --enable-datafiles \
+ --enable-loopback=builtin \
+ $(use_enable bluetooth bluetooth builtin) \
+ $(use_enable debug) \
+ $(use_enable ethernet ethernet builtin) \
+ $(use_enable examples test) \
+ $(use_enable iwd) \
+ $(use_enable l2tp l2tp builtin) \
+ $(use_enable networkmanager nmcompat) \
+ $(use_enable ofono ofono builtin) \
+ $(use_enable openconnect openconnect builtin) \
+ $(use_enable openvpn openvpn builtin) \
+ $(use_enable policykit polkit builtin) \
+ $(use_enable pptp pptp builtin) \
+ $(use_enable tools) \
+ $(use_enable vpnc vpnc builtin) \
+ $(use_enable wifi wifi builtin) \
+ $(use_enable wireguard) \
+ $(use_enable wispr wispr builtin) \
+ --with-firewall=$(usex iptables "iptables" "nftables" ) \
+ --disable-iospm \
+ --disable-hh2serial-gps
+}
+
+src_install() {
+ default
+ dobin client/connmanctl
+
+ if use doc; then
+ dodoc doc/*.txt
+ fi
+ keepdir /usr/lib/${PN}/scripts
+ keepdir /var/lib/${PN}
+ newinitd "${FILESDIR}"/${PN}.initd2 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process /usr/lib/tmpfiles.d/connman_resolvconf.conf
+}
diff --git a/net-misc/connman/files/connman-1.38-musl-fixes.patch b/net-misc/connman/files/connman-1.38-musl-fixes.patch
new file mode 100644
index 00000000..043f13f1
--- /dev/null
+++ b/net-misc/connman/files/connman-1.38-musl-fixes.patch
@@ -0,0 +1,81 @@
+--- ./configure.ac.orig
++++ ./configure.ac
+@@ -171,6 +171,8 @@
+ AM_CONDITIONAL(PPTP, test "${enable_pptp}" != "no")
+ AM_CONDITIONAL(PPTP_BUILTIN, test "${enable_pptp}" = "builtin")
+
++AC_CHECK_MEMBERS([struct in6_pktinfo.ipi6_addr], [], [], [[#include <netinet/in.h>]])
++AC_CHECK_HEADERS(execinfo.h)
+ AC_CHECK_HEADERS(resolv.h, dummy=yes,
+ AC_MSG_ERROR(resolver header files are required))
+ AC_CHECK_LIB(resolv, ns_initparse, dummy=yes, [
+diff --git a/gdhcp/common.c b/gdhcp/common.c
+index e111150..ee4dc43 100644
+--- a/gdhcp/common.c
++++ b/gdhcp/common.c
+@@ -22,6 +22,7 @@
+ #include <config.h>
+ #endif
+
++#define _GNU_SOURCE
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <errno.h>
+@@ -31,7 +32,6 @@
+ #include <string.h>
+ #include <endian.h>
+ #include <net/if_arp.h>
+-#include <linux/if.h>
+ #include <netpacket/packet.h>
+ #include <net/ethernet.h>
+ #include <arpa/inet.h>
+@@ -39,6 +39,8 @@
+ #include "gdhcp.h"
+ #include "common.h"
+
++#include <linux/if.h>
++
+ static const DHCPOption client_options[] = {
+ { OPTION_IP, 0x01 }, /* subnet-mask */
+ { OPTION_IP | OPTION_LIST, 0x03 }, /* routers */
+diff --git a/src/log.c b/src/log.c
+index a693bd0..9054462 100644
+--- a/src/log.c
++++ b/src/log.c
+ static void signal_handler(int signo)
+diff --exclude '*.*o' -ru connman-1.24.orig/src/tethering.c connman-1.24/src/tethering.c
+--- connman-1.24.orig/src/tethering.c 2014-04-04 15:12:07.000000000 -0300
++++ connman-1.24/src/tethering.c 2014-07-18 20:39:12.091344804 -0300
+@@ -31,8 +31,6 @@
+ #include <string.h>
+ #include <fcntl.h>
+ #include <netinet/in.h>
+-#include <linux/sockios.h>
+-#include <linux/if_tun.h>
+ #include <linux/if_bridge.h>
+
+ #include "connman.h"
+diff '--exclude=*.*o' -ru connman-1.24.orig/gweb/gresolv.c connman-1.24/gweb/gresolv.c
+--- connman-1.24.orig/gweb/gresolv.c 2014-07-18 20:43:40.000000000 -0300
++++ connman-1.24/gweb/gresolv.c 2014-07-18 20:44:43.284681413 -0300
+@@ -24,6 +24,8 @@
+ #endif
+
+ #include <errno.h>
++#include <stdio.h>
++#include <ctype.h>
+ #include <unistd.h>
+ #include <stdarg.h>
+ #include <string.h>
+--- ./gdhcp/common.h.orig
++++ ./gdhcp/common.h
+@@ -18,6 +18,9 @@
+ * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+ *
+ */
++#ifdef HAVE_CONFIG_H
++#include <config.h>
++#endif
+
+ #include <netinet/udp.h>
+ #include <netinet/ip.h> \ No newline at end of file
diff --git a/net-misc/connman/files/connman-9999-musl-fixes.patch b/net-misc/connman/files/connman-9999-musl-fixes.patch
new file mode 100644
index 00000000..043f13f1
--- /dev/null
+++ b/net-misc/connman/files/connman-9999-musl-fixes.patch
@@ -0,0 +1,81 @@
+--- ./configure.ac.orig
++++ ./configure.ac
+@@ -171,6 +171,8 @@
+ AM_CONDITIONAL(PPTP, test "${enable_pptp}" != "no")
+ AM_CONDITIONAL(PPTP_BUILTIN, test "${enable_pptp}" = "builtin")
+
++AC_CHECK_MEMBERS([struct in6_pktinfo.ipi6_addr], [], [], [[#include <netinet/in.h>]])
++AC_CHECK_HEADERS(execinfo.h)
+ AC_CHECK_HEADERS(resolv.h, dummy=yes,
+ AC_MSG_ERROR(resolver header files are required))
+ AC_CHECK_LIB(resolv, ns_initparse, dummy=yes, [
+diff --git a/gdhcp/common.c b/gdhcp/common.c
+index e111150..ee4dc43 100644
+--- a/gdhcp/common.c
++++ b/gdhcp/common.c
+@@ -22,6 +22,7 @@
+ #include <config.h>
+ #endif
+
++#define _GNU_SOURCE
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <errno.h>
+@@ -31,7 +32,6 @@
+ #include <string.h>
+ #include <endian.h>
+ #include <net/if_arp.h>
+-#include <linux/if.h>
+ #include <netpacket/packet.h>
+ #include <net/ethernet.h>
+ #include <arpa/inet.h>
+@@ -39,6 +39,8 @@
+ #include "gdhcp.h"
+ #include "common.h"
+
++#include <linux/if.h>
++
+ static const DHCPOption client_options[] = {
+ { OPTION_IP, 0x01 }, /* subnet-mask */
+ { OPTION_IP | OPTION_LIST, 0x03 }, /* routers */
+diff --git a/src/log.c b/src/log.c
+index a693bd0..9054462 100644
+--- a/src/log.c
++++ b/src/log.c
+ static void signal_handler(int signo)
+diff --exclude '*.*o' -ru connman-1.24.orig/src/tethering.c connman-1.24/src/tethering.c
+--- connman-1.24.orig/src/tethering.c 2014-04-04 15:12:07.000000000 -0300
++++ connman-1.24/src/tethering.c 2014-07-18 20:39:12.091344804 -0300
+@@ -31,8 +31,6 @@
+ #include <string.h>
+ #include <fcntl.h>
+ #include <netinet/in.h>
+-#include <linux/sockios.h>
+-#include <linux/if_tun.h>
+ #include <linux/if_bridge.h>
+
+ #include "connman.h"
+diff '--exclude=*.*o' -ru connman-1.24.orig/gweb/gresolv.c connman-1.24/gweb/gresolv.c
+--- connman-1.24.orig/gweb/gresolv.c 2014-07-18 20:43:40.000000000 -0300
++++ connman-1.24/gweb/gresolv.c 2014-07-18 20:44:43.284681413 -0300
+@@ -24,6 +24,8 @@
+ #endif
+
+ #include <errno.h>
++#include <stdio.h>
++#include <ctype.h>
+ #include <unistd.h>
+ #include <stdarg.h>
+ #include <string.h>
+--- ./gdhcp/common.h.orig
++++ ./gdhcp/common.h
+@@ -18,6 +18,9 @@
+ * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+ *
+ */
++#ifdef HAVE_CONFIG_H
++#include <config.h>
++#endif
+
+ #include <netinet/udp.h>
+ #include <netinet/ip.h> \ No newline at end of file
diff --git a/net-misc/connman/metadata.xml b/net-misc/connman/metadata.xml
index e0b4e8fa..88deddf4 100644
--- a/net-misc/connman/metadata.xml
+++ b/net-misc/connman/metadata.xml
@@ -2,15 +2,12 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>dlan@gentoo.org</email>
- <name>Yixun Lan</name>
- </maintainer>
- <maintainer type="person">
<email>bkohler@gentoo.org</email>
<name>Ben Kohler</name>
</maintainer>
<use>
<flag name="ethernet">Enable ethernet support.</flag>
+ <flag name="iwd">Enable wifi support via net-wireless/iwd</flag>
<flag name="l2tp">Use <pkg>net-dialup/xl2tpd</pkg> for L2TP VPN support.</flag>
<flag name="iptables">Use <pkg>net-firewall/iptables</pkg> as firewall.</flag>
<flag name="nftables">Use <pkg>net-firewall/nftables</pkg> as firewall.</flag>
@@ -21,5 +18,9 @@
<flag name="tools">Enable testing tools.</flag>
<flag name="vpnc">Use <pkg>net-vpn/vpnc</pkg> for cisco VPN support.</flag>
<flag name="wispr">Enable support for WISPr hotspot logins.</flag>
+ <flag name="wireguard">Enable WireGuard VPN support.</flag>
</use>
+ <upstream>
+ <remote-id type="cpe">cpe:/a:intel:connman</remote-id>
+ </upstream>
</pkgmetadata>