aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-05-23 14:43:10 +0100
committerJory Pratt <anarchy@gentoo.org>2021-05-24 09:41:22 -0500
commit95fbfebf9a0e5061413382e9701f9d21b1da88e0 (patch)
treed7429e58a9f928deda8b07b820ce105dbe31b316
parentmedia-tv/kodi: use a stacksize of 1M for musl users (diff)
downloadmusl-95fbfebf9a0e5061413382e9701f9d21b1da88e0.tar.gz
musl-95fbfebf9a0e5061413382e9701f9d21b1da88e0.tar.bz2
musl-95fbfebf9a0e5061413382e9701f9d21b1da88e0.zip
sys-apps/tcp-wrappers: Sync with ::gentoo
Closes: https://github.com/gentoo/musl/pull/434 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Jory Pratt <anarchy@gentoo.org>
-rw-r--r--sys-apps/tcp-wrappers/tcp-wrappers-7.6.28-r1.ebuild (renamed from sys-apps/tcp-wrappers/tcp-wrappers-7.6.28.ebuild)11
1 files changed, 7 insertions, 4 deletions
diff --git a/sys-apps/tcp-wrappers/tcp-wrappers-7.6.28.ebuild b/sys-apps/tcp-wrappers/tcp-wrappers-7.6.28-r1.ebuild
index c756489a..901bca6f 100644
--- a/sys-apps/tcp-wrappers/tcp-wrappers-7.6.28.ebuild
+++ b/sys-apps/tcp-wrappers/tcp-wrappers-7.6.28-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-inherit toolchain-funcs flag-o-matic multilib-minimal usr-ldscript
+inherit toolchain-funcs multilib-minimal usr-ldscript
MY_PV=$(ver_cut 1-2)
DEB_PV=$(ver_cut 3)
@@ -18,7 +18,8 @@ SLOT="0"
KEYWORDS="amd64 arm arm64 ~mips ppc ppc64 x86"
IUSE="ipv6 netgroups static-libs"
-RDEPEND=""
+RDEPEND="netgroups? ( net-libs/libnsl:= )"
+DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}
@@ -52,7 +53,7 @@ temake() {
RANLIB="$(tc-getRANLIB)" \
COPTS="${CFLAGS} ${CPPFLAGS} ${mycppflags}" \
LDFLAGS="${LDFLAGS}" \
- "$@" || die
+ "$@"
}
multilib_src_configure() {
@@ -61,6 +62,8 @@ multilib_src_configure() {
}
multilib_src_compile() {
+ # https://bugs.gentoo.org/728348
+ unset STRINGS
temake all
}