aboutsummaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorAndrian Nord <nightnord@gmail.com>2009-11-13 11:48:29 +0100
committerDaniel Lezcano <dlezcano@fr.ibm.com>2009-11-13 11:48:29 +0100
commit3fb0a9bb6e13143e7a55f2a709ec84da923b6044 (patch)
tree0de09bba1efa5684d6f76601f9e147ee0e3ba3a4 /doc
parentlxc lxc-sshd using new lxc.mount.entry keyword (diff)
downloadlxc-3fb0a9bb6e13143e7a55f2a709ec84da923b6044.tar.gz
lxc-3fb0a9bb6e13143e7a55f2a709ec84da923b6044.tar.bz2
lxc-3fb0a9bb6e13143e7a55f2a709ec84da923b6044.zip
Q: general lxc architecture
Patch moves etc/* contents into doc/examples/ and adds --disable-examples configure switch which may be used not to install examples. Default is to install them into ${docdir}/examples (commonly: /usr/share/doc/lxc/examples) Signed-off-by: Andrian Nord <NightNord@gmail.com> Signed-off-by: Daniel Lezcano <dlezcano@fr.ibm.com>
Diffstat (limited to 'doc')
-rw-r--r--doc/Makefile.am2
-rw-r--r--doc/examples/Makefile.am21
-rw-r--r--doc/examples/lxc-complex-config.in23
-rw-r--r--doc/examples/lxc-empty-netns.conf.in4
-rw-r--r--doc/examples/lxc-macvlan.conf.in8
-rw-r--r--doc/examples/lxc-no-netns.conf.in2
-rw-r--r--doc/examples/lxc-phys.conf.in9
-rw-r--r--doc/examples/lxc-veth.conf.in9
8 files changed, 78 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 9f7bf69..bd96c99 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,3 +1,5 @@
+SUBDIRS = examples
+DIST_SUBDIRS = examples
EXTRA_DIST = \
FAQ.txt \
diff --git a/doc/examples/Makefile.am b/doc/examples/Makefile.am
new file mode 100644
index 0000000..0490a8b
--- /dev/null
+++ b/doc/examples/Makefile.am
@@ -0,0 +1,21 @@
+EXTRA_DIST = $(pkgexamples_DATA)
+
+if ENABLE_EXAMPLES
+pkgexamplesdir=$(docdir)/examples
+
+pkgexamples_DATA = \
+ lxc-macvlan.conf \
+ lxc-no-netns.conf \
+ lxc-empty-netns.conf \
+ lxc-phys.conf \
+ lxc-veth.conf \
+ lxc-complex-config
+endif
+
+noinst_DATA = \
+ lxc-macvlan.conf.in \
+ lxc-empty-netns.conf.in \
+ lxc-no-netns.conf.in \
+ lxc-phys.conf.in \
+ lxc-veth.conf.in \
+ lxc-complex-config.in
diff --git a/doc/examples/lxc-complex-config.in b/doc/examples/lxc-complex-config.in
new file mode 100644
index 0000000..9d761cb
--- /dev/null
+++ b/doc/examples/lxc-complex-config.in
@@ -0,0 +1,23 @@
+# Container with network a complex network mixing macvlan, veth and
+# physical network devices
+lxc.utsname = complex
+lxc.network.type = veth
+lxc.network.flags = up
+lxc.network.link = br0
+lxc.network.hwaddr = 4a:49:43:49:79:bf
+lxc.network.ipv4 = 1.2.3.5/24
+lxc.network.ipv6 = 2003:db8:1:0:214:1234:fe0b:3597
+
+lxc.network.type = macvlan
+lxc.network.flags = up
+lxc.network.link = eth0
+lxc.network.hwaddr = 4a:49:43:49:79:bd
+lxc.network.ipv4 = 1.2.3.4/24
+lxc.network.ipv6 = 2003:db8:1:0:214:1234:fe0b:3596
+
+lxc.network.type = phys
+lxc.network.flags = up
+lxc.network.link = dummy0
+lxc.network.hwaddr = 4a:49:43:49:79:ff
+lxc.network.ipv4 = 1.2.3.6/24
+lxc.network.ipv6 = 2003:db8:1:0:214:1234:fe0b:3297
diff --git a/doc/examples/lxc-empty-netns.conf.in b/doc/examples/lxc-empty-netns.conf.in
new file mode 100644
index 0000000..aedc99f
--- /dev/null
+++ b/doc/examples/lxc-empty-netns.conf.in
@@ -0,0 +1,4 @@
+# Container with new network withtout network devices
+lxc.utsname = omega
+lxc.network.type = empty
+lxc.network.flags = up
diff --git a/doc/examples/lxc-macvlan.conf.in b/doc/examples/lxc-macvlan.conf.in
new file mode 100644
index 0000000..d42d4af
--- /dev/null
+++ b/doc/examples/lxc-macvlan.conf.in
@@ -0,0 +1,8 @@
+# Container with network virtualized using the macvlan device driver
+lxc.utsname = alpha
+lxc.network.type = macvlan
+lxc.network.flags = up
+lxc.network.link = eth0
+lxc.network.hwaddr = 4a:49:43:49:79:bd
+lxc.network.ipv4 = 1.2.3.4/24
+lxc.network.ipv6 = 2003:db8:1:0:214:1234:fe0b:3596
diff --git a/doc/examples/lxc-no-netns.conf.in b/doc/examples/lxc-no-netns.conf.in
new file mode 100644
index 0000000..2c21264
--- /dev/null
+++ b/doc/examples/lxc-no-netns.conf.in
@@ -0,0 +1,2 @@
+# Container with non-virtualized network
+lxc.utsname = delta
diff --git a/doc/examples/lxc-phys.conf.in b/doc/examples/lxc-phys.conf.in
new file mode 100644
index 0000000..7c33eab
--- /dev/null
+++ b/doc/examples/lxc-phys.conf.in
@@ -0,0 +1,9 @@
+# Container with network virtualized using a physical network device with name
+# 'eth0'
+lxc.utsname = gamma
+lxc.network.type = phys
+lxc.network.flags = up
+lxc.network.link = eth0
+lxc.network.hwaddr = 4a:49:43:49:79:ff
+lxc.network.ipv4 = 1.2.3.6/24
+lxc.network.ipv6 = 2003:db8:1:0:214:1234:fe0b:3297
diff --git a/doc/examples/lxc-veth.conf.in b/doc/examples/lxc-veth.conf.in
new file mode 100644
index 0000000..0b1568f
--- /dev/null
+++ b/doc/examples/lxc-veth.conf.in
@@ -0,0 +1,9 @@
+# Container with network virtualized using a pre-configured bridge named br0 and
+# veth pair virtual network devices
+lxc.utsname = beta
+lxc.network.type = veth
+lxc.network.flags = up
+lxc.network.link = br0
+lxc.network.hwaddr = 4a:49:43:49:79:bf
+lxc.network.ipv4 = 1.2.3.5/24
+lxc.network.ipv6 = 2003:db8:1:0:214:1234:fe0b:3597