aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-08-10 16:03:40 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-08-10 16:16:15 +0200
commit33ce97bf5e02da8c600ee99832c07539fdd140b2 (patch)
tree886e78629b08449e29cd1af5cf893900905c3158 /kde-plasma
parentgear.kde.org.eclass: Move skanlite to 24.08 SLOT=5 blockers (diff)
downloadkde-33ce97bf5e02da8c600ee99832c07539fdd140b2.tar.gz
kde-33ce97bf5e02da8c600ee99832c07539fdd140b2.tar.bz2
kde-33ce97bf5e02da8c600ee99832c07539fdd140b2.zip
kde-plasma/kinfocenter: Add sys-apps/dmidecode and dev-util/clinfo opts
Bug: https://bugs.gentoo.org/923821 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-6.1.49.9999.ebuild21
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-9999.ebuild21
2 files changed, 30 insertions, 12 deletions
diff --git a/kde-plasma/kinfocenter/kinfocenter-6.1.49.9999.ebuild b/kde-plasma/kinfocenter/kinfocenter-6.1.49.9999.ebuild
index c0b18c7723..d8d7228231 100644
--- a/kde-plasma/kinfocenter/kinfocenter-6.1.49.9999.ebuild
+++ b/kde-plasma/kinfocenter/kinfocenter-6.1.49.9999.ebuild
@@ -73,15 +73,24 @@ src_install() {
pkg_postinst() {
if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature_header "Query network filesystem info:"
optfeature "NFS information module" net-fs/nfs-utils
optfeature "Samba status information module" net-fs/samba
- optfeature "Vulkan graphics API information module" dev-util/vulkan-tools
+ optfeature_header "Query firmware/hardware info:"
+ fi
+ optfeature "System DMI table readout" sys-apps/dmidecode
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Firmware security module" "app-text/aha sys-apps/fwupd"
+ optfeature "PCI devices information module" sys-apps/pciutils
optfeature "advanced CPU information module" sys-apps/util-linux
+ optfeature_header "Query GPU/graphics support info:"
+ fi
+ optfeature "OpenCL information module" dev-util/clinfo
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "OpenGL information module" x11-apps/mesa-progs
+ optfeature "Vulkan graphics API information module" dev-util/vulkan-tools
+ optfeature "Wayland information module" app-misc/wayland-utils
+ optfeature "X Server information module" x11-apps/xdpyinfo
fi
- optfeature "Wayland information module" app-misc/wayland-utils
- optfeature "Firmware security module" "app-text/aha sys-apps/fwupd"
- optfeature "OpenGL information module" x11-apps/mesa-progs
- optfeature "PCI devices information module" sys-apps/pciutils
- optfeature "X Server information module" x11-apps/xdpyinfo
ecm_pkg_postinst
}
diff --git a/kde-plasma/kinfocenter/kinfocenter-9999.ebuild b/kde-plasma/kinfocenter/kinfocenter-9999.ebuild
index 684c2e8a86..be5dac9991 100644
--- a/kde-plasma/kinfocenter/kinfocenter-9999.ebuild
+++ b/kde-plasma/kinfocenter/kinfocenter-9999.ebuild
@@ -73,15 +73,24 @@ src_install() {
pkg_postinst() {
if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature_header "Query network filesystem info:"
optfeature "NFS information module" net-fs/nfs-utils
optfeature "Samba status information module" net-fs/samba
- optfeature "Vulkan graphics API information module" dev-util/vulkan-tools
+ optfeature_header "Query firmware/hardware info:"
+ fi
+ optfeature "System DMI table readout" sys-apps/dmidecode
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Firmware security module" "app-text/aha sys-apps/fwupd"
+ optfeature "PCI devices information module" sys-apps/pciutils
optfeature "advanced CPU information module" sys-apps/util-linux
+ optfeature_header "Query GPU/graphics support info:"
+ fi
+ optfeature "OpenCL information module" dev-util/clinfo
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "OpenGL information module" x11-apps/mesa-progs
+ optfeature "Vulkan graphics API information module" dev-util/vulkan-tools
+ optfeature "Wayland information module" app-misc/wayland-utils
+ optfeature "X Server information module" x11-apps/xdpyinfo
fi
- optfeature "Wayland information module" app-misc/wayland-utils
- optfeature "Firmware security module" "app-text/aha sys-apps/fwupd"
- optfeature "OpenGL information module" x11-apps/mesa-progs
- optfeature "PCI devices information module" sys-apps/pciutils
- optfeature "X Server information module" x11-apps/xdpyinfo
ecm_pkg_postinst
}