aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-09-07 10:48:01 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-09-07 11:42:06 +0200
commit093aee401a87e5801b3c8ae31c6db3cd1b8b2992 (patch)
treec55bac5ac2ad3101621018fb1a7fdc2b7874ad61 /kde-frameworks/kquickcharts
parentkde-frameworks/kplotting: 6.6.0 version bump (diff)
downloadkde-093aee401a87e5801b3c8ae31c6db3cd1b8b2992.tar.gz
kde-093aee401a87e5801b3c8ae31c6db3cd1b8b2992.tar.bz2
kde-093aee401a87e5801b3c8ae31c6db3cd1b8b2992.zip
kde-frameworks/kquickcharts: 6.6.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kquickcharts')
-rw-r--r--kde-frameworks/kquickcharts/Manifest1
-rw-r--r--kde-frameworks/kquickcharts/kquickcharts-6.6.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/kde-frameworks/kquickcharts/Manifest b/kde-frameworks/kquickcharts/Manifest
new file mode 100644
index 0000000000..c168bde6d5
--- /dev/null
+++ b/kde-frameworks/kquickcharts/Manifest
@@ -0,0 +1 @@
+DIST kquickcharts-6.6.0.tar.xz 110208 BLAKE2B 43af5f0604e2313cd8494d924caeacf233402898e56d3e6dc048b3866fed28811da4270ac9a6bf1bade9fb03abcca8d66a6ebacd3d8b09c9e20f49729e309924 SHA512 fe9b8441ece209eb5c7b4a3675c148739ce2cbd799ce976c46f9a45c39d4acb9b195dddad25ac57cd164cebb75964c17ae097671841b3fddf6879b45cfc630e0
diff --git a/kde-frameworks/kquickcharts/kquickcharts-6.6.0.ebuild b/kde-frameworks/kquickcharts/kquickcharts-6.6.0.ebuild
new file mode 100644
index 0000000000..15f1e1833e
--- /dev/null
+++ b/kde-frameworks/kquickcharts/kquickcharts-6.6.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_EXAMPLES="true"
+ECM_QTHELP="false"
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.6.2
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="QtQuick plugin providing high-performance charts"
+HOMEPAGE="https://invent.kde.org/frameworks/kquickcharts"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ examples? (
+ >=dev-qt/qtbase-${QTMIN}:6[widgets]
+ =kde-frameworks/kdeclarative-${PVCUT}*:6
+ =kde-frameworks/kirigami-${PVCUT}*:6
+ )
+"
+RDEPEND="${DEPEND}
+ examples? ( !${CATEGORY}/${PN}:5[examples(-)] )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=$(usex examples)
+ )
+
+ ecm_src_configure
+}