aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-15 20:53:27 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-15 20:53:27 +0100
commitf6c6a42de43e8d3b5a8e9d5c2b0e69b295871451 (patch)
treebe6eb646d1182021092a6bb0782219026ad56a00 /kde-apps
parentkde-apps/kwave: README was moved to README.md (diff)
downloadkde-f6c6a42de43e8d3b5a8e9d5c2b0e69b295871451.tar.gz
kde-f6c6a42de43e8d3b5a8e9d5c2b0e69b295871451.tar.bz2
kde-f6c6a42de43e8d3b5a8e9d5c2b0e69b295871451.zip
kde-apps/umbrello: Rebase gentoo-docbundledir.patch on top of 24.12
Broken by foreach-loop to for-loop conversion Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/umbrello/files/umbrello-24.11.80-gentoo-docbundledir.patch (renamed from kde-apps/umbrello/files/umbrello-23.03.80-gentoo-docbundledir.patch)14
-rw-r--r--kde-apps/umbrello/umbrello-24.11.80.ebuild2
-rw-r--r--kde-apps/umbrello/umbrello-24.12.49.9999.ebuild2
-rw-r--r--kde-apps/umbrello/umbrello-9999.ebuild2
4 files changed, 10 insertions, 10 deletions
diff --git a/kde-apps/umbrello/files/umbrello-23.03.80-gentoo-docbundledir.patch b/kde-apps/umbrello/files/umbrello-24.11.80-gentoo-docbundledir.patch
index c577a72f74..7af65f2a29 100644
--- a/kde-apps/umbrello/files/umbrello-23.03.80-gentoo-docbundledir.patch
+++ b/kde-apps/umbrello/files/umbrello-24.11.80-gentoo-docbundledir.patch
@@ -1,4 +1,4 @@
-From 20e7b4e1cf4e150e7de2d9fa3f0ee43f434e8ec3 Mon Sep 17 00:00:00 2001
+From ce2c9900c36376cde471344e699b37f28ececd98 Mon Sep 17 00:00:00 2001
From: Andreas Sturmlechner <asturm@gentoo.org>
Date: Thu, 5 Nov 2020 14:39:51 +0100
Subject: [PATCH] Fix hardcoded docbook install paths for Gentoo
@@ -11,13 +11,13 @@ Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/umbrello/umlappprivate.cpp b/umbrello/umlappprivate.cpp
-index 08c138518..28e5d3086 100644
+index 8966837fb..d5a56bfd8 100644
--- a/umbrello/umlappprivate.cpp
+++ b/umbrello/umlappprivate.cpp
@@ -33,17 +33,17 @@ QString UMLAppPrivate::findWelcomeFile()
// from custom install
- foreach(const QString &lang, langList) {
+ for(const QString &lang : langList) {
- dirList.append(QCoreApplication::applicationDirPath() + QString(QStringLiteral("/../share/doc/HTML/%1/umbrello/apphelp")).arg(lang));
+ dirList.append(QCoreApplication::applicationDirPath() + QString(QStringLiteral("/../share/help/%1/umbrello/apphelp")).arg(lang));
}
@@ -26,16 +26,16 @@ index 08c138518..28e5d3086 100644
QStringList locations = QStandardPaths::standardLocations(QStandardPaths::GenericDataLocation);
// from real installation
- foreach(const QString &location, locations) {
- foreach(const QString &lang, langList) {
+ for(const QString &location : locations) {
+ for (const QString &lang : langList) {
- dirList.append(QString(QStringLiteral("%1/doc/HTML/%2/umbrello/apphelp")).arg(location).arg(lang));
+ dirList.append(QString(QStringLiteral("%1/help/%2/umbrello/apphelp")).arg(location).arg(lang));
}
- dirList.append(QString(QStringLiteral("%1/doc/HTML/en/umbrello/apphelp")).arg(location));
+ dirList.append(QString(QStringLiteral("%1/help/en/umbrello/apphelp")).arg(location));
}
- foreach(const QString &dir, dirList) {
+ for(const QString &dir : dirList) {
QString filePath = dir + QStringLiteral("/index.cache.bz2");
--
-2.40.0
+2.47.0
diff --git a/kde-apps/umbrello/umbrello-24.11.80.ebuild b/kde-apps/umbrello/umbrello-24.11.80.ebuild
index e988cb09e2..7da5c4553b 100644
--- a/kde-apps/umbrello/umbrello-24.11.80.ebuild
+++ b/kde-apps/umbrello/umbrello-24.11.80.ebuild
@@ -52,7 +52,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
PATCHES=(
- "${FILESDIR}"/${PN}-23.03.80-gentoo-docbundledir.patch # fix hardcoded path
+ "${FILESDIR}"/${P}-gentoo-docbundledir.patch # fix hardcoded path
)
src_configure() {
diff --git a/kde-apps/umbrello/umbrello-24.12.49.9999.ebuild b/kde-apps/umbrello/umbrello-24.12.49.9999.ebuild
index 40c48779c7..e700d658cc 100644
--- a/kde-apps/umbrello/umbrello-24.12.49.9999.ebuild
+++ b/kde-apps/umbrello/umbrello-24.12.49.9999.ebuild
@@ -52,7 +52,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
PATCHES=(
- "${FILESDIR}"/${PN}-23.03.80-gentoo-docbundledir.patch # fix hardcoded path
+ "${FILESDIR}"/${PN}-24.11.80-gentoo-docbundledir.patch # fix hardcoded path
)
src_configure() {
diff --git a/kde-apps/umbrello/umbrello-9999.ebuild b/kde-apps/umbrello/umbrello-9999.ebuild
index 40c48779c7..e700d658cc 100644
--- a/kde-apps/umbrello/umbrello-9999.ebuild
+++ b/kde-apps/umbrello/umbrello-9999.ebuild
@@ -52,7 +52,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
PATCHES=(
- "${FILESDIR}"/${PN}-23.03.80-gentoo-docbundledir.patch # fix hardcoded path
+ "${FILESDIR}"/${PN}-24.11.80-gentoo-docbundledir.patch # fix hardcoded path
)
src_configure() {