aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-05 21:07:51 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-05 22:03:15 +0100
commit44e25a319a984944b9f0bc5289f9191ac41e9d13 (patch)
tree9074c8b39d737fd321d91ab1238015ab086dcc8c /dev-build
parentkde-misc/zanshin: 24.08.3 version bump (diff)
downloadkde-44e25a319a984944b9f0bc5289f9191ac41e9d13.tar.gz
kde-44e25a319a984944b9f0bc5289f9191ac41e9d13.tar.bz2
kde-44e25a319a984944b9f0bc5289f9191ac41e9d13.zip
dev-build/dolphin-plugins-makefileactions: 24.08.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-build')
-rw-r--r--dev-build/dolphin-plugins-makefileactions/Manifest1
-rw-r--r--dev-build/dolphin-plugins-makefileactions/dolphin-plugins-makefileactions-24.08.3.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-build/dolphin-plugins-makefileactions/Manifest b/dev-build/dolphin-plugins-makefileactions/Manifest
new file mode 100644
index 0000000000..7d41bdbd17
--- /dev/null
+++ b/dev-build/dolphin-plugins-makefileactions/Manifest
@@ -0,0 +1 @@
+DIST dolphin-plugins-24.08.3.tar.xz 317540 BLAKE2B 54fa2e13be2cceb53b12b1edb2d6d7c1793f6ba2bbec67e9e00121b33683aa6bd4895392cbdf5aa7627958c6323984ae3db8b5bbf6b14faba86b13181e0a2614 SHA512 05da7ac7b3ebe085cf0808d8e1eba49372bfeb1488800f40c1d0b9025e743efede1200095a1e660c1d538b2cc1b19f0f717f3d0723043517859f5c2015f961ce
diff --git a/dev-build/dolphin-plugins-makefileactions/dolphin-plugins-makefileactions-24.08.3.ebuild b/dev-build/dolphin-plugins-makefileactions/dolphin-plugins-makefileactions-24.08.3.ebuild
new file mode 100644
index 0000000000..f3c4f87c8c
--- /dev/null
+++ b/dev-build/dolphin-plugins-makefileactions/dolphin-plugins-makefileactions-24.08.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="makefileactions"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.5.0
+QTMIN=6.7.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for Makefile targets integration"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[concurrent,gui,widgets]
+ >=kde-apps/dolphin-${PVCUT}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kjobwidgets-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ !<kde-apps/dolphin-plugins-subversion-24.08.2-r1
+ >=kde-apps/dolphin-plugins-common-${PV}
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_po_install
+ # solid, qtdbus only required by mountiso
+ ecm_punt_qt_module DBus
+ ecm_punt_kf_module Solid
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+ # kcompletion, ktextwidgets only required by other plugins
+ ecm_punt_kf_module Completion
+ ecm_punt_kf_module TextWidgets
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_mountiso=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}