summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/kdelibs/files')
-rw-r--r--kde-frameworks/kdelibs/files/kdelibs-4.14.38-CVE-2019-14744.patch11
-rw-r--r--kde-frameworks/kdelibs/files/kdelibs-4.14.38-gentoo-docbundledir.patch72
-rw-r--r--kde-frameworks/kdelibs/files/kdelibs-4.14.38-gentoo-slotted-FindPopplerQt4.patch26
-rw-r--r--kde-frameworks/kdelibs/files/kdelibs-4.14.38-library-doc-policy-links.patch56
4 files changed, 160 insertions, 5 deletions
diff --git a/kde-frameworks/kdelibs/files/kdelibs-4.14.38-CVE-2019-14744.patch b/kde-frameworks/kdelibs/files/kdelibs-4.14.38-CVE-2019-14744.patch
index bc71dc0f..95c6d160 100644
--- a/kde-frameworks/kdelibs/files/kdelibs-4.14.38-CVE-2019-14744.patch
+++ b/kde-frameworks/kdelibs/files/kdelibs-4.14.38-CVE-2019-14744.patch
@@ -1,7 +1,8 @@
From 2c3762feddf7e66cf6b64d9058f625a715694a00 Mon Sep 17 00:00:00 2001
From: Kai Uwe Broulik <kde@privat.broulik.de>
Date: Wed, 7 Aug 2019 09:47:46 +0200
-Subject: Security: remove support for $(...) in config keys with [$e] marker.
+Subject: [PATCH] Security: remove support for $(...) in config keys with [$e]
+ marker.
It is very unclear at this point what a valid use case for this feature
would possibly be. The old documentation only mentions $(hostname) as
@@ -23,7 +24,7 @@ Differential Revision: https://phabricator.kde.org/D22989
3 files changed, 2 insertions(+), 48 deletions(-)
diff --git a/kdecore/config/kconfig.cpp b/kdecore/config/kconfig.cpp
-index 7ea26a5..b30584b 100644
+index 7ea26a5480..b30584b302 100644
--- a/kdecore/config/kconfig.cpp
+++ b/kdecore/config/kconfig.cpp
@@ -160,37 +160,7 @@ QString KConfigPrivate::expandString(const QString& value)
@@ -66,7 +67,7 @@ index 7ea26a5..b30584b 100644
// the next character is not $
QString aVarName;
diff --git a/kdecore/doc/README.kiosk b/kdecore/doc/README.kiosk
-index b95002d..d902c61 100644
+index b95002d040..d902c61ea9 100644
--- a/kdecore/doc/README.kiosk
+++ b/kdecore/doc/README.kiosk
@@ -640,18 +640,6 @@ The following syntax is also supported:
@@ -89,7 +90,7 @@ index b95002d..d902c61 100644
==========================
diff --git a/kdecore/tests/kconfigtest.cpp b/kdecore/tests/kconfigtest.cpp
-index 78e6ad1..37ea3c2 100644
+index 78e6ad180e..37ea3c2825 100644
--- a/kdecore/tests/kconfigtest.cpp
+++ b/kdecore/tests/kconfigtest.cpp
@@ -479,12 +479,8 @@ void KConfigTest::testPath()
@@ -107,5 +108,5 @@ index 78e6ad1..37ea3c2 100644
QCOMPARE(group.readEntry("noeol", QString()), QString("foo"));
}
--
-cgit v1.1
+2.29.2
diff --git a/kde-frameworks/kdelibs/files/kdelibs-4.14.38-gentoo-docbundledir.patch b/kde-frameworks/kdelibs/files/kdelibs-4.14.38-gentoo-docbundledir.patch
new file mode 100644
index 00000000..00eb10d1
--- /dev/null
+++ b/kde-frameworks/kdelibs/files/kdelibs-4.14.38-gentoo-docbundledir.patch
@@ -0,0 +1,72 @@
+From c7159b51b4b78d4fd81f886be7b476d143f78869 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 6 Dec 2020 21:16:00 +0100
+Subject: [PATCH] Switch HTML_INSTALL_DIR over to /usr/share/help
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ cmake/modules/FindKDE4Internal.cmake | 6 +++---
+ cmake/modules/FindPyKDE4.cmake | 2 +-
+ kdecore/kernel/kstandarddirs_win.cpp | 2 +-
+ 3 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/cmake/modules/FindKDE4Internal.cmake b/cmake/modules/FindKDE4Internal.cmake
+index c345eca36f..d436ec7756 100644
+--- a/cmake/modules/FindKDE4Internal.cmake
++++ b/cmake/modules/FindKDE4Internal.cmake
+@@ -164,7 +164,7 @@
+ #
+ #
+ # The following variable is provided, but seem to be unused:
+-# LIBS_HTML_INSTALL_DIR /share/doc/HTML CACHE STRING "Is this still used ?")
++# LIBS_HTML_INSTALL_DIR /share/help CACHE STRING "Is this still used ?")
+ #
+ # The following user adjustable options are provided:
+ #
+@@ -773,7 +773,7 @@ if (WIN32)
+ set(IMPORTS_INSTALL_DIR "${PLUGIN_INSTALL_DIR}/imports" ) # "The subdirectory relative to the install prefix where imports will be installed
+ set(CONFIG_INSTALL_DIR "share/config" ) # The config file install dir
+ set(DATA_INSTALL_DIR "share/apps" ) # The parent directory where applications can install their data
+- set(HTML_INSTALL_DIR "share/doc/HTML" ) # The HTML install dir for documentation
++ set(HTML_INSTALL_DIR "share/help" ) # The HTML install dir for documentation
+ set(ICON_INSTALL_DIR "share/icons" ) # The icon install dir (default ${SHARE_INSTALL_PREFIX}/share/icons/)
+ set(KCFG_INSTALL_DIR "share/config.kcfg" ) # The install dir for kconfig files
+ set(LOCALE_INSTALL_DIR "share/locale" ) # The install dir for translations
+@@ -846,7 +846,7 @@ else (WIN32)
+ _set_fancy(IMPORTS_INSTALL_DIR "${PLUGIN_INSTALL_DIR}/imports" "The subdirectory relative to the install prefix where imports will be installed")
+ _set_fancy(CONFIG_INSTALL_DIR "${SHARE_INSTALL_PREFIX}/config" "The config file install dir")
+ _set_fancy(DATA_INSTALL_DIR "${SHARE_INSTALL_PREFIX}/apps" "The parent directory where applications can install their data")
+- _set_fancy(HTML_INSTALL_DIR "${SHARE_INSTALL_PREFIX}/doc/HTML" "The HTML install dir for documentation")
++ _set_fancy(HTML_INSTALL_DIR "${SHARE_INSTALL_PREFIX}/help" "The HTML install dir for documentation")
+ _set_fancy(ICON_INSTALL_DIR "${SHARE_INSTALL_PREFIX}/icons" "The icon install dir (default ${SHARE_INSTALL_PREFIX}/share/icons/)")
+ _set_fancy(KCFG_INSTALL_DIR "${SHARE_INSTALL_PREFIX}/config.kcfg" "The install dir for kconfig files")
+ _set_fancy(LOCALE_INSTALL_DIR "${SHARE_INSTALL_PREFIX}/locale" "The install dir for translations")
+diff --git a/cmake/modules/FindPyKDE4.cmake b/cmake/modules/FindPyKDE4.cmake
+index 9b1379486d..9569864aa5 100644
+--- a/cmake/modules/FindPyKDE4.cmake
++++ b/cmake/modules/FindPyKDE4.cmake
+@@ -70,7 +70,7 @@ IF(PYTHONINTERP_FOUND)
+ _set_fancy(PLUGIN_INSTALL_DIR "${LIB_INSTALL_DIR}/kde4" "The subdirectory relative to the install prefix where plugins will be installed (default is ${LIB_INSTALL_DIR}/kde4)")
+ _set_fancy(CONFIG_INSTALL_DIR "${SHARE_INSTALL_PREFIX}/config" "The config file install dir")
+ _set_fancy(DATA_INSTALL_DIR "${SHARE_INSTALL_PREFIX}/apps" "The parent directory where applications can install their data")
+- _set_fancy(HTML_INSTALL_DIR "${SHARE_INSTALL_PREFIX}/doc/HTML" "The HTML install dir for documentation")
++ _set_fancy(HTML_INSTALL_DIR "${SHARE_INSTALL_PREFIX}/help" "The HTML install dir for documentation")
+ _set_fancy(ICON_INSTALL_DIR "${SHARE_INSTALL_PREFIX}/icons" "The icon install dir (default ${SHARE_INSTALL_PREFIX}/share/icons/)")
+ _set_fancy(KCFG_INSTALL_DIR "${SHARE_INSTALL_PREFIX}/config.kcfg" "The install dir for kconfig files")
+ _set_fancy(LOCALE_INSTALL_DIR "${SHARE_INSTALL_PREFIX}/locale" "The install dir for translations")
+diff --git a/kdecore/kernel/kstandarddirs_win.cpp b/kdecore/kernel/kstandarddirs_win.cpp
+index b47aa152ef..aebb57138c 100644
+--- a/kdecore/kernel/kstandarddirs_win.cpp
++++ b/kdecore/kernel/kstandarddirs_win.cpp
+@@ -58,7 +58,7 @@ QString KStandardDirs::installPath(const char *type)
+ break;
+ case 'h':
+ if (strcmp("html", type) == 0)
+- return share() + QLatin1String("doc/HTML/");
++ return share() + QLatin1String("help/");
+ break;
+ case 'i':
+ if (strcmp("icon", type) == 0)
+--
+2.29.2
+
diff --git a/kde-frameworks/kdelibs/files/kdelibs-4.14.38-gentoo-slotted-FindPopplerQt4.patch b/kde-frameworks/kdelibs/files/kdelibs-4.14.38-gentoo-slotted-FindPopplerQt4.patch
new file mode 100644
index 00000000..750a17ba
--- /dev/null
+++ b/kde-frameworks/kdelibs/files/kdelibs-4.14.38-gentoo-slotted-FindPopplerQt4.patch
@@ -0,0 +1,26 @@
+From c1ee468c3588b517f8373e650b8b81fe54b583f7 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 6 Dec 2020 20:22:56 +0100
+Subject: [PATCH] FindPopplerQt4.cmake: Find Gentoo "0-qt4"-slotted poppler
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ cmake/modules/FindPopplerQt4.cmake | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cmake/modules/FindPopplerQt4.cmake b/cmake/modules/FindPopplerQt4.cmake
+index 95b75295cb..e1a85eee96 100644
+--- a/cmake/modules/FindPopplerQt4.cmake
++++ b/cmake/modules/FindPopplerQt4.cmake
+@@ -24,7 +24,7 @@ set(POPPLER_QT4_DEFINITIONS ${PC_POPPLERQT4_CFLAGS_OTHER})
+ find_path(POPPLER_QT4_INCLUDE_DIR
+ NAMES poppler-qt4.h
+ HINTS ${PC_POPPLERQT4_INCLUDEDIR}
+- PATH_SUFFIXES poppler/qt4 poppler
++ PATH_SUFFIXES poppler0-qt4/qt4 poppler/qt4 poppler
+ )
+
+ find_library(POPPLER_QT4_LIBRARY
+--
+2.29.2
+
diff --git a/kde-frameworks/kdelibs/files/kdelibs-4.14.38-library-doc-policy-links.patch b/kde-frameworks/kdelibs/files/kdelibs-4.14.38-library-doc-policy-links.patch
new file mode 100644
index 00000000..41a3b8fe
--- /dev/null
+++ b/kde-frameworks/kdelibs/files/kdelibs-4.14.38-library-doc-policy-links.patch
@@ -0,0 +1,56 @@
+From 12a8bb503351b98869f722ba932f822e3c495883 Mon Sep 17 00:00:00 2001
+From: Ben Cooksley <bcooksley@kde.org>
+Date: Mon, 5 Aug 2019 15:41:05 +1200
+Subject: [PATCH] Correct links to Library Documentation Policy.
+
+Fixes T11309
+
+CCMAIL: kossebau@kde.org
+---
+ doc/common/README.Doxygen | 2 +-
+ doc/common/footer.html | 2 +-
+ doc/common/mainfooter.html | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/doc/common/README.Doxygen b/doc/common/README.Doxygen
+index 3c46a51bd0..24df4fe2ef 100644
+--- a/doc/common/README.Doxygen
++++ b/doc/common/README.Doxygen
+@@ -29,7 +29,7 @@ The tool for generating dox lives in admin/ :
+
+
+ Writing dox is beyond the scope of this README -- see the notes at
+-http://techbase.kde.org/Policies/Library_Documentation_Policy .
++https://community.kde.org/Policies/Library_Documentation_Policy .
+ You can generate dox by hand -- without even having a configured
+ build directory -- as explained below. There is also documentation
+ for the special tags you can enter in Makefile.am anywhere
+diff --git a/doc/common/footer.html b/doc/common/footer.html
+index 3b609f00e6..91cdb9711e 100644
+--- a/doc/common/footer.html
++++ b/doc/common/footer.html
+@@ -5,7 +5,7 @@ Generated on $datetime by
+ <a href="http://www.doxygen.org/index.html">doxygen</a> $doxygenversion written
+ by <a href="mailto:dimitri@stack.nl">Dimitri van Heesch</a>, &copy;&nbsp;1997-2006
+ <p>
+-KDE's <a href="http://techbase.kde.org/Policies/Library_Documentation_Policy">Doxygen guidelines</a> are available online.
++KDE's <a href="https://community.kde.org/Policies/Library_Documentation_Policy">Doxygen guidelines</a> are available online.
+ </p>
+ </div>
+ </div>
+diff --git a/doc/common/mainfooter.html b/doc/common/mainfooter.html
+index b129193292..a644603fa8 100644
+--- a/doc/common/mainfooter.html
++++ b/doc/common/mainfooter.html
+@@ -5,7 +5,7 @@ Generated on $datetime by
+ <a href="http://www.doxygen.org/index.html">doxygen</a> $doxygenversion written
+ by <a href="mailto:dimitri@stack.nl">Dimitri van Heesch</a>, &copy;&nbsp;1997-2006
+ <p>
+-KDE's <a href="http://techbase.kde.org/Policies/Library_Documentation_Policy">Doxygen guidelines</a> are available online.
++KDE's <a href="https://community.kde.org/Policies/Library_Documentation_Policy">Doxygen guidelines</a> are available online.
+ </p>
+ </div>
+ </div>
+--
+2.29.2
+