summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-04-27 17:15:05 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-04-27 17:15:44 +0200
commit3eea6933056d38d15b0e0a9933b845b9c5168956 (patch)
treea469aa67d94b3c9b8ad982e2792baf8120688cae /dev-util/automoc/automoc-0.9.88-r1.ebuild
parent*/*: Drop nonexistent ~x86-macos KEYWORD (diff)
downloadkde-sunset-3eea6933056d38d15b0e0a9933b845b9c5168956.tar.gz
kde-sunset-3eea6933056d38d15b0e0a9933b845b9c5168956.tar.bz2
kde-sunset-3eea6933056d38d15b0e0a9933b845b9c5168956.zip
dev-util/automoc: EAPI-7 bump, switch to cmake.eclass
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util/automoc/automoc-0.9.88-r1.ebuild')
-rw-r--r--dev-util/automoc/automoc-0.9.88-r1.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/dev-util/automoc/automoc-0.9.88-r1.ebuild b/dev-util/automoc/automoc-0.9.88-r1.ebuild
index 4c423747..d28605da 100644
--- a/dev-util/automoc/automoc-0.9.88-r1.ebuild
+++ b/dev-util/automoc/automoc-0.9.88-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
MY_PN="automoc4"
MY_P="${MY_PN}-${PV}"
-inherit cmake-utils flag-o-matic
+inherit cmake flag-o-matic
DESCRIPTION="KDE Meta Object Compiler"
HOMEPAGE="https://www.kde.org"
@@ -16,9 +16,7 @@ SLOT="0"
KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
IUSE=""
-DEPEND="
- dev-qt/qtcore:4
-"
+DEPEND="dev-qt/qtcore:4"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
@@ -26,7 +24,7 @@ S="${WORKDIR}/${MY_P}"
PATCHES=( "${FILESDIR}/${PN}-0.9.88-objc++.patch" )
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
if [[ ${ELIBC} = uclibc ]]; then
append-flags -pthread