aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build38
1 files changed, 38 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..3dff1fd
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,38 @@
+project(
+ 'java-config',
+ version: '2.3.3-SNAPSHOT',
+ license: 'GPL-2.0',
+ meson_version: '>=1.1.1'
+)
+
+py_mod = import('python')
+py = py_mod.find_installation(pure : true)
+
+system_wide = get_option('system-wide')
+python_only = get_option('python-only')
+
+eprefix = get_option('eprefix')
+datadir = get_option('datadir')
+
+sysconfdir = system_wide ? get_option('sysconfdir') \
+ : datadir / 'etc'
+
+conf_data = configuration_data({
+ 'VERSION': meson.project_version(),
+ 'EPREFIX': eprefix
+})
+
+subdir('src')
+subdir('tests')
+
+if python_only
+ subdir_done()
+endif
+
+subdir('config')
+
+if not system_wide
+ subdir_done()
+endif
+
+subdir('man')