summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-06 23:01:52 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-20 20:16:32 +0200
commit0670e86033365cf41f689fbd1f24e6cbe83f79e5 (patch)
tree001c8fd406e76ae1360d4015c54809f8c26e799e /media-video
parentgnome-base/nautilus: 3.10.1 → 3.12.0 (diff)
downloadgnome-0670e86033365cf41f689fbd1f24e6cbe83f79e5.tar.gz
gnome-0670e86033365cf41f689fbd1f24e6cbe83f79e5.tar.bz2
gnome-0670e86033365cf41f689fbd1f24e6cbe83f79e5.zip
media-video/totem: 3.10.1 → 3.12.0
Diffstat (limited to 'media-video')
-rw-r--r--media-video/totem/Manifest11
-rw-r--r--media-video/totem/totem-3.12.0.ebuild141
-rw-r--r--media-video/totem/totem-9999.ebuild27
3 files changed, 163 insertions, 16 deletions
diff --git a/media-video/totem/Manifest b/media-video/totem/Manifest
new file mode 100644
index 00000000..0c7f0921
--- /dev/null
+++ b/media-video/totem/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST totem-3.12.0.tar.xz 3309516 SHA256 96762a1c2026f7bbc6ef8a431cf7626647e54ac2d195eb573a71d62dc3a2c430 SHA512 c4d546363ee688ebab843a7b63f65d39c6eed407cbd4caf59ab85075191f1036855dbfd4582212add3b56881e67f3006170f94933b1f20d590df4b988e47f0e1 WHIRLPOOL 7a4695d578d83ed1933d4b3c9e7183633b8aed53eb7a554061376318fc372174cd46fe748955a4771512452a06cca8cb625515607a74179617e57b7d17d8dcfa
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.22 (GNU/Linux)
+
+iEYEAREKAAYFAlNBwMEACgkQ1fmVwcYIWAazJQCgyER4wkJNvWprfYfTscMY0W87
+W40AmgMHZFSE5zgAH5PIkwLMytnhZuMM
+=rtS0
+-----END PGP SIGNATURE-----
diff --git a/media-video/totem/totem-3.12.0.ebuild b/media-video/totem/totem-3.12.0.ebuild
new file mode 100644
index 00000000..2151d506
--- /dev/null
+++ b/media-video/totem/totem-3.12.0.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes" # plugins are dlopened
+PYTHON_COMPAT=( python2_{6,7} )
+PYTHON_REQ_USE="threads"
+
+inherit autotools eutils gnome2 multilib python-single-r1
+
+DESCRIPTION="Media player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Videos"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="flash +introspection lirc nautilus nsplugin +python test zeitgeist"
+# see bug #359379
+REQUIRED_USE="
+ flash? ( nsplugin )
+ python? ( introspection ${PYTHON_REQUIRED_USE} )
+ zeitgeist? ( introspection )
+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+# TODO:
+# Cone (VLC) plugin needs someone with the right setup to test it
+#
+# FIXME:
+# Automagic tracker-0.9.0
+# Runtime dependency on gnome-session-2.91
+RDEPEND="
+ >=dev-libs/glib-2.35:2
+ >=x11-libs/gdk-pixbuf-2.23.0:2
+ >=x11-libs/gtk+-3.11.5:3[introspection?]
+ >=dev-libs/totem-pl-parser-3.10.1:0=[introspection?]
+ >=dev-libs/libpeas-1.1.0[gtk]
+ >=x11-themes/gnome-icon-theme-2.16
+ x11-libs/cairo
+ >=dev-libs/libxml2-2.6:2
+ >=media-libs/clutter-1.17.3:1.0
+ >=media-libs/clutter-gst-1.5.5:2.0
+ >=media-libs/clutter-gtk-1.0.2:1.0
+ x11-libs/mx:1.0
+
+ >=media-libs/grilo-0.2.10:0.2[playlist]
+ media-plugins/grilo-plugins:0.2
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0[X,introspection?,pango]
+ media-libs/gst-plugins-good:1.0
+ media-plugins/gst-plugins-taglib:1.0
+ media-plugins/gst-plugins-meta:1.0
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ >=x11-libs/libXxf86vm-1.0.1
+
+ gnome-base/gsettings-desktop-schemas
+ x11-themes/gnome-icon-theme-symbolic
+
+ flash? ( dev-libs/totem-pl-parser[quvi] )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )
+ lirc? ( app-misc/lirc )
+ nautilus? ( >=gnome-base/nautilus-2.91.3 )
+ nsplugin? ( >=x11-misc/shared-mime-info-0.22 )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3.5.2:3[introspection] )
+ zeitgeist? ( >=gnome-extra/zeitgeist-0.9.12 )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.5
+ app-text/scrollkeeper
+ app-text/yelp-tools
+ dev-util/appdata-tools
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ x11-proto/xextproto
+ x11-proto/xproto
+ virtual/pkgconfig
+"
+# docbook-xml-dtd is needed for user doc
+# Prevent dev-python/pylint dep, bug #482538
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Prevent pylint usage by tests, bug #482538
+ sed -i -e 's/ check-pylint//' src/plugins/Makefile.plugins || die
+
+ eautoreconf
+ gnome2_src_prepare
+
+ # FIXME: upstream should provide a way to set GST_INSPECT, bug #358755 & co.
+ # gst-inspect causes sandbox violations when a plugin needs write access to
+ # /dev/dri/card* in its init phase.
+ sed -e "s|\(gst10_inspect=\).*|\1$(type -P true)|" \
+ -i configure || die
+}
+
+src_configure() {
+ use nsplugin && DOCS="${DOCS} browser-plugin/README.browser-plugin"
+
+ # Disabled: sample-python, sample-vala
+ local plugins="apple-trailers,autoload-subtitles,brasero-disc-recorder"
+ plugins+=",chapters,im-status,gromit,media-player-keys,ontop"
+ plugins+=",properties,recent,rotation,screensaver,screenshot"
+ plugins+=",skipto,vimeo"
+ use lirc && plugins+=",lirc"
+ use nautilus && plugins+=",save-file"
+ use python && plugins+=",dbusservice,pythonconsole,opensubtitles"
+ use zeitgeist && plugins+=",zeitgeist-dp"
+
+ #--with-smclient=auto needed to correctly link to libICE and libSM
+ # XXX: always set to true otherwise tests fails due to pylint not
+ # respecting EPYTHON (wait for python-r1)
+ # pylint is checked unconditionally, but is only used for make check
+ gnome2_src_configure \
+ --disable-run-in-source-tree \
+ --disable-static \
+ --with-smclient=auto \
+ --enable-easy-codec-installation \
+ --enable-vala \
+ $(use_enable flash vegas-plugin) \
+ $(use_enable introspection) \
+ $(use_enable nautilus) \
+ $(use_enable nsplugin browser-plugins) \
+ $(use_enable python) \
+ PYLINT=$(type -P true) \
+ VALAC=$(type -P true) \
+ BROWSER_PLUGIN_DIR=/usr/$(get_libdir)/nsbrowser/plugins \
+ --with-plugins=${plugins}
+}
diff --git a/media-video/totem/totem-9999.ebuild b/media-video/totem/totem-9999.ebuild
index ab6bf906..2ef9f040 100644
--- a/media-video/totem/totem-9999.ebuild
+++ b/media-video/totem/totem-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -15,11 +15,11 @@ if [[ ${PV} = 9999 ]]; then
fi
DESCRIPTION="Media player for GNOME"
-HOMEPAGE="http://projects.gnome.org/totem/"
+HOMEPAGE="https://wiki.gnome.org/Apps/Videos"
LICENSE="GPL-2+ LGPL-2+"
SLOT="0"
-IUSE="flash grilo +introspection lirc nautilus nsplugin +python test zeitgeist"
+IUSE="flash +introspection lirc nautilus nsplugin +python test zeitgeist"
# see bug #359379
REQUIRED_USE="
flash? ( nsplugin )
@@ -42,22 +42,23 @@ fi
# Automagic tracker-0.9.0
# Runtime dependency on gnome-session-2.91
RDEPEND="
- >=dev-libs/glib-2.33:2
+ >=dev-libs/glib-2.35:2
>=x11-libs/gdk-pixbuf-2.23.0:2
- >=x11-libs/gtk+-3.7.10:3[introspection?]
- >=dev-libs/totem-pl-parser-3.9.92:0=[introspection?]
+ >=x11-libs/gtk+-3.11.5:3[introspection?]
+ >=dev-libs/totem-pl-parser-3.10.1:0=[introspection?]
>=dev-libs/libpeas-1.1.0[gtk]
>=x11-themes/gnome-icon-theme-2.16
x11-libs/cairo
>=dev-libs/libxml2-2.6:2
- >=media-libs/clutter-1.10:1.0
+ >=media-libs/clutter-1.17.3:1.0
>=media-libs/clutter-gst-1.5.5:2.0
>=media-libs/clutter-gtk-1.0.2:1.0
x11-libs/mx:1.0
+ >=media-libs/grilo-0.2.9:0.2[playlist]
+ media-plugins/grilo-plugins:0.2
media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0[X,introspection?,pango]
- >=media-libs/gst-plugins-bad-1.0.2:1.0
media-libs/gst-plugins-good:1.0
media-plugins/gst-plugins-taglib:1.0
media-plugins/gst-plugins-meta:1.0
@@ -71,15 +72,10 @@ RDEPEND="
x11-themes/gnome-icon-theme-symbolic
flash? ( dev-libs/totem-pl-parser[quvi] )
- grilo? (
- media-libs/grilo:0.2
- media-plugins/grilo-plugins:0.2 )
introspection? ( >=dev-libs/gobject-introspection-0.6.7 )
lirc? ( app-misc/lirc )
nautilus? ( >=gnome-base/nautilus-2.91.3 )
- nsplugin? (
- >=dev-libs/dbus-glib-0.82
- >=x11-misc/shared-mime-info-0.22 )
+ nsplugin? ( >=x11-misc/shared-mime-info-0.22 )
python? (
${PYTHON_DEPS}
>=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
@@ -140,8 +136,7 @@ src_configure() {
local plugins="apple-trailers,autoload-subtitles,brasero-disc-recorder"
plugins+=",chapters,im-status,gromit,media-player-keys,ontop"
plugins+=",properties,recent,rotation,screensaver,screenshot"
- plugins+=",sidebar-test,skipto,vimeo"
- use grilo && plugins+=",grilo"
+ plugins+=",skipto,vimeo"
use lirc && plugins+=",lirc"
use nautilus && plugins+=",save-file"
use python && plugins+=",dbusservice,pythonconsole,opensubtitles"