summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-01 23:15:20 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-01 23:15:20 +0200
commitf8097fddaf97bc280b3e04ebc261b32d4a62d882 (patch)
treeeb45108ef00f5b0516f34a77291746bb040bdc4d /media-sound/gnome-music
parentmail-client/evolution: 3.11.91 -> 3.11.92 (diff)
downloadgnome-f8097fddaf97bc280b3e04ebc261b32d4a62d882.tar.gz
gnome-f8097fddaf97bc280b3e04ebc261b32d4a62d882.tar.bz2
gnome-f8097fddaf97bc280b3e04ebc261b32d4a62d882.zip
media-sound/gnome-music: 3.10.3 → 3.12.0
Diffstat (limited to 'media-sound/gnome-music')
-rw-r--r--media-sound/gnome-music/Manifest11
-rw-r--r--media-sound/gnome-music/gnome-music-3.12.0.ebuild51
2 files changed, 62 insertions, 0 deletions
diff --git a/media-sound/gnome-music/Manifest b/media-sound/gnome-music/Manifest
new file mode 100644
index 00000000..381352d9
--- /dev/null
+++ b/media-sound/gnome-music/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST gnome-music-3.12.0.tar.xz 1411608 SHA256 4c63b04ecb9bc253f16e9f1de88de2792ddd90e469de03722e7f9d5b4dc767aa SHA512 b25c2e5e6d494981bb64061b75820b670b3976cc8e88888cbcdc2b17c80bfdf4bad9790169bdd47e9c331429f56ee6ee312f70af1e3ccec546004bf643f7f7f1 WHIRLPOOL e6ccbe5a09890c9653e90d48298c33f74a8982df8fdd7aa6db548bab3102a5d4a519208d299b2b56cf4ed845d2f57fafd15c51af39615e0ea3871473366a59db
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.22 (GNU/Linux)
+
+iEYEAREKAAYFAlM7LGgACgkQ1fmVwcYIWAY0sgCghH1QqrPLrW1xPhrTMX0lIL5C
+gGoAn2ZpodXF12WKRZGk9tQoQ9SjgBul
+=VLBW
+-----END PGP SIGNATURE-----
diff --git a/media-sound/gnome-music/gnome-music-3.12.0.ebuild b/media-sound/gnome-music/gnome-music-3.12.0.ebuild
new file mode 100644
index 00000000..bfe8f60f
--- /dev/null
+++ b/media-sound/gnome-music/gnome-music-3.12.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnome-music/gnome-music-3.10.3.ebuild,v 1.5 2014/03/09 12:06:10 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python{3_2,3_3} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Music management for Gnome"
+HOMEPAGE="http://wiki.gnome.org/Apps/Music"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+# Let people emerge this by default, bug #472932
+IUSE+=" python_single_target_python3_2 +python_single_target_python3_3"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.28:2
+ >=dev-libs/gobject-introspection-1.35.9
+ >=media-libs/grilo-0.2.6:0.2[introspection]
+ >=x11-libs/gtk+-3.9:3[introspection]
+"
+RDEPEND="${COMMON_DEPEND}
+ app-misc/tracker[introspection(+)]
+ || (
+ app-misc/tracker[gstreamer]
+ app-misc/tracker[xine]
+ )
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-plugins/gst-plugins-meta:1.0
+ media-plugins/grilo-plugins:0.2[tracker]
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.26
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure ITSTOOL="$(type -P true)"
+}