summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-10-28 18:00:54 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2012-10-28 18:28:57 +0100
commit30aec2778140623149d851937e0a15423d150b01 (patch)
treec91078886bbef21a09df072cba8a5228f12158a6 /app-dicts
parentgnome-base/gnome-desktop: 3.6.0.1 → 3.6.1 (diff)
downloadgnome-30aec2778140623149d851937e0a15423d150b01.tar.gz
gnome-30aec2778140623149d851937e0a15423d150b01.tar.bz2
gnome-30aec2778140623149d851937e0a15423d150b01.zip
app-dicts/gnome-dictionary: 3.4.0 → 3.6.0
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/gnome-dictionary/Manifest11
-rw-r--r--app-dicts/gnome-dictionary/gnome-dictionary-3.6.0.ebuild57
-rw-r--r--app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild26
3 files changed, 87 insertions, 7 deletions
diff --git a/app-dicts/gnome-dictionary/Manifest b/app-dicts/gnome-dictionary/Manifest
new file mode 100644
index 00000000..10e05f44
--- /dev/null
+++ b/app-dicts/gnome-dictionary/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST gnome-dictionary-3.6.0.tar.xz 2141008 SHA256 1ad03f629bbfe4360fc6d8dd2d7cb4a03e24579068bdd79a25ff5fc5fbff6fa9 SHA512 7478661750030004e5c0ce205ae9e2f112ad1e95c32b8aaadec3f7994b690f580b7aa05b68e485fa5924d75d686e6d2769f82d8561727e5e6aa62032109aa2ab WHIRLPOOL f147a50617a67b395a02609e6e03934712da5da32eb31609837cec2684357269f610692a5894690d09428fa392ecd9f93db56f9349e1e7dc78958b901e01dbfd
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.19 (GNU/Linux)
+
+iEYEAREKAAYFAlCNZMYACgkQ1fmVwcYIWAZpggCeLowOkwJduwkneRpCm4tUWpvz
+1VwAnRDxqzwt+GIyGOYxDTjy76WzYCUk
+=FkMD
+-----END PGP SIGNATURE-----
diff --git a/app-dicts/gnome-dictionary/gnome-dictionary-3.6.0.ebuild b/app-dicts/gnome-dictionary/gnome-dictionary-3.6.0.ebuild
new file mode 100644
index 00000000..462ea905
--- /dev/null
+++ b/app-dicts/gnome-dictionary/gnome-dictionary-3.6.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="Dictionary utility for GNOME 3"
+HOMEPAGE="https://live.gnome.org/GnomeUtils"
+
+LICENSE="GPL-2 LGPL-2.1 FDL-1.1"
+SLOT="0"
+IUSE="ipv6"
+if [[ ${PV} = 9999 ]]; then
+ IUSE="${IUSE} doc"
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+fi
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.28.0:2
+ x11-libs/cairo
+ >=x11-libs/gtk+-3.0.0:3
+ x11-libs/pango
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas
+ !<gnome-extra/gnome-utils-3.4
+"
+# ${PN} was part of gnome-utils before 3.4
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ >=dev-util/gtk-doc-am-1.15
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+if [[ ${PV} = 9999 ]]; then
+ DEPEND="${DEPEND}
+ doc? ( >=dev-util/gtk-doc-1.15 )"
+fi
+
+src_configure() {
+ DOCS="AUTHORS NEWS README TODO"
+ G2CONF="${G2CONF}
+ --disable-schemas-compile
+ $(use_enable ipv6)"
+ gnome2_src_configure
+}
diff --git a/app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild b/app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild
index a8956e21..462ea905 100644
--- a/app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild
+++ b/app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild
@@ -3,6 +3,7 @@
# $Header: $
EAPI="4"
+GCONF_DEBUG="yes"
GNOME2_LA_PUNT="yes"
inherit gnome2
@@ -15,31 +16,42 @@ HOMEPAGE="https://live.gnome.org/GnomeUtils"
LICENSE="GPL-2 LGPL-2.1 FDL-1.1"
SLOT="0"
-IUSE="doc ipv6"
+IUSE="ipv6"
if [[ ${PV} = 9999 ]]; then
+ IUSE="${IUSE} doc"
KEYWORDS=""
else
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
fi
-COMMON_DEPEND=">=dev-libs/glib-2.28.0:2
+COMMON_DEPEND="
+ >=dev-libs/glib-2.28.0:2
x11-libs/cairo
>=x11-libs/gtk+-3.0.0:3
- x11-libs/pango"
+ x11-libs/pango
+"
RDEPEND="${COMMON_DEPEND}
gnome-base/gsettings-desktop-schemas
- !<gnome-extra/gnome-utils-3.4"
+ !<gnome-extra/gnome-utils-3.4
+"
# ${PN} was part of gnome-utils before 3.4
DEPEND="${COMMON_DEPEND}
- app-text/gnome-doc-utils
+ app-text/yelp-tools
+ >=dev-util/gtk-doc-am-1.15
>=dev-util/intltool-0.40
>=sys-devel/gettext-0.17
virtual/pkgconfig
- doc? ( >=dev-util/gtk-doc-1.15 )"
+"
-pkg_setup() {
+if [[ ${PV} = 9999 ]]; then
+ DEPEND="${DEPEND}
+ doc? ( >=dev-util/gtk-doc-1.15 )"
+fi
+
+src_configure() {
DOCS="AUTHORS NEWS README TODO"
G2CONF="${G2CONF}
--disable-schemas-compile
$(use_enable ipv6)"
+ gnome2_src_configure
}