summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJavier Villavicencio <the_paya@gentoo.org>2010-10-27 04:49:07 -0300
committerJavier Villavicencio <the_paya@gentoo.org>2010-10-27 04:49:07 -0300
commite100db567eafb82442c76ac8dbfeabf5fa3c84bc (patch)
treeada5529cbfb624be14953da908410de116a4748a /sys-netbsd/netbsd-share
parentAdded Manifests and files subdirs (diff)
downloadgentoo-bsd-e100db567eafb82442c76ac8dbfeabf5fa3c84bc.tar.gz
gentoo-bsd-e100db567eafb82442c76ac8dbfeabf5fa3c84bc.tar.bz2
gentoo-bsd-e100db567eafb82442c76ac8dbfeabf5fa3c84bc.zip
Relayout the repo as a portage overlay.
Diffstat (limited to 'sys-netbsd/netbsd-share')
-rw-r--r--sys-netbsd/netbsd-share/Manifest2
-rw-r--r--sys-netbsd/netbsd-share/files/netbsd-share-5.0-Makefile.patch13
-rw-r--r--sys-netbsd/netbsd-share/netbsd-share-5.0.ebuild46
3 files changed, 61 insertions, 0 deletions
diff --git a/sys-netbsd/netbsd-share/Manifest b/sys-netbsd/netbsd-share/Manifest
new file mode 100644
index 0000000..ab05610
--- /dev/null
+++ b/sys-netbsd/netbsd-share/Manifest
@@ -0,0 +1,2 @@
+AUX netbsd-share-5.0-Makefile.patch 450 RMD160 63091665a897dd7e8d227307e185f3439e779e27 SHA1 a9563b4cb4cd981f1def89298936ce77785fbe29 SHA256 b5a0361e74ca91f8d833ce40a0b72b195d202695a01191bc9a38fbbf6716df23
+EBUILD netbsd-share-5.0.ebuild 1222 RMD160 97255f41aece3b8bdcdfb0888c877c727913202b SHA1 01385c01e968f798bec4413aca40adc3ff591ecd SHA256 f7ae95b6b41274de16693048b4f3e2ba00b5e473c20f12b0b54ae00774e2d426
diff --git a/sys-netbsd/netbsd-share/files/netbsd-share-5.0-Makefile.patch b/sys-netbsd/netbsd-share/files/netbsd-share-5.0-Makefile.patch
new file mode 100644
index 0000000..bf65f5c
--- /dev/null
+++ b/sys-netbsd/netbsd-share/files/netbsd-share-5.0-Makefile.patch
@@ -0,0 +1,13 @@
+--- Makefile.orig 2009-08-06 17:03:37.000000000 +0200
++++ Makefile 2009-08-06 17:10:21.000000000 +0200
+@@ -7,8 +7,8 @@
+
+ .if ${MKSHARE} != "no" || \
+ make(clean) || make(cleandir) || make(distclean) || make(obj)
+-SUBDIR= atf dict doc examples legal man me misc mk \
+- tabset termcap tmac wscons xml xsl zoneinfo
++SUBDIR= atf dict doc examples legal me misc mk \
++ tmac wscons xml xsl zoneinfo
+ .if ${MKNLS} != "no"
+ SUBDIR+=i18n locale nls
+ .endif
diff --git a/sys-netbsd/netbsd-share/netbsd-share-5.0.ebuild b/sys-netbsd/netbsd-share/netbsd-share-5.0.ebuild
new file mode 100644
index 0000000..ee4579c
--- /dev/null
+++ b/sys-netbsd/netbsd-share/netbsd-share-5.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo FounDation
+# Distributed under the terms of the GNU General Public License v2
+# Gentoo/NetBSD share base system
+# Patrice Clement <charlieroot@free.fr>
+inherit eutils netbsd
+
+DESCRIPTION="NetBSD 5.0 share base system"
+HOMEPAGE="http://cvsweb.netbsd.org"
+SRC_URI=""
+SLOT="0"
+LICENCE="BSD"
+KEYWORDS="~x86-nbsd"
+
+DEPEND=">=sys-netbsd/netbsd-src-5.0
+ >=sys-netbsd/netbsd-cctools-5.0"
+
+src_unpack() {
+ cd ${NETBSD_SRC_DIR}/share
+ netbsd_mk_prepatch
+
+ # This patch prevents man and termcap directories to be installed.
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+}
+
+src_compile() {
+ cd ${NETBSD_SRC_DIR}/share
+ netbsd_src_compile cleandir
+ netbsd_src_compile dependall
+}
+
+src_install() {
+ cd ${D}
+ # Strange behaviour ? Same as with netbsd-libs. This time, we can't unset
+ # FILESDIR (read-only variable). Just create the dir and remove it later.
+ dodir ./${FILESDIR}
+ netbsd_create_dirs usr/share
+ cd ${NETBSD_SRC_DIR}/share
+ netbsd_src_install install
+ cd ${D}
+ netbsd_clean_dirs ./
+ # Here!
+ find ./${FILESDIR} -type f -exec mv {} usr/share/doc/smm \;
+ rm -rf ./${FILESDIR}
+ find usr/share/man -type f -name '*.html'|xargs dohtml
+ rm -rf usr/share/man/html[1-9]
+}