summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJavier Villavicencio <the_paya@gentoo.org>2010-10-27 04:49:07 -0300
committerJavier Villavicencio <the_paya@gentoo.org>2010-10-27 04:49:07 -0300
commite100db567eafb82442c76ac8dbfeabf5fa3c84bc (patch)
treeada5529cbfb624be14953da908410de116a4748a /sys-netbsd/netbsd-cctools/netbsd-cctools-5.0.ebuild
parentAdded Manifests and files subdirs (diff)
downloadgentoo-bsd-e100db567eafb82442c76ac8dbfeabf5fa3c84bc.tar.gz
gentoo-bsd-e100db567eafb82442c76ac8dbfeabf5fa3c84bc.tar.bz2
gentoo-bsd-e100db567eafb82442c76ac8dbfeabf5fa3c84bc.zip
Relayout the repo as a portage overlay.
Diffstat (limited to 'sys-netbsd/netbsd-cctools/netbsd-cctools-5.0.ebuild')
-rw-r--r--sys-netbsd/netbsd-cctools/netbsd-cctools-5.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-netbsd/netbsd-cctools/netbsd-cctools-5.0.ebuild b/sys-netbsd/netbsd-cctools/netbsd-cctools-5.0.ebuild
new file mode 100644
index 0000000..942e947
--- /dev/null
+++ b/sys-netbsd/netbsd-cctools/netbsd-cctools-5.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# Gentoo/NetBSD cross-compiling tools needed to build, compile and install NetBSD system parts
+# Patrice Clement <charlieroot@free.fr>
+inherit netbsd
+
+DESCRIPTION="Build, compile and install tools to compile NetBSD 5.0 system."
+HOMEPAGE="http://cvsweb.netbsd.org"
+SRC_URI=""
+SLOT="0"
+LICENCE="BSD"
+KEYWORDS="~x86-nbsd"
+
+DEPEND=">=sys-netbsd/netbsd-src-5.0"
+
+src_compile() {
+ # "dummy" make clean
+ cd ${NETBSD_SRC_DIR}/tools
+ netbsd_src_compile clean
+}
+
+src_install() {
+ # Let's go inside NetBSD sources directory
+ cd ${NETBSD_SRC_DIR}
+ # If objects directory doesn't exist, we create it
+ if [ ! -d ${NETBSD_SRC_DIR}/objdir ]; then
+ dodir ${NETBSD_SRC_DIR}/objdir
+ fi
+ # We display some information before building tools
+ einfo "Cross-compiling tools will be compiled and installed in ${NETBSD_TOOLDIR} ..."
+ sleep 5
+ ./build.sh -a i386 -m i386 -O ${NETBSD_SRC_DIR}/objdir -T ${NETBSD_TOOLDIR} tools || die "./build.sh tools failed"
+ einfo "Build finished."
+}