aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gentoo_ads/example_settings.py')
-rw-r--r--gentoo_ads/example_settings.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/gentoo_ads/example_settings.py b/gentoo_ads/example_settings.py
index f76c474..60cb68d 100644
--- a/gentoo_ads/example_settings.py
+++ b/gentoo_ads/example_settings.py
@@ -13,6 +13,14 @@ import os
## please note, in general the ads.py file should live outside the webroot.
CONFIG_PATH = '/some/path/towards/the/file/gentoo-ads/example_ads.py'
+## Put in an identifying string like gentoo-ads
+## This facilitates filtering with syslog
+AD_LOG_PREFIX = 'example-domain-ads'
+
+## PLEASE NOTE: You need to setup two variables in logging_setup.py, namely LOGGING_DEBUG and SYS_LOG_ADDRESS
+## IF LOGGING_DEBUG = True we log to both the console (for debugging) and syslog
+## SYS_LOG_ADDRESS is simply the log file you wish to use, in general and since we want to use the SysLogHandler, we desire to log to /dev/log
+
## nifty, facilitates use of advertiser dictionary
## loads a python module living somwhere on the machine
## though if it finds a good .pyc|o it will use it first