summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2016-04-19 21:43:24 +0500
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2016-04-19 21:43:24 +0500
commita68133f3aa6deb70629ae8c4877ac35c0132dd5e (patch)
tree7f952b4f1e3b8a3c91cc29bc80e59eb8a32e15c2 /dev-games
parentdev-games/aseprite: Bump to 1.1.4.1 (diff)
downloadgamerlay-a68133f3aa6deb70629ae8c4877ac35c0132dd5e.tar.gz
gamerlay-a68133f3aa6deb70629ae8c4877ac35c0132dd5e.tar.bz2
gamerlay-a68133f3aa6deb70629ae8c4877ac35c0132dd5e.zip
dev-games/aseprite: Cleanup and EAPI 6
Package-Manager: portage-2.2.26 Manifest-Sign-Key: A018DE8C
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/aseprite/aseprite-1.1.4.1.ebuild19
-rw-r--r--dev-games/aseprite/metadata.xml1
2 files changed, 10 insertions, 10 deletions
diff --git a/dev-games/aseprite/aseprite-1.1.4.1.ebuild b/dev-games/aseprite/aseprite-1.1.4.1.ebuild
index 8a6de5a..f89be11 100644
--- a/dev-games/aseprite/aseprite-1.1.4.1.ebuild
+++ b/dev-games/aseprite/aseprite-1.1.4.1.ebuild
@@ -2,20 +2,22 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit cmake-utils multilib toolchain-funcs flag-o-matic
+inherit cmake-utils flag-o-matic
DESCRIPTION="Animated sprite editor & pixel art tool"
HOMEPAGE="http://www.aseprite.org"
SRC_URI="https://github.com/aseprite/aseprite/releases/download/v${PV}/Aseprite-v${PV}-Source.zip"
-LICENSE="GPL-2 FTL"
+# See https://github.com/aseprite/aseprite#credits
+# Some bundled third-party packages built-in:
+# gtest duktape modp_b64 simpleini
+LICENSE="BSD GPL-2 MIT"
SLOT="0"
-# giflib still unkeyworded
KEYWORDS="~amd64 ~x86"
-IUSE="debug memleak webp"
+IUSE="debug test webp"
RDEPEND="dev-libs/tinyxml
media-libs/allegro:0[X,png]
@@ -49,8 +51,6 @@ src_prepare() {
if use debug ; then
sed -i '/-DNDEBUG/d' CMakeLists.txt || die
fi
- # Replace to actual version
-# sed -i -e "s:1.1.2-dev:1.1.3:g" src/config.h data/gui.xml || die
}
src_configure() {
@@ -69,8 +69,9 @@ src_configure() {
-DUSE_SHARED_PIXMAN=ON
-DUSE_SHARED_TINYXML=ON
-DUSE_SHARED_ZLIB=ON
- $(cmake-utils_use_with webp WEBP_SUPPORT)
- $(cmake-utils_use_enable memleak)
+ -DUSE_SHARED_LIBWEBP=ON
+ -DWITH_WEBP_SUPPORT="$(usex webp)"
+ -DENABLE_TESTS="$(usex test)"
)
cmake-utils_src_configure
diff --git a/dev-games/aseprite/metadata.xml b/dev-games/aseprite/metadata.xml
index 91c8b9b..bafa309 100644
--- a/dev-games/aseprite/metadata.xml
+++ b/dev-games/aseprite/metadata.xml
@@ -8,7 +8,6 @@
Animated sprite editor and pixel art tool
</longdescription>
<use>
- <flag name="memleak">Enable memory-leaks detector (only for developers)</flag>
<flag name="webp">Enable webp image format support</flag>
</use>
</pkgmetadata>