summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Misbakh-Soloviov <mva@gentoo.org>2023-04-16 02:06:38 +0700
committerVadim Misbakh-Soloviov <mva@gentoo.org>2023-04-16 02:06:38 +0700
commitcc137a6f8dc88a6ac032f639548f5eb3827c168b (patch)
tree520ad38613edfd9d1d2a0006db59dabe8272be50
parentgames-strategy/defcon: use version from gentoo repo (diff)
downloadgamerlay-cc137a6f8dc88a6ac032f639548f5eb3827c168b.tar.gz
gamerlay-cc137a6f8dc88a6ac032f639548f5eb3827c168b.tar.bz2
gamerlay-cc137a6f8dc88a6ac032f639548f5eb3827c168b.zip
games-arcade/VVVVVV: new version
Signed-off-by: Vadim Misbakh-Soloviov <mva@gentoo.org>
-rw-r--r--games-arcade/VVVVVV/Manifest2
-rw-r--r--games-arcade/VVVVVV/VVVVVV-2.4_pre20230416.ebuild (renamed from games-arcade/VVVVVV/VVVVVV-2.02_p20200206.ebuild)27
2 files changed, 18 insertions, 11 deletions
diff --git a/games-arcade/VVVVVV/Manifest b/games-arcade/VVVVVV/Manifest
index 4771ae7..2e3df15 100644
--- a/games-arcade/VVVVVV/Manifest
+++ b/games-arcade/VVVVVV/Manifest
@@ -1 +1 @@
-DIST VVVVVV-data.zip 61404595 BLAKE2B 35eb3a2463942af55122c07c1feadefd70b5e7ee5115027791affa3f4fde8ef2db2a49e471ecae269034788c63b9bdc239b85f0b1bef82b83b91332cdde4edbb SHA512 3cb08ede10ea8ed41056fef1837ef85b981f2cb8fc7627da4393984b9e8045b0a8343120520c32e24ff7e97399eabaa790d1d7b35c3e5dd30e052837b2c021da
+DIST VVVVVV-2.4_pre20230416-data.zip 61405423 BLAKE2B 86e8827a35d3d1df37e22a3832f4323fe8dd08a3e3781424b9dff6b3c0e19bd91fb75331c3a37510f92701605d8c0d0837c9f66c4979e43e2f2f035ddfbd8dac SHA512 2215bea302aa0edbb9ee8694ccd1b24cfa4bc6a8a99cb6905d8fb864cef5cf7583920d8bb1cd79e10ed5350a6a734f21f4e92c7c559358d9191fa503247ba12a
diff --git a/games-arcade/VVVVVV/VVVVVV-2.02_p20200206.ebuild b/games-arcade/VVVVVV/VVVVVV-2.4_pre20230416.ebuild
index 0bc68c4..46ad91c 100644
--- a/games-arcade/VVVVVV/VVVVVV-2.02_p20200206.ebuild
+++ b/games-arcade/VVVVVV/VVVVVV-2.4_pre20230416.ebuild
@@ -1,33 +1,40 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-inherit cmake desktop git-r3
+EAPI=8
+inherit wrapper cmake desktop git-r3
DESCRIPTION="Retro-styled open-world 2D puzzle platformer"
HOMEPAGE="https://thelettervsixtim.es/"
EGIT_REPO_URI="https://github.com/TerryCavanagh/VVVVVV"
-EGIT_COMMIT="4e378b6057cca8e994b5b3049ff8b0cdadf1ebd9"
+EGIT_COMMIT="fb386681821d503b767c465d41d99126626c2789"
+# TODO
+# EGIT_SUBMODULES=( -third_party/{physfs,libxml2,FAudio} )
-SRC_URI="https://thelettervsixtim.es/makeandplay/data.zip -> ${PN}-data.zip"
+SRC_URI="https://thelettervsixtim.es/makeandplay/data.zip -> ${PF}-data.zip"
RESTRICT="mirror"
LICENSE="VVVVVV-License-1.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-DEPEND="media-libs/libsdl2
- media-libs/sdl2-mixer"
+DEPEND="
+ media-libs/libsdl2
+ media-libs/sdl2-mixer
+"
+# dev-libs/tinyxml2
+# app-emulation/faudio
+# dev-games/physfs
RDEPEND="${DEPEND}"
CMAKE_USE_DIR="${S}/desktop_version"
src_install() {
- exeinto /opt/${PN}
+ exeinto /opt/"${PN}"
doexe "${BUILD_DIR}/${PN}"
- insinto /opt/${PN}
- newins "${DISTDIR}/${PN}-data.zip" data.zip
+ insinto /opt/"${PN}"
+ newins "${DISTDIR}/${PF}-data.zip" data.zip
make_wrapper "${PN}" "./${PN}" "/opt/${PN}"
dodoc README.md
}