aboutsummaryrefslogtreecommitdiff
path: root/TODO
diff options
context:
space:
mode:
authorCorentin Chary <corentincj@iksaif.net>2012-04-23 17:05:59 +0200
committerCorentin Chary <corentincj@iksaif.net>2012-04-23 17:05:59 +0200
commit07beab265ce9d0cd5784f88ff36e56b438f62ee5 (patch)
tree828faffc9eaa04c374ff627ef924a08a9f88a7da /TODO
parenteuscanwww: use tz aware datetimes (diff)
downloadeuscan-07beab265ce9d0cd5784f88ff36e56b438f62ee5.tar.gz
euscan-07beab265ce9d0cd5784f88ff36e56b438f62ee5.tar.bz2
euscan-07beab265ce9d0cd5784f88ff36e56b438f62ee5.zip
TODO: update
Signed-off-by: Corentin Chary <corentincj@iksaif.net>
Diffstat (limited to 'TODO')
-rw-r--r--TODO63
1 files changed, 32 insertions, 31 deletions
diff --git a/TODO b/TODO
index 11d089c..110bd7d 100644
--- a/TODO
+++ b/TODO
@@ -1,52 +1,53 @@
TODO
====
-GSoC Ideas
-----------
-- Misc work on detection
-- Celery port
-
euscan
------
-- run euscan on .ebuild (see /usr/bin/ebuild + os.environ['PORTDIR_OVERLAY']
-- check other distros (youri, distrowatch, distromatch, whoas; Equivalent-Packages)
-- steal ideas from other tools (uscan, portscout)
-- steal data from other tools (dehs)
-- debian/watch support ? (or a tool to convert debian/watch to something euscan could use).
+### Version detections
+
+- Check other distros (youri, distrowatch, distromatch, whoas; Equivalent-Packages)
+- Steal ideas from other tools (uscan, portscout)
+- Steal data from other tools (dehs)
+- Debian/watch support ? (or a tool to convert debian/watch to something euscan could use).
- push some kind of equivalent in metadata.xml
- <upsteam><watch options="quirck1 quirck2">http://my.soft/tar-(\d+).ball</watch></upstream>
-- cleaner code to separate gentoo mangled version and upstream unmangled versions
- - try to import $PV -> $MY_PV transformations from ebuilds ?
- - http://euscan.iksaif.net/package/net-misc/ntp/ 4.2.6p5 -> 4.2.6_p5
+- Add a way to enable/disable methods: other_distributions,remote_euscan,handlers, etc....
+- Try to differenciate stable, beta, alpha versions
+
+### Command line interface
+
+- Run euscan on .ebuild (see /usr/bin/ebuild + os.environ['PORTDIR_OVERLAY']
+- Choose output format (basic html, json, xml, human)
- Add a way to how we failled to find a new version
-- add a HTTP cache (1day, configurable)
-- add a way to enable/disable methods: other_distributions,remote_euscan,handlers, etc....
-- try to differenciate stable, beta, alpha versions
-- give the full Package() to handlers, not just the cpv string
-- better handlers detection logic __init__.py
+
+### Misc
+
+- clean the code to separate gentoo mangled version and upstream unmangled versions
+ - try to import $PV -> $MY_PV transformations from ebuilds ?
+- Add a HTTP cache (1day, configurable)
+- Give the full Package() to handlers, not just the cpv string
+- Better handlers detection logic __init__.py
Site Handlers
-------------
- sourceforge: http://sourceforge.net/api/file/index/project-name/vboxgtk/mtime/desc/limit/20/rss http://sourceforge.net/api/release/index/project-id/264534/rss
-- ftp.kde.org: doesn't scan the "unstable" tree
-- mysql: should use http://downloads.mysql.com/archives/
+- MySQL: should use http://downloads.mysql.com/archives/
- mariadb: should use http://downloads.askmonty.org/MariaDB/+releases/
euscanwww
---------
-- rename euscan application django-euscan/djeuscan
-- try to separate portage stuff in django-portage/djportage
-- add last scan in the footer [0.2.0]
-- add an /about/config page that describe the current config (overlays, stuff in make.conf, euscan default settings, etc..) [0.2.0]
-- add a table for overlays, change euscan_versions [0.2.0]
-- rss scan world + post ?
-- always keep in db the last upstream version (could be marked as packaged without overlay ?)
-- store euscan status (and used methods ?)
+- Try to separate portage stuff in django-portage/djportage (see what can be shared with other GSoC projects)
+- Add last scan date in the footer
+- Add an /about/config page that describe the current config (overlays, stuff in make.conf, euscan default settings, etc..)
+- Add a table for overlays, change euscan_versions
+- Create a rss for "scan world" + packages in GET
+- Always keep in db the last upstream version (could be marked as packaged without overlay ?)
+- Store euscan status (and used methods ?)
-### Commands [0.2.0]
+### Commands
- euscan_init: init local tree (portage, layman, eix)
- euscan_addoverlay: add a layman overlay
@@ -56,7 +57,7 @@ euscanwww
### Scan process
-- Move to celery: [0.2.0]
+- Move to celery:
- periodic task for emerge --sync; layman -S; eix-update etc... (every day ?)
- periodic task for euscan (once every week, groupped by category or package ?)
@@ -64,4 +65,4 @@ This would allow easier on-demand refresh from web interface
### API
-- Move to tastypie: [0.3.0]
+- Move to tastypie: