aboutsummaryrefslogtreecommitdiff
path: root/bin
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2005-09-05 13:52:20 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2005-09-05 13:52:20 +0000
commit3a692385ded1e5a7a64f4dc39f5f3900b1c75cb0 (patch)
tree29bc3ae62e5faba79e2c3d157bc65f775f68ef46 /bin
parent2005-09-04 Danny van Dyk <kugelfang@gentoo.org> (diff)
downloadeselect-3a692385ded1e5a7a64f4dc39f5f3900b1c75cb0.tar.gz
eselect-3a692385ded1e5a7a64f4dc39f5f3900b1c75cb0.tar.bz2
eselect-3a692385ded1e5a7a64f4dc39f5f3900b1c75cb0.zip
2005-09-05 Danny van Dyk <kugelfang@gentoo.org>
* libs/core.bash.in: Added inherit() function that allows dynamic and individual sourcing of libraries for each module. * bin/eselect.in: Removed sourcing of all available modules. * libs/core.bash.in, libs/path-manipulation.bash.in, libs/Makefile.in: Moved basename() and dirname() to a new seperate library. * libs/core.bash.in, libs/test.bash.in: moved has() and is_function() to tests library. * modules/binutils.eselect, modules/blas.eselect, modules/env.eselect, modules/lapack.eselect, modules/opengl.eselect: Added necessary inherit lines. diffstat: bin/eselect.in | 9 ++---- libs/Makefile.am | 1 libs/core.bash.in | 56 +++++++++++++++-------------------------- libs/path-manipulation.bash.in | 32 +++++++++++++++++++++++ libs/tests.bash.in | 17 ++++++++++++ modules/binutils.eselect | 2 + modules/blas.eselect | 2 + modules/env.eselect | 2 + modules/lapack.eselect | 2 + modules/opengl.eselect | 4 ++ 10 files changed, 85 insertions(+), 42 deletions(-) svn path=/trunk/; revision=183
Diffstat (limited to 'bin')
-rwxr-xr-xbin/eselect.in9
1 files changed, 3 insertions, 6 deletions
diff --git a/bin/eselect.in b/bin/eselect.in
index c8f2b9a..04144bb 100755
--- a/bin/eselect.in
+++ b/bin/eselect.in
@@ -46,13 +46,10 @@ ESELECT_OPTIONS=""
shopt -s extglob
shopt -s expand_aliases
-# Load core and output functions
+# Load core functions
source "${ESELECT_CORE_PATH}/core.bash" || exit 255
-source "${ESELECT_CORE_PATH}/output.bash" || die "Couldn't source output.bash"
-source "${ESELECT_CORE_PATH}/config.bash" || die "Couldn't source config.bash"
-source "${ESELECT_CORE_PATH}/multilib.bash" || die "Couldn't source multilib.bash"
-source "${ESELECT_CORE_PATH}/tests.bash" || die "Couldn't source tests.bash"
-source "${ESELECT_CORE_PATH}/manip.bash" || die "Couldn't source manip.bash"
+# Load necessary functions for the main script
+inherit manip output tests
# Sneaky trick to make die in subshells work. If you don't get
# it, don't ask...