summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-19 19:50:29 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-19 19:50:29 +0000
commitf21266108e9d7437f4d48444a4e56569760dad4f (patch)
tree006dfa225fd1c5c83f0d2d5870e2323550117321
parentFix building on systems without strndup (bug #282041). (diff)
downloadeselect-python-f21266108e9d7437f4d48444a4e56569760dad4f.tar.gz
eselect-python-f21266108e9d7437f4d48444a4e56569760dad4f.tar.bz2
eselect-python-f21266108e9d7437f4d48444a4e56569760dad4f.zip
Fix build system.
-rw-r--r--Makefile.in10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index c617486..0de6349 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -4,7 +4,13 @@ WARNINGS_FLAGS = -Wall -Wextra
all: python-wrapper
python-wrapper: config.h python-wrapper.c
- $(CC) $(CPPFLAGS) $(CFLAGS) $(WARNINGS_FLAGS) $(ASFLAGS) $(LDFLAGS) -o $@ $<
+ $(CC) $(CPPFLAGS) $(CFLAGS) $(WARNINGS_FLAGS) $(ASFLAGS) $(LDFLAGS) -o $@ python-wrapper.c
clean:
- rm -fr config.h config.h.in config.log config.status configure Makefile python-wrapper
+ rm -fr python-wrapper
+
+distclean: clean
+ rm -fr config.h config.log config.status Makefile
+
+extraclean: distclean
+ rm -fr config.h.in configure