summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-07-25 20:03:35 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-07-25 20:03:35 -0400
commitcb16f05a22acaf933a4204f6fa1d6bc3eb1a966a (patch)
tree87084f20061a6b42f238f583cb3c1e378b2f0325
parentMakefile.am: install the php-fpm.conf file with "make install". (diff)
downloadeselect-php-cb16f05a22acaf933a4204f6fa1d6bc3eb1a966a.tar.gz
eselect-php-cb16f05a22acaf933a4204f6fa1d6bc3eb1a966a.tar.bz2
eselect-php-cb16f05a22acaf933a4204f6fa1d6bc3eb1a966a.zip
Makefile.am: mark openrc/php-fpm as a script and not as data.
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 1abef9e..15b0ca8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,7 @@ eselectdir = $(datadir)/eselect/modules
nodist_eselect_DATA = $(srcdir)/src/php.eselect
initdir = $(sysconfdir)/init.d
confdir = $(sysconfdir)/conf.d
-nodist_init_DATA = $(srcdir)/openrc/php-fpm
+nodist_init_SCRIPTS = $(srcdir)/openrc/php-fpm
nodist_conf_DATA = $(srcdir)/openrc/php-fpm.conf
# Without EXTRA_DIST, these files don't wind up in the tarball.
@@ -23,7 +23,7 @@ edit = sed -e 's|@BINDIR[@]|$(bindir)|g' \
-e 's|@LOCALSTATEDIR[@]|$(localstatedir)|g' \
-e 's|@SYSCONFDIR[@]|$(sysconfdir)|g'
-$(nodist_eselect_DATA) $(nodist_apacheconf_DATA) $(nodist_init_DATA): Makefile
+$(nodist_eselect_DATA) $(nodist_apacheconf_DATA) $(nodist_init_SCRIPTS): Makefile
rm -f $@ $@.tmp
srcdir=''; \
test -f ./$@.in || srcdir=$(srcdir)/; \