aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/gstreamer/files/gstreamer-0.10.20-cross-checklib-checking.patch')
-rw-r--r--media-libs/gstreamer/files/gstreamer-0.10.20-cross-checklib-checking.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/gstreamer/files/gstreamer-0.10.20-cross-checklib-checking.patch b/media-libs/gstreamer/files/gstreamer-0.10.20-cross-checklib-checking.patch
new file mode 100644
index 0000000..103de4c
--- /dev/null
+++ b/media-libs/gstreamer/files/gstreamer-0.10.20-cross-checklib-checking.patch
@@ -0,0 +1,33 @@
+--- configure.ac 2008-11-12 20:12:08.000000000 +0100
++++ configure.ac.new 2008-11-12 20:11:58.000000000 +0100
+@@ -501,6 +501,15 @@
+ AC_SUBST(GST_DISABLE_XML_DEFINE)
+
+ dnl check for "check", unit testing library/header
++
++if test x$cross_compiling != x; then
++dnl pkg-config check that for libcheck that works for cross-compiling
++dnl but not normal compilation on Fedora & Ubuntu:
++PKG_CHECK_MODULES(CHECK, check >= 0.9.2,
++ AM_CONDITIONAL(HAVE_CHECK, true),
++ AM_CONDITIONAL(HAVE_CHECK, false)
++ )
++else
+ AM_PATH_CHECK(0.9.2,
+ [
+ HAVE_CHECK=yes
+@@ -509,13 +518,7 @@
+ ],
+ HAVE_CHECK=no)
+ AM_CONDITIONAL(HAVE_CHECK, test "x$HAVE_CHECK" = "xyes")
+-
+-dnl pkg-config check that for libcheck that works for cross-compiling
+-dnl but not normal compilation on Fedora & Ubuntu:
+-dnl PKG_CHECK_MODULES(CHECK, check >= 0.9.2,
+-dnl AM_CONDITIONAL(HAVE_CHECK, true),
+-dnl AM_CONDITIONAL(HAVE_CHECK, false)
+-dnl )
++fi
+
+ dnl *** set variables based on configure arguments
+