aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Marchese <maffblaster@gentoo.org>2023-12-21 04:17:53 -0800
committerUlrich Müller <ulm@gentoo.org>2024-05-07 19:16:52 +0200
commitfb8f7e599d39a1f4f7b1250e8ae64a7feac742e7 (patch)
tree0271324d8aed1987cc6281fa0d6233aaa97b4b6e /ebuild-writing
parentebuild-writing/functions/src_prepare/eapply: fix typo (diff)
downloaddevmanual-fb8f7e599d39a1f4f7b1250e8ae64a7feac742e7.tar.gz
devmanual-fb8f7e599d39a1f4f7b1250e8ae64a7feac742e7.tar.bz2
devmanual-fb8f7e599d39a1f4f7b1250e8ae64a7feac742e7.zip
Sentence case devmanual
Signed-off-by: Matthew Marchese <maffblaster@gentoo.org> [Whitespace. Fix rebase artifact in ebuild-writing/functions/src_test.] Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'ebuild-writing')
-rw-r--r--ebuild-writing/common-mistakes/text.xml18
-rw-r--r--ebuild-writing/eapi/text.xml28
-rw-r--r--ebuild-writing/error-handling/text.xml12
-rw-r--r--ebuild-writing/file-format/text.xml10
-rw-r--r--ebuild-writing/functions/pkg_postinst/text.xml2
-rw-r--r--ebuild-writing/functions/pkg_postrm/text.xml2
-rw-r--r--ebuild-writing/functions/pkg_preinst/text.xml2
-rw-r--r--ebuild-writing/functions/pkg_prerm/text.xml2
-rw-r--r--ebuild-writing/functions/src_compile/build-environment/text.xml10
-rw-r--r--ebuild-writing/functions/src_compile/building/text.xml4
-rw-r--r--ebuild-writing/functions/src_compile/no-build-system/text.xml2
-rw-r--r--ebuild-writing/functions/src_compile/text.xml2
-rw-r--r--ebuild-writing/functions/src_configure/configuring/text.xml4
-rw-r--r--ebuild-writing/functions/src_configure/text.xml2
-rw-r--r--ebuild-writing/functions/src_install/docompress/text.xml2
-rw-r--r--ebuild-writing/functions/src_install/text.xml8
-rw-r--r--ebuild-writing/functions/src_prepare/text.xml2
-rw-r--r--ebuild-writing/functions/src_unpack/other-formats/text.xml8
-rw-r--r--ebuild-writing/functions/src_unpack/rpm-sources/text.xml4
-rw-r--r--ebuild-writing/functions/src_unpack/text.xml4
-rw-r--r--ebuild-writing/functions/src_unpack/vcs-sources/text.xml6
-rw-r--r--ebuild-writing/functions/text.xml2
-rw-r--r--ebuild-writing/messages/text.xml8
-rw-r--r--ebuild-writing/misc-files/metadata/text.xml16
-rw-r--r--ebuild-writing/misc-files/patches/text.xml6
-rw-r--r--ebuild-writing/misc-files/text.xml2
-rw-r--r--ebuild-writing/text.xml2
-rw-r--r--ebuild-writing/use-conditional-code/text.xml2
-rw-r--r--ebuild-writing/user-submitted/text.xml2
-rw-r--r--ebuild-writing/users-and-groups/text.xml2
-rw-r--r--ebuild-writing/using-eclasses/text.xml4
-rw-r--r--ebuild-writing/variables/text.xml12
32 files changed, 96 insertions, 96 deletions
diff --git a/ebuild-writing/common-mistakes/text.xml b/ebuild-writing/common-mistakes/text.xml
index 41f6d35..5db3973 100644
--- a/ebuild-writing/common-mistakes/text.xml
+++ b/ebuild-writing/common-mistakes/text.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<guide self="ebuild-writing/common-mistakes/">
<chapter>
-<title>Common Mistakes</title>
+<title>Common mistakes</title>
<body>
<p>
@@ -11,7 +11,7 @@ writing ebuilds.
</body>
<section>
-<title>Common Ebuild Writing Mistakes</title>
+<title>Common ebuild writing mistakes</title>
<subsection>
<title>Unguarded external calls</title>
@@ -27,7 +27,7 @@ See <uri link="::ebuild-writing/error-handling/"/>.
</subsection>
<subsection>
-<title>Invalid use of <c>static</c> use-flag</title>
+<title>Invalid use of <c>static</c> USE flag</title>
<body>
<p>
The <c>static</c> use-flag should only be used to make a binary use static
@@ -217,7 +217,7 @@ the resulting Makefile.
</subsection>
<subsection>
-<title>Missing/Invalid/Broken Header</title>
+<title>Missing/invalid/broken header</title>
<body>
<p>
@@ -239,7 +239,7 @@ The first two lines <e>must</e> look like this:
</body>
</subsection>
<subsection>
-<title>Redefined P, PV, PN, PF</title>
+<title>Redefined P, PV, PN, PF variables</title>
<body>
<p>
@@ -359,7 +359,7 @@ some tips on how to find the correct dependencies.
</body>
</subsection>
<subsection>
-<title>LICENSE Invalid</title>
+<title>LICENSE invalid</title>
<body>
<p>
@@ -547,7 +547,7 @@ Don't then forget to add <c>virtual/pkgconfig</c> to BDEPEND!
</section>
<section>
-<title>Common Ebuild Submission Mistakes</title>
+<title>Common ebuild submission mistakes</title>
<subsection>
<title>Introduction</title>
<body>
@@ -560,7 +560,7 @@ Please submit ebuilds properly by following the
</body>
</subsection>
<subsection>
-<title>Tarball'ing an ebuild</title>
+<title>Tarballing an ebuild</title>
<body>
<p>
@@ -571,7 +571,7 @@ operations when reviewing.
</body>
</subsection>
<subsection>
-<title>Inlining Ebuilds</title>
+<title>Inlining ebuilds</title>
<body>
<p>
diff --git a/ebuild-writing/eapi/text.xml b/ebuild-writing/eapi/text.xml
index b6463c0..f470676 100644
--- a/ebuild-writing/eapi/text.xml
+++ b/ebuild-writing/eapi/text.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<guide self="ebuild-writing/eapi/">
<chapter>
-<title>EAPI Usage and Description</title>
+<title>EAPI usage and description</title>
<body>
<p>
@@ -112,7 +112,7 @@ Manager Specification for details about them.
<title>EAPI 5</title>
<subsection>
-<title>EAPI 5 Metadata</title>
+<title>EAPI 5 metadata</title>
<body>
<dl>
@@ -205,7 +205,7 @@ RDEPEND="dev-libs/foo:2=
</subsection>
<subsection>
-<title>EAPI 5 Profiles</title>
+<title>EAPI 5 profiles</title>
<body>
<dl>
@@ -223,7 +223,7 @@ RDEPEND="dev-libs/foo:2=
</subsection>
<subsection>
-<title>EAPI 5 Helpers</title>
+<title>EAPI 5 helpers</title>
<body>
<dl>
@@ -262,7 +262,7 @@ If USE flag is set, echo [true output][true suffix] (defaults to "yes"),
</subsection>
<subsection>
-<title>EAPI 5 Phases</title>
+<title>EAPI 5 phases</title>
<body>
<dl>
@@ -277,7 +277,7 @@ If USE flag is set, echo [true output][true suffix] (defaults to "yes"),
</subsection>
<subsection>
-<title>EAPI 5 Variables</title>
+<title>EAPI 5 variables</title>
<body>
<dl>
@@ -311,7 +311,7 @@ If USE flag is set, echo [true output][true suffix] (defaults to "yes"),
</subsection>
<subsection>
-<title>EAPI 6 Ebuild Environment</title>
+<title>EAPI 6 ebuild environment</title>
<body>
<dl>
@@ -333,7 +333,7 @@ If USE flag is set, echo [true output][true suffix] (defaults to "yes"),
</subsection>
<subsection>
-<title>EAPI 6 Phases</title>
+<title>EAPI 6 phases</title>
<body>
<dl>
@@ -376,7 +376,7 @@ src_install() {
</subsection>
<subsection>
-<title>EAPI 6 Helpers</title>
+<title>EAPI 6 helpers</title>
<body>
<dl>
@@ -456,7 +456,7 @@ src_install() {
<title>EAPI 7</title>
<subsection>
-<title>EAPI 7 Terminology</title>
+<title>EAPI 7 terminology</title>
<body>
<p>
@@ -484,7 +484,7 @@ installation targets.
</subsection>
<subsection>
-<title>EAPI 7 Variables</title>
+<title>EAPI 7 variables</title>
<body>
<dl>
@@ -534,7 +534,7 @@ installation targets.
</subsection>
<subsection>
-<title>EAPI 7 Metadata</title>
+<title>EAPI 7 metadata</title>
<body>
<dl>
@@ -552,7 +552,7 @@ installation targets.
</subsection>
<subsection>
-<title>EAPI 7 Profiles</title>
+<title>EAPI 7 profiles</title>
<body>
<dl>
@@ -567,7 +567,7 @@ installation targets.
</subsection>
<subsection>
-<title>EAPI 7 Helpers</title>
+<title>EAPI 7 helpers</title>
<body>
<dl>
diff --git a/ebuild-writing/error-handling/text.xml b/ebuild-writing/error-handling/text.xml
index f8171f5..28dca4e 100644
--- a/ebuild-writing/error-handling/text.xml
+++ b/ebuild-writing/error-handling/text.xml
@@ -1,10 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<guide self="ebuild-writing/error-handling/">
<chapter>
-<title>Error Handling</title>
+<title>Error handling</title>
<section>
-<title>Importance of Error Handling</title>
+<title>Importance of error handling</title>
<body>
<p>
@@ -32,7 +32,7 @@ Decent error handling is important because:
</section>
<section>
-<title>The <c>die</c> Function</title>
+<title>The <c>die</c> function</title>
<body>
<p>
@@ -65,7 +65,7 @@ You should use <c>die</c> on almost all external commands in ebuilds.
</section>
<section>
-<title><c>die</c> and Subshells</title>
+<title><c>die</c> and subshells</title>
<body>
<warning>
@@ -112,7 +112,7 @@ while read file ; do eapply ${file} ; done &lt; list
</section>
<section>
-<title>The <c>assert</c> Function and <c>$PIPESTATUS</c></title>
+<title>The <c>assert</c> function and <c>$PIPESTATUS</c></title>
<body>
<p>
@@ -136,7 +136,7 @@ time, <c>assert</c> is enough.
</section>
<section>
-<title>The <c>nonfatal</c> Command</title>
+<title>The <c>nonfatal</c> command</title>
<body>
<p>
diff --git a/ebuild-writing/file-format/text.xml b/ebuild-writing/file-format/text.xml
index 3772554..aa7bb72 100644
--- a/ebuild-writing/file-format/text.xml
+++ b/ebuild-writing/file-format/text.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<guide self="ebuild-writing/file-format/">
<chapter>
-<title>Ebuild File Format</title>
+<title>Ebuild file format</title>
<body>
<p>
@@ -11,7 +11,7 @@ Files should be simple text files with a <c>.ebuild</c> extension.
</body>
<section>
-<title>File Naming Rules</title>
+<title>File naming rules</title>
<body>
<p>
@@ -178,7 +178,7 @@ like CPU time or memory when being built from source.
</section>
<section>
-<title>Ebuild Header</title>
+<title>Ebuild header</title>
<body>
<p>
@@ -205,7 +205,7 @@ Council on 28 February 2017</uri> and <e>must not</e> be added any more.
</section>
<section>
-<title>Indenting and Whitespace</title>
+<title>Indenting and whitespace</title>
<body>
<p>
@@ -230,7 +230,7 @@ positions wide, and multibyte characters are just one position wide.
</section>
<section>
-<title>Character Set</title>
+<title>Character set</title>
<body>
<p>
All ebuilds (and eclasses, metadata files, etc.) must use the
diff --git a/ebuild-writing/functions/pkg_postinst/text.xml b/ebuild-writing/functions/pkg_postinst/text.xml
index 06b3330..7a160a5 100644
--- a/ebuild-writing/functions/pkg_postinst/text.xml
+++ b/ebuild-writing/functions/pkg_postinst/text.xml
@@ -58,7 +58,7 @@ pkg_postinst() {
</section>
<section>
-<title>Common <c>pkg_postinst</c> Tasks</title>
+<title>Common <c>pkg_postinst</c> tasks</title>
<body>
<p>
The most common use for <c>pkg_postinst</c> is to display post-install
diff --git a/ebuild-writing/functions/pkg_postrm/text.xml b/ebuild-writing/functions/pkg_postrm/text.xml
index 7e9b475..6607b37 100644
--- a/ebuild-writing/functions/pkg_postrm/text.xml
+++ b/ebuild-writing/functions/pkg_postrm/text.xml
@@ -54,7 +54,7 @@ pkg_postrm() {
</section>
<section>
-<title>Common <c>pkg_postrm</c> Tasks</title>
+<title>Common <c>pkg_postrm</c> tasks</title>
<body>
<p>
<c>pkg_postrm</c> is is used to update symlinks, cache files and other
diff --git a/ebuild-writing/functions/pkg_preinst/text.xml b/ebuild-writing/functions/pkg_preinst/text.xml
index ee78f6c..cb3a9ab 100644
--- a/ebuild-writing/functions/pkg_preinst/text.xml
+++ b/ebuild-writing/functions/pkg_preinst/text.xml
@@ -52,7 +52,7 @@ pkg_preinst() {
</section>
<section>
-<title>Common <c>pkg_preinst</c> Tasks</title>
+<title>Common <c>pkg_preinst</c> tasks</title>
<body>
<p>
There are a few things that are often done in <c>pkg_preinst</c>:
diff --git a/ebuild-writing/functions/pkg_prerm/text.xml b/ebuild-writing/functions/pkg_prerm/text.xml
index 7522624..9ce88f4 100644
--- a/ebuild-writing/functions/pkg_prerm/text.xml
+++ b/ebuild-writing/functions/pkg_prerm/text.xml
@@ -52,7 +52,7 @@ pkg_prerm() {
</section>
<section>
-<title>Common <c>pkg_prerm</c> Tasks</title>
+<title>Common <c>pkg_prerm</c> tasks</title>
<body>
<p>
<c>pkg_prerm</c> is used to clean up any files that would otherwise prevent
diff --git a/ebuild-writing/functions/src_compile/build-environment/text.xml b/ebuild-writing/functions/src_compile/build-environment/text.xml
index 1aa826e..a9fc035 100644
--- a/ebuild-writing/functions/src_compile/build-environment/text.xml
+++ b/ebuild-writing/functions/src_compile/build-environment/text.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<guide self="ebuild-writing/functions/src_compile/build-environment/">
<chapter>
-<title>Configuring Build Environment</title>
+<title>Configuring build environment</title>
<body>
<p>
@@ -23,7 +23,7 @@ Ebuilds must not simply ignore user CFLAGS, CXXFLAGS or LDFLAGS <d/> see
</body>
<section>
-<title>Guidelines for Flag Filtering</title>
+<title>Guidelines for flag filtering</title>
<body>
<p>
@@ -59,7 +59,7 @@ line in the correct place.
</section>
<section>
-<title>Simple Flag Stripping</title>
+<title>Simple flag stripping</title>
<body>
<p>
@@ -94,7 +94,7 @@ conservative set of flags.
</section>
<section>
-<title>Flag Replacement</title>
+<title>Flag replacement</title>
<body>
<p>
@@ -124,7 +124,7 @@ the flags to be replaced.
</section>
<section>
-<title>Adding Additional Flags</title>
+<title>Adding additional flags</title>
<body>
<p>
Sometimes it is necessary to add in additional <c>CFLAGS</c>
diff --git a/ebuild-writing/functions/src_compile/building/text.xml b/ebuild-writing/functions/src_compile/building/text.xml
index 9ac9c13..96aeef8 100644
--- a/ebuild-writing/functions/src_compile/building/text.xml
+++ b/ebuild-writing/functions/src_compile/building/text.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<guide self="ebuild-writing/functions/src_compile/building/">
<chapter>
-<title>Building a Package</title>
+<title>Building a package</title>
<body>
<p>
@@ -28,7 +28,7 @@ some MIPS and SPARC systems.
</body>
<section>
-<title>Fixing Compiler Usage</title>
+<title>Fixing compiler usage</title>
<body>
<p>
diff --git a/ebuild-writing/functions/src_compile/no-build-system/text.xml b/ebuild-writing/functions/src_compile/no-build-system/text.xml
index e4e878a..b5d6191 100644
--- a/ebuild-writing/functions/src_compile/no-build-system/text.xml
+++ b/ebuild-writing/functions/src_compile/no-build-system/text.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<guide self="ebuild-writing/functions/src_compile/no-build-system/">
<chapter>
-<title>No Build System</title>
+<title>No build system</title>
<body>
<p>
diff --git a/ebuild-writing/functions/src_compile/text.xml b/ebuild-writing/functions/src_compile/text.xml
index abe67d9..a74bbc2 100644
--- a/ebuild-writing/functions/src_compile/text.xml
+++ b/ebuild-writing/functions/src_compile/text.xml
@@ -72,7 +72,7 @@ src_compile() {
</section>
<section>
-<title><c>src_compile</c> Processes</title>
+<title><c>src_compile</c> processes</title>
<body>
<p>
The following subsections cover different topics which often occur when writing
diff --git a/ebuild-writing/functions/src_configure/configuring/text.xml b/ebuild-writing/functions/src_configure/configuring/text.xml
index 14672c4..f7b3076 100644
--- a/ebuild-writing/functions/src_configure/configuring/text.xml
+++ b/ebuild-writing/functions/src_configure/configuring/text.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<guide self="ebuild-writing/functions/src_configure/configuring/">
<chapter>
-<title>Configuring a Package</title>
+<title>Configuring a package</title>
<body>
<p>
@@ -75,7 +75,7 @@ form can be used.
</body>
<section>
-<title><c>econf</c> Options</title>
+<title><c>econf</c> options</title>
<body>
<p>
diff --git a/ebuild-writing/functions/src_configure/text.xml b/ebuild-writing/functions/src_configure/text.xml
index 03f9583..50ccc42 100644
--- a/ebuild-writing/functions/src_configure/text.xml
+++ b/ebuild-writing/functions/src_configure/text.xml
@@ -71,7 +71,7 @@ eclass in order to use the <c>append-ldflags</c> function.
</section>
<section>
-<title><c>src_configure</c> Processes</title>
+<title><c>src_configure</c> processes</title>
<body>
<p>
The following subsections cover different topics which often occur when writing
diff --git a/ebuild-writing/functions/src_install/docompress/text.xml b/ebuild-writing/functions/src_install/docompress/text.xml
index ed1634b..adaef2b 100644
--- a/ebuild-writing/functions/src_install/docompress/text.xml
+++ b/ebuild-writing/functions/src_install/docompress/text.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<guide self="ebuild-writing/functions/src_install/docompress/">
<chapter>
-<title>Controllable Compression</title>
+<title>Controllable compression</title>
<body>
<p>
diff --git a/ebuild-writing/functions/src_install/text.xml b/ebuild-writing/functions/src_install/text.xml
index d6589e9..85cfa6e 100644
--- a/ebuild-writing/functions/src_install/text.xml
+++ b/ebuild-writing/functions/src_install/text.xml
@@ -84,7 +84,7 @@ src_install() {
</section>
<section>
-<title>Easy Installs</title>
+<title>Easy installs</title>
<body>
<p>
Often, especially with autotools-powered packages, there is a <c>Makefile</c>
@@ -129,7 +129,7 @@ applied to different parts of the application, for example.
</section>
<section>
-<title>Trivial Installs</title>
+<title>Trivial installs</title>
<body>
<p>
@@ -209,7 +209,7 @@ simple <c>Makefile</c> driven install.
</section>
<section>
-<title>Other Installs</title>
+<title>Other installs</title>
<body>
<p>
Sometimes, there will be a <c>Makefile</c> that does not
@@ -221,7 +221,7 @@ upstream explaining the situation to them.
</section>
<section>
-<title><c>src_install</c> Processes</title>
+<title><c>src_install</c> processes</title>
<body>
<p>
diff --git a/ebuild-writing/functions/src_prepare/text.xml b/ebuild-writing/functions/src_prepare/text.xml
index 7f515bb..342a112 100644
--- a/ebuild-writing/functions/src_prepare/text.xml
+++ b/ebuild-writing/functions/src_prepare/text.xml
@@ -83,7 +83,7 @@ src_prepare() {
</section>
<section>
-<title><c>src_prepare</c> Processes</title>
+<title><c>src_prepare</c> processes</title>
<body>
<p>
The following subsections cover different topics which often occur
diff --git a/ebuild-writing/functions/src_unpack/other-formats/text.xml b/ebuild-writing/functions/src_unpack/other-formats/text.xml
index 809802b..891b322 100644
--- a/ebuild-writing/functions/src_unpack/other-formats/text.xml
+++ b/ebuild-writing/functions/src_unpack/other-formats/text.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<guide self="ebuild-writing/functions/src_unpack/other-formats/">
<chapter>
-<title>Other Archive Formats</title>
+<title>Other archive formats</title>
<body>
<p>
@@ -11,7 +11,7 @@ Instructions for some of them are detailed below:
</body>
<section>
-<title>Zip Files</title>
+<title>Zip files</title>
<body>
<p>
@@ -27,7 +27,7 @@ If a package is supplied as a .zip file, you should:
</section>
<section>
-<title>Shar Files</title>
+<title>Shar files</title>
<body>
<p>
If a package is supplied as a <c>.shar</c> file, you should repackage it locally
@@ -39,7 +39,7 @@ done a release in at least ten years.
</section>
<section>
-<title>RAR Files</title>
+<title>RAR files</title>
<body>
<p>
diff --git a/ebuild-writing/functions/src_unpack/rpm-sources/text.xml b/ebuild-writing/functions/src_unpack/rpm-sources/text.xml
index 5d3a6be..0029c53 100644
--- a/ebuild-writing/functions/src_unpack/rpm-sources/text.xml
+++ b/ebuild-writing/functions/src_unpack/rpm-sources/text.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<guide self="ebuild-writing/functions/src_unpack/rpm-sources/">
<chapter>
-<title>RPM Sources</title>
+<title>RPM sources</title>
<body>
<p>
@@ -40,7 +40,7 @@ format.
</body>
<section>
-<title>Example RPM Handling</title>
+<title>Example RPM handling</title>
<body>
<p>
diff --git a/ebuild-writing/functions/src_unpack/text.xml b/ebuild-writing/functions/src_unpack/text.xml
index 045e1c9..250d947 100644
--- a/ebuild-writing/functions/src_unpack/text.xml
+++ b/ebuild-writing/functions/src_unpack/text.xml
@@ -56,7 +56,7 @@ src_unpack() {
</section>
<section>
-<title>Unpacking Tarballs</title>
+<title>Unpacking tarballs</title>
<body>
<p>
The <c>unpack</c> function should be used to unpack tarballs, compressed
@@ -109,7 +109,7 @@ specify the necessary build time dependency (<c>BDEPEND</c>) for it.
</section>
<section>
-<title><c>src_unpack</c> Actions</title>
+<title><c>src_unpack</c> actions</title>
<body>
<p>
The following subsections cover different topics which often occur when writing
diff --git a/ebuild-writing/functions/src_unpack/vcs-sources/text.xml b/ebuild-writing/functions/src_unpack/vcs-sources/text.xml
index 0596fef..68fbe91 100644
--- a/ebuild-writing/functions/src_unpack/vcs-sources/text.xml
+++ b/ebuild-writing/functions/src_unpack/vcs-sources/text.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<guide self="ebuild-writing/functions/src_unpack/vcs-sources/">
<chapter>
-<title>Version Control System (VCS) Sources</title>
+<title>Version Control System (VCS) sources</title>
<body>
<p>
@@ -31,7 +31,7 @@ system for fetching.
</body>
<section>
-<title>Disadvantages of VCS Sources</title>
+<title>Disadvantages of VCS sources</title>
<body>
<p>
@@ -71,7 +71,7 @@ $ git archive --prefix=emacs/ HEAD | xz &gt; emacs-${PV}.tar.xz
</section>
<section>
-<title>Disadvantages of VCS Live Sources</title>
+<title>Disadvantages of VCS live sources</title>
<body>
<p>
diff --git a/ebuild-writing/functions/text.xml b/ebuild-writing/functions/text.xml
index 47babef..0c1fbd6 100644
--- a/ebuild-writing/functions/text.xml
+++ b/ebuild-writing/functions/text.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<guide self="ebuild-writing/functions/">
<chapter>
-<title>Ebuild Phase Functions</title>
+<title>Ebuild phase functions</title>
<body>
<p>
diff --git a/ebuild-writing/messages/text.xml b/ebuild-writing/messages/text.xml
index bfe666c..fe05e6b 100644
--- a/ebuild-writing/messages/text.xml
+++ b/ebuild-writing/messages/text.xml
@@ -28,7 +28,7 @@ occupy 4 columns with their fancy leading markers.
</body>
<section>
-<title>Information Messages</title>
+<title>Information messages</title>
<body>
<p>
@@ -70,7 +70,7 @@ src_compile() {
</section>
<section>
-<title>Warning Messages</title>
+<title>Warning messages</title>
<body>
<p>
@@ -82,7 +82,7 @@ used for warning messages rather than information.
</section>
<section>
-<title>Error Messages</title>
+<title>Error messages</title>
<body>
<p>
@@ -119,7 +119,7 @@ See <uri link="::function-reference/message-functions/"/> for a full list of fun
</section>
<section>
-<title>Good and Bad Messages</title>
+<title>Good and bad messages</title>
<body>
<p>
diff --git a/ebuild-writing/misc-files/metadata/text.xml b/ebuild-writing/misc-files/metadata/text.xml
index fb0dab1..cde4364 100644
--- a/ebuild-writing/misc-files/metadata/text.xml
+++ b/ebuild-writing/misc-files/metadata/text.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<guide self="ebuild-writing/misc-files/metadata/">
<chapter>
-<title>Package and Category <c>metadata.xml</c></title>
+<title>Package and category <c>metadata.xml</c></title>
<body>
<p>
@@ -351,7 +351,7 @@ There are also some attributes that can be used with these tags:
</body>
</section>
<section>
-<title>Package Metadata</title>
+<title>Package metadata</title>
<body>
<p>
All packages <b>must</b> include a <c>metadata.xml</c> file which
@@ -381,7 +381,7 @@ GLEP 67</uri>.
</body>
<subsection>
-<title>Package Metadata Examples</title>
+<title>Package metadata examples</title>
<body>
<p>
@@ -393,7 +393,7 @@ these files verbatim and should be taken as hypothetical examples.
</body>
<subsubsection>
-<title>Projects as Maintainers</title>
+<title>Projects as maintainers</title>
<body>
<p>
@@ -458,7 +458,7 @@ projects listing</uri> available on the Gentoo Wiki:
</body>
</subsubsection>
<subsubsection>
-<title>Local USE Flag Descriptions</title>
+<title>Local USE flag descriptions</title>
<body>
<p>
@@ -505,7 +505,7 @@ as opposed to a URL. Conversely, email addresses specified in the
</body>
</subsubsection>
<subsubsection>
-<title>Split Maintainership</title>
+<title>Split maintainership</title>
<body>
<p>
@@ -574,7 +574,7 @@ is demonstrated.
</body>
</subsubsection>
<subsubsection>
-<title>Slots and Subslots</title>
+<title>Slots and subslots</title>
<body>
<p>
@@ -679,7 +679,7 @@ part of the QA reports.
</section>
<section>
-<title>Category Metadata</title>
+<title>Category metadata</title>
<body>
<p>
For categories, <c>metadata.xml</c> specifies a long description (in
diff --git a/ebuild-writing/misc-files/patches/text.xml b/ebuild-writing/misc-files/patches/text.xml
index 56ba94c..c71551b 100644
--- a/ebuild-writing/misc-files/patches/text.xml
+++ b/ebuild-writing/misc-files/patches/text.xml
@@ -54,7 +54,7 @@ up the tree too much.
</body>
<section>
-<title>Patch Descriptions</title>
+<title>Patch descriptions</title>
<body>
<p>
It is possible to include a description with a patch. This is often
@@ -172,7 +172,7 @@ allows them to be applied unconditionally.
</section>
<section>
-<title>Clean Patch Howto</title>
+<title>Clean patch guide</title>
<body>
<p>
@@ -199,7 +199,7 @@ assess a patch without searching through many other files.
</subsection>
<subsection>
-<title>File Naming</title>
+<title>File naming</title>
<body>
<p>
diff --git a/ebuild-writing/misc-files/text.xml b/ebuild-writing/misc-files/text.xml
index 3ea435c..3fe6026 100644
--- a/ebuild-writing/misc-files/text.xml
+++ b/ebuild-writing/misc-files/text.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<guide self="ebuild-writing/misc-files/">
<chapter>
-<title>Miscellaneous Files</title>
+<title>Miscellaneous files</title>
<body>
<p>
diff --git a/ebuild-writing/text.xml b/ebuild-writing/text.xml
index 0be139b..0817a04 100644
--- a/ebuild-writing/text.xml
+++ b/ebuild-writing/text.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<guide self="ebuild-writing/">
<chapter>
-<title>Ebuild Writing</title>
+<title>Ebuild writing</title>
<body>
<p>
diff --git a/ebuild-writing/use-conditional-code/text.xml b/ebuild-writing/use-conditional-code/text.xml
index 655bbaa..57ea99a 100644
--- a/ebuild-writing/use-conditional-code/text.xml
+++ b/ebuild-writing/use-conditional-code/text.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<guide self="ebuild-writing/use-conditional-code/">
<chapter>
-<title>USE Flag Conditional Code</title>
+<title>USE flag conditional code</title>
<body>
<p>
diff --git a/ebuild-writing/user-submitted/text.xml b/ebuild-writing/user-submitted/text.xml
index 58a372d..15576fb 100644
--- a/ebuild-writing/user-submitted/text.xml
+++ b/ebuild-writing/user-submitted/text.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<guide self="ebuild-writing/user-submitted/">
<chapter>
-<title>User-submitted Ebuilds</title>
+<title>User-submitted ebuilds</title>
<body>
diff --git a/ebuild-writing/users-and-groups/text.xml b/ebuild-writing/users-and-groups/text.xml
index 80f9b5b..679d028 100644
--- a/ebuild-writing/users-and-groups/text.xml
+++ b/ebuild-writing/users-and-groups/text.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<guide self="ebuild-writing/users-and-groups/">
<chapter>
-<title>Users and Groups</title>
+<title>Users and groups</title>
<body>
<p>
diff --git a/ebuild-writing/using-eclasses/text.xml b/ebuild-writing/using-eclasses/text.xml
index db41d25..7fa2c7b 100644
--- a/ebuild-writing/using-eclasses/text.xml
+++ b/ebuild-writing/using-eclasses/text.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<guide self="ebuild-writing/using-eclasses/">
<chapter>
-<title>Using Eclasses</title>
+<title>Using eclasses</title>
<body>
<p>
@@ -14,7 +14,7 @@ how to use an eclass which has already been written.
</body>
<section>
-<title>The <c>inherit</c> Function</title>
+<title>The <c>inherit</c> function</title>
<body>
<p>
diff --git a/ebuild-writing/variables/text.xml b/ebuild-writing/variables/text.xml
index 67c9887..6b8565b 100644
--- a/ebuild-writing/variables/text.xml
+++ b/ebuild-writing/variables/text.xml
@@ -12,7 +12,7 @@ which are of use throughout the ebuild.
</body>
<section>
-<title>Predefined Read-Only Variables</title>
+<title>Predefined read-only variables</title>
<body>
<p>
@@ -238,7 +238,7 @@ pkg_postinst() {
</section>
<section>
-<title>Ebuild-defined Variables</title>
+<title>Ebuild-defined variables</title>
<body>
<p>
@@ -403,7 +403,7 @@ The following variables may or must be defined by every ebuild.
<title>SRC_URI</title>
<subsubsection>
-<title>Conditional Sources</title>
+<title>Conditional sources</title>
<body>
<p>
@@ -424,7 +424,7 @@ SRC_URI="https://example.com/files/${P}-core.tar.bz2
</subsubsection>
<subsubsection>
-<title>Renaming Sources</title>
+<title>Renaming sources</title>
<body>
<p>
@@ -756,7 +756,7 @@ strings (ignoring case):
</section>
<section>
-<title>Version and Name Formatting Issues</title>
+<title>Version and name formatting issues</title>
<body>
<p>
@@ -857,7 +857,7 @@ here</uri>, courtesy of Gentoo developer mgorny.
</section>
<section>
-<title>Trailing Slashes in Variables</title>
+<title>Trailing slashes in variables</title>
<body>
<p>